summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-04-16 19:15:10 +0000
committerPacho Ramos <pacho@gentoo.org>2013-04-16 19:15:10 +0000
commitc1a192adbeaae400f1b847fb59a98658ddc64357 (patch)
treecf8dc4696976ff29adb8b53523f77369e236233f /dev-util/anjuta
parentStable for arm, wrt bug #466002 (diff)
downloadgentoo-2-c1a192adbeaae400f1b847fb59a98658ddc64357.tar.gz
gentoo-2-c1a192adbeaae400f1b847fb59a98658ddc64357.tar.bz2
gentoo-2-c1a192adbeaae400f1b847fb59a98658ddc64357.zip
Version bump, drop old
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-util/anjuta')
-rw-r--r--dev-util/anjuta/ChangeLog9
-rw-r--r--dev-util/anjuta/anjuta-3.8.1.ebuild (renamed from dev-util/anjuta/anjuta-3.8.0.ebuild)61
-rw-r--r--dev-util/anjuta/files/anjuta-3.8.1-vala-0.20.patch23
3 files changed, 67 insertions, 26 deletions
diff --git a/dev-util/anjuta/ChangeLog b/dev-util/anjuta/ChangeLog
index 84143532e7a3..635d1d5dda0c 100644
--- a/dev-util/anjuta/ChangeLog
+++ b/dev-util/anjuta/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/anjuta
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/anjuta/ChangeLog,v 1.159 2013/04/14 16:19:51 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/anjuta/ChangeLog,v 1.160 2013/04/16 19:15:10 pacho Exp $
+
+*anjuta-3.8.1 (16 Apr 2013)
+
+ 16 Apr 2013; Pacho Ramos <pacho@gentoo.org> +anjuta-3.8.1.ebuild,
+ +files/anjuta-3.8.1-vala-0.20.patch, -anjuta-3.8.0.ebuild,
+ anjuta-3.6.2-r1.ebuild:
+ Version bump, drop old
14 Apr 2013; Agostino Sarubbo <ago@gentoo.org> anjuta-3.6.2-r1.ebuild:
Stable for ppc, wrt bug #463660
diff --git a/dev-util/anjuta/anjuta-3.8.0.ebuild b/dev-util/anjuta/anjuta-3.8.1.ebuild
index c02ffa993bef..d5345daa0d6d 100644
--- a/dev-util/anjuta/anjuta-3.8.0.ebuild
+++ b/dev-util/anjuta/anjuta-3.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/anjuta/anjuta-3.8.0.ebuild,v 1.1 2013/03/28 17:00:13 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/anjuta/anjuta-3.8.1.ebuild,v 1.1 2013/04/16 19:15:10 pacho Exp $
EAPI="5"
GCONF_DEBUG="yes"
@@ -8,10 +8,10 @@ GNOME2_LA_PUNT="yes"
PYTHON_COMPAT=( python{2_6,2_7} )
# libanjuta-language-vala.so links to a specific slot of libvala; we want to
# avoid automagic behavior.
-VALA_MIN_API_VERSION="0.18"
+VALA_MIN_API_VERSION="0.20"
VALA_MAX_API_VERSION="${VALA_MIN_API_VERSION}"
-inherit eutils gnome2 flag-o-matic multilib python-single-r1 vala
+inherit autotools eutils gnome2 flag-o-matic multilib readme.gentoo python-single-r1 vala
DESCRIPTION="A versatile IDE for GNOME"
HOMEPAGE="http://www.anjuta.org"
@@ -22,7 +22,8 @@ KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
IUSE="debug devhelp glade +introspection packagekit subversion test vala"
# FIXME: make python dependency non-automagic
-COMMON_DEPEND=">=dev-libs/glib-2.32:2
+COMMON_DEPEND="
+ >=dev-libs/glib-2.32:2
x11-libs/gdk-pixbuf:2
>=x11-libs/gtk+-3.4:3
>=x11-libs/vte-0.27.6:2.90
@@ -70,27 +71,26 @@ DEPEND="${COMMON_DEPEND}
dev-libs/gobject-introspection-common
gnome-base/gnome-common
"
-# eautoreconf requires: gtk-doc-am, gnome-common, gobject-introspection-common, yelp-tools
+# eautoreconf requires: gnome-common, gobject-introspection-common, yelp-tools
pkg_setup() {
python-single-r1_pkg_setup
}
src_prepare() {
+ if use vala; then
+ DISABLE_AUTOFORMATTING="yes"
+ DOC_CONTENTS="To create a generic vala project you will need to specify
+desired valac versioned binary to be used, to do that you
+will need to:
+1. Go to 'Build' -> 'Configure project'
+2. Add 'VALAC=/usr/bin/valac-X.XX' (respecting quotes) to
+'Configure options'."
+ fi
+
# COPYING is used in Anjuta's help/about entry
DOCS="AUTHORS ChangeLog COPYING FUTURE MAINTAINERS NEWS README ROADMAP THANKS TODO"
- G2CONF="${G2CONF}
- --disable-static
- --docdir=/usr/share/doc/${PF}
- $(use_enable debug)
- $(use_enable devhelp plugin-devhelp)
- $(use_enable glade plugin-glade)
- $(use_enable introspection)
- $(use_enable packagekit)
- $(use_enable subversion plugin-subversion)
- $(use_enable vala)"
-
# Conflicts with -pg in a plugin, bug #266777
filter-flags -fomit-frame-pointer
@@ -98,10 +98,27 @@ src_prepare() {
sed -e 's:$PYTHON-config:$PYTHON$PYTHON_VERSION-config:g' \
-i plugins/am-project/tests/anjuta.lst || die "sed failed"
+ # Let it build with vala-0.20, upstream bug #698158
+ epatch "${FILESDIR}/${PN}-3.8.1-vala-0.20.patch"
+
+ eautoreconf
use vala && vala_src_prepare
gnome2_src_prepare
}
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable debug) \
+ $(use_enable devhelp plugin-devhelp) \
+ $(use_enable glade plugin-glade) \
+ $(use_enable introspection) \
+ $(use_enable packagekit) \
+ $(use_enable subversion plugin-subversion) \
+ $(use_enable vala)
+}
+
src_install() {
# COPYING is used in Anjuta's help/about entry
docompress -x "/usr/share/doc/${PF}/COPYING"
@@ -109,17 +126,11 @@ src_install() {
# Anjuta uses a custom rule to install DOCS, get rid of it
gnome2_src_install
rm -rf "${ED}"/usr/share/doc/${PN} || die "rm failed"
+
+ use vala && readme.gentoo_create_doc
}
pkg_postinst() {
gnome2_pkg_postinst
- if use vala; then
- elog ""
- elog "To create a generic vala project you will need to specify"
- elog "desired valac versioned binary to be used, to do that you"
- elog "will need to:"
- elog "1. Go to 'Build' -> 'Configure project'"
- elog "2. Add 'VALAC=/usr/bin/valac-X.XX' (respecting quotes) to"
- elog "'Configure options'."
- fi
+ use vala && readme.gentoo_print_elog
}
diff --git a/dev-util/anjuta/files/anjuta-3.8.1-vala-0.20.patch b/dev-util/anjuta/files/anjuta-3.8.1-vala-0.20.patch
new file mode 100644
index 000000000000..8e66c810886c
--- /dev/null
+++ b/dev-util/anjuta/files/anjuta-3.8.1-vala-0.20.patch
@@ -0,0 +1,23 @@
+diff -uNr anjuta-3.8.0.old/configure.ac anjuta-3.8.0/configure.ac
+--- anjuta-3.8.0.old/configure.ac 2013-03-25 05:32:20.000000000 +0100
++++ anjuta-3.8.0/configure.ac 2013-03-30 21:56:06.603174301 +0100
+@@ -285,11 +285,14 @@
+ else
+ AC_MSG_RESULT(no)
+ AC_MSG_CHECKING(if libvala is available)
+- PKG_CHECK_EXISTS([ libvala-0.18 ],
+- [ valaver="-0.18" ],
+- [ PKG_CHECK_EXISTS([ libvala-0.16 ],
+- [ valaver="-0.16" ],
+- [ valaver="" ])
++ PKG_CHECK_EXISTS([ libvala-0.20 ],
++ [ valaver="-0.20" ],
++ [ PKG_CHECK_EXISTS([ libvala-0.18 ],
++ [ valaver="-0.18" ],
++ [ PKG_CHECK_EXISTS([ libvala-0.16 ],
++ [ valaver="-0.16" ],
++ [ valaver="" ])
++ ])
+ ])
+ if test "x$valaver" != "x"; then
+ AC_MSG_RESULT(yes)