summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-09-08 18:33:05 +0000
committerMamoru Komachi <usata@gentoo.org>2004-09-08 18:33:05 +0000
commit176e8889f817d2cf4a266e5a80e39c7db042fc28 (patch)
tree62ea4a6e1080e28cd835bc26858d71741738c72f /dev-tex/ha-prosper/ha-prosper-4.21.ebuild
parentInitial import. (Manifest recommit) (diff)
downloadgentoo-2-176e8889f817d2cf4a266e5a80e39c7db042fc28.tar.gz
gentoo-2-176e8889f817d2cf4a266e5a80e39c7db042fc28.tar.bz2
gentoo-2-176e8889f817d2cf4a266e5a80e39c7db042fc28.zip
Initial import. Ebuild submitted by Adam Piatyszek <ediap@et.put.poznan.pl>, closing bug #63151.
Diffstat (limited to 'dev-tex/ha-prosper/ha-prosper-4.21.ebuild')
-rw-r--r--dev-tex/ha-prosper/ha-prosper-4.21.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-tex/ha-prosper/ha-prosper-4.21.ebuild b/dev-tex/ha-prosper/ha-prosper-4.21.ebuild
new file mode 100644
index 000000000000..e5d5b399005c
--- /dev/null
+++ b/dev-tex/ha-prosper/ha-prosper-4.21.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/ha-prosper/ha-prosper-4.21.ebuild,v 1.1 2004/09/08 18:33:05 usata Exp $
+
+inherit latex-package
+
+DESCRIPTION="HA-prosper is a LaTeX class for writing transparencies"
+HOMEPAGE="http://stuwww.uvt.nl/~hendri/Downloads/haprosper.html"
+# Taken from: ftp://ftp.dante.de/tex-archive/macros/latex/contrib/${PN}.tar.gz
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+LICENSE="LPPL-1.2"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND="virtual/tetex
+ >=dev-tex/prosper-1.5
+ dev-tex/xkeyval"
+S=${WORKDIR}/${PN}
+IUSE=""
+
+src_install(){
+ cd ${S}/Run
+ insinto ${TEXMF}/tex/latex/${PN}/
+ doins *.sty *.cfg
+ dodir ${TEXMF}/tex/latex/${PN}/Styles
+ for i in `find ./Styles/* -maxdepth 1 -type d`
+ do
+ dodir ${TEXMF}/tex/latex/${PN}/$i
+ insinto ${TEXMF}/tex/latex/${PN}/$i/
+ doins $i/*
+ done
+ cd ${S}
+ dodoc README
+ dodoc Doc/*.tex Doc/*.tex
+}