summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-10-27 21:54:21 +0000
committerUlrich Müller <ulm@gentoo.org>2010-10-27 21:54:21 +0000
commitc5dadcd278e3f0e72966e6ed88dbba057b523eed (patch)
tree9a33c80b61a9d32422885daf5ce87f7128b2a92d /dev-tex/catdvi
parentVersion bump. Update usage of gnome APIs. (diff)
downloadgentoo-2-c5dadcd278e3f0e72966e6ed88dbba057b523eed.tar.gz
gentoo-2-c5dadcd278e3f0e72966e6ed88dbba057b523eed.tar.bz2
gentoo-2-c5dadcd278e3f0e72966e6ed88dbba057b523eed.zip
Fix compilation with kpathsea-6 library, bug 342817.
(Portage version: 2.1.9.21/cvs/Linux x86_64)
Diffstat (limited to 'dev-tex/catdvi')
-rw-r--r--dev-tex/catdvi/ChangeLog11
-rw-r--r--dev-tex/catdvi/catdvi-0.14-r1.ebuild35
-rw-r--r--dev-tex/catdvi/files/catdvi-0.14-kpathsea.patch12
3 files changed, 56 insertions, 2 deletions
diff --git a/dev-tex/catdvi/ChangeLog b/dev-tex/catdvi/ChangeLog
index 5c562af9ec53..1b00d0d74fe0 100644
--- a/dev-tex/catdvi/ChangeLog
+++ b/dev-tex/catdvi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-tex/catdvi
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/catdvi/ChangeLog,v 1.5 2008/09/17 07:29:18 ulm Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/catdvi/ChangeLog,v 1.6 2010/10/27 21:54:21 ulm Exp $
+
+*catdvi-0.14-r1 (26 Oct 2010)
+
+ 26 Oct 2010; Ulrich Mueller <ulm@gentoo.org> +catdvi-0.14-r1.ebuild,
+ +files/catdvi-0.14-kpathsea.patch:
+ Fix compilation with kpathsea-6 library, bug 342817. Thanks to Martin Väth
+ <vaeth@mathematik.uni-wuerzburg.de>.
17 Sep 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add package to tex herd.
diff --git a/dev-tex/catdvi/catdvi-0.14-r1.ebuild b/dev-tex/catdvi/catdvi-0.14-r1.ebuild
new file mode 100644
index 000000000000..d0ef3d05a63c
--- /dev/null
+++ b/dev-tex/catdvi/catdvi-0.14-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/catdvi/catdvi-0.14-r1.ebuild,v 1.1 2010/10/27 21:54:21 ulm Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="DVI to plain text translator"
+HOMEPAGE="http://catdvi.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/tex-base"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-kpathsea.patch"
+}
+
+src_compile() {
+ # Do not use plain emake here, because make tests
+ # may cache fonts and generate sandbox violations.
+ emake catdvi CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ dobin catdvi || die
+ doman catdvi.1 || die
+ dodoc AUTHORS ChangeLog NEWS README TODO || die
+}
diff --git a/dev-tex/catdvi/files/catdvi-0.14-kpathsea.patch b/dev-tex/catdvi/files/catdvi-0.14-kpathsea.patch
new file mode 100644
index 000000000000..c94e6d4aef95
--- /dev/null
+++ b/dev-tex/catdvi/files/catdvi-0.14-kpathsea.patch
@@ -0,0 +1,12 @@
+http://bugs.gentoo.org/342817
+
+--- catdvi-0.14-orig/kpathsea.c
++++ catdvi-0.14/kpathsea.c
+@@ -36,7 +36,6 @@
+
+ void version_findtfm(void)
+ {
+- extern char * kpathsea_version_string;
+ puts(kpathsea_version_string);
+ }
+