summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-03-05 11:43:28 +0000
committerJustin Lecher <jlec@gentoo.org>2013-03-05 11:43:28 +0000
commitde898516142c215584dec8c18bc62e28ab8f7603 (patch)
tree1edfc98290c72bd4eec8eb1670c291adaded0001 /dev-tcltk
parentRemoved older ebuilds (diff)
downloadgentoo-2-de898516142c215584dec8c18bc62e28ab8f7603.tar.gz
gentoo-2-de898516142c215584dec8c18bc62e28ab8f7603.tar.bz2
gentoo-2-de898516142c215584dec8c18bc62e28ab8f7603.zip
dev-tcltk/tcllib: Add backports for test failures and manpage collision
(Portage version: 2.2.0_alpha165/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tcllib/ChangeLog7
-rw-r--r--dev-tcltk/tcllib/tcllib-1.15-r1.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-tcltk/tcllib/ChangeLog b/dev-tcltk/tcllib/ChangeLog
index d36748fe64eb..0c7f65f8313b 100644
--- a/dev-tcltk/tcllib/ChangeLog
+++ b/dev-tcltk/tcllib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tcltk/tcllib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tcllib/ChangeLog,v 1.37 2013/03/04 08:02:40 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tcllib/ChangeLog,v 1.38 2013/03/05 11:43:28 jlec Exp $
+
+*tcllib-1.15-r1 (05 Mar 2013)
+
+ 05 Mar 2013; Justin Lecher <jlec@gentoo.org> +tcllib-1.15-r1.ebuild:
+ Add backports for test failures and manpage collision
04 Mar 2013; Justin Lecher <jlec@gentoo.org> tcllib-1.15.ebuild:
Clean collision fix
diff --git a/dev-tcltk/tcllib/tcllib-1.15-r1.ebuild b/dev-tcltk/tcllib/tcllib-1.15-r1.ebuild
new file mode 100644
index 000000000000..8d5d8a3e502c
--- /dev/null
+++ b/dev-tcltk/tcllib/tcllib-1.15-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tcllib/tcllib-1.15-r1.ebuild,v 1.1 2013/03/05 11:43:28 jlec Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Tcl Standard Library"
+HOMEPAGE="http://www.tcl.tk/software/tcllib/"
+SRC_URI="
+ http://dev.gentoo.org/~jlec/distfiles/${P}-manpage-rename.patch.xz
+ http://dev.gentoo.org/~jlec/distfiles/${P}-test.patch.xz
+ mirror://sourceforge/tcllib/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="examples"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~s390 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos"
+
+RDEPEND="dev-lang/tcl"
+DEPEND="${RDEPEND}"
+
+DOCS=( DESCRIPTION.txt STATUS )
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-tcl8.6-test.patch \
+ "${WORKDIR}"/${P}-test.patch \
+ "${WORKDIR}"/${P}-manpage-rename.patch
+}
+
+src_test() {
+# emake test_interactive
+ emake test_batch
+}
+
+src_install() {
+ default
+
+ dodoc devdoc/*.txt
+
+ dohtml devdoc/*.html
+ if use examples ; then
+ for f in $(find examples -type f); do
+ docinto $(dirname $f)
+ dodoc $f
+ done
+ fi
+}