summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-08-02 14:27:14 +0000
committerJustin Lecher <jlec@gentoo.org>2010-08-02 14:27:14 +0000
commit9f0c6457b4f2e3da881d3c0b6251fbcf38aaa5ab (patch)
treeae266dccce5d84f7cac2cfa4a6b3c9892fcb543d /dev-tcltk
parentPKGDIR is a symlink (#330097) and virtual and perl-core versions differ (#330... (diff)
downloadgentoo-2-9f0c6457b4f2e3da881d3c0b6251fbcf38aaa5ab.tar.gz
gentoo-2-9f0c6457b4f2e3da881d3c0b6251fbcf38aaa5ab.tar.bz2
gentoo-2-9f0c6457b4f2e3da881d3c0b6251fbcf38aaa5ab.zip
Unversioning the installation path
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tklib/ChangeLog7
-rw-r--r--dev-tcltk/tklib/tklib-0.5-r1.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-tcltk/tklib/ChangeLog b/dev-tcltk/tklib/ChangeLog
index 96f60b74ede7..25487eaff3a7 100644
--- a/dev-tcltk/tklib/ChangeLog
+++ b/dev-tcltk/tklib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tcltk/tklib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tklib/ChangeLog,v 1.1 2010/03/29 11:32:45 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tklib/ChangeLog,v 1.2 2010/08/02 14:27:14 jlec Exp $
+
+*tklib-0.5-r1 (02 Aug 2010)
+
+ 02 Aug 2010; Justin Lecher <jlec@gentoo.org> +tklib-0.5-r1.ebuild:
+ Unversioning the installation path
*tklib-0.5 (29 Mar 2010)
diff --git a/dev-tcltk/tklib/tklib-0.5-r1.ebuild b/dev-tcltk/tklib/tklib-0.5-r1.ebuild
new file mode 100644
index 000000000000..11febe145c09
--- /dev/null
+++ b/dev-tcltk/tklib/tklib-0.5-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tklib/tklib-0.5-r1.ebuild,v 1.1 2010/08/02 14:27:14 jlec Exp $
+
+inherit multilib
+
+DESCRIPTION="Collection of utility modules for Tk, and a companion to Tcllib"
+HOMEPAGE="http://www.tcl.tk/software/tklib"
+SRC_URI="mirror://sourceforge/project/tcllib/${PN}/${PV}/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD"
+IUSE="doc"
+
+RDEPEND="
+ dev-lang/tk
+ dev-tcltk/tcllib"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ if use doc; then
+ emake DESTDIR="${D}" doc || die
+ dohtml doc/html/* || die
+ fi
+ dodoc ChangeLog DESCRIPTION.txt README* || die
+ dosym ${PN}${PV} /usr/$(get_libdir)/${PN}
+}