summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-04-05 20:16:17 +0000
committerJustin Lecher <jlec@gentoo.org>2010-04-05 20:16:17 +0000
commit140afc81aaa9adeaf7b18e9431a41584414a5fb8 (patch)
treedc22042d0d285d176ea92f469324908d0b020352 /dev-tcltk
parentamd64 stable wrt #310385 (diff)
downloadgentoo-2-140afc81aaa9adeaf7b18e9431a41584414a5fb8.tar.gz
gentoo-2-140afc81aaa9adeaf7b18e9431a41584414a5fb8.tar.bz2
gentoo-2-140afc81aaa9adeaf7b18e9431a41584414a5fb8.zip
Underlinking fixed, all src files get compiled, #313255
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tclpython/ChangeLog6
-rw-r--r--dev-tcltk/tclpython/tclpython-3.1-r1.ebuild19
-rw-r--r--dev-tcltk/tclpython/tclpython-4.1-r2.ebuild19
3 files changed, 28 insertions, 16 deletions
diff --git a/dev-tcltk/tclpython/ChangeLog b/dev-tcltk/tclpython/ChangeLog
index 80f745d614a7..9a8c2537725b 100644
--- a/dev-tcltk/tclpython/ChangeLog
+++ b/dev-tcltk/tclpython/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-tcltk/tclpython
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclpython/ChangeLog,v 1.10 2010/03/31 21:03:25 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclpython/ChangeLog,v 1.11 2010/04/05 20:16:17 jlec Exp $
+
+ 05 Apr 2010; Justin Lecher <jlec@gentoo.org> tclpython-3.1-r1.ebuild,
+ tclpython-4.1-r2.ebuild:
+ Underlinking fixed, all src files get compiled, #313255
*tclpython-4.1-r2 (31 Mar 2010)
*tclpython-3.1-r1 (31 Mar 2010)
diff --git a/dev-tcltk/tclpython/tclpython-3.1-r1.ebuild b/dev-tcltk/tclpython/tclpython-3.1-r1.ebuild
index 5e77c4070c6c..ec598446c9a7 100644
--- a/dev-tcltk/tclpython/tclpython-3.1-r1.ebuild
+++ b/dev-tcltk/tclpython/tclpython-3.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclpython/tclpython-3.1-r1.ebuild,v 1.1 2010/03/31 21:03:25 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclpython/tclpython-3.1-r1.ebuild,v 1.2 2010/04/05 20:16:17 jlec Exp $
PYTHON_DEPEND="2"
@@ -18,13 +18,18 @@ IUSE=""
DEPEND=">=dev-lang/tcl-8.4"
src_compile() {
- einfo \
- "$(tc-getCC) -shared ${LDFLAGS} -fPIC ${CFLAGS} -o tclpython.so.${PV} \
- -I$(python_get_includedir) tclpython.c -lpthread -lutil"
+ cfile="tclpython"
+ for src in ${cfile}; do
+ compile="$(tc-getCC) -shared -fPIC ${CFLAGS} -I$(python_get_includedir) -c ${src}.c"
+ einfo "${compile}"
+ eval "${compile}" || die
+ done
- $(tc-getCC) -shared ${LDFLAGS} -fPIC ${CFLAGS} -o tclpython.so.${PV} \
- -I$(python_get_includedir) tclpython.c -lpthread -lutil \
- || die
+ link="$(tc-getCC) -fPIC -shared ${LDFLAGS} -o tclpython.so.${PV} tclpython.o -lpthread -lutil $(python_get_library -l) -ltcl"
+
+ einfo "${link}"
+
+ eval "${link}" || die
}
src_install() {
diff --git a/dev-tcltk/tclpython/tclpython-4.1-r2.ebuild b/dev-tcltk/tclpython/tclpython-4.1-r2.ebuild
index 28c745a57df9..e726cf25dc8c 100644
--- a/dev-tcltk/tclpython/tclpython-4.1-r2.ebuild
+++ b/dev-tcltk/tclpython/tclpython-4.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclpython/tclpython-4.1-r2.ebuild,v 1.1 2010/03/31 21:03:25 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclpython/tclpython-4.1-r2.ebuild,v 1.2 2010/04/05 20:16:17 jlec Exp $
PYTHON_DEPEND="2"
@@ -18,13 +18,16 @@ IUSE=""
DEPEND=">=dev-lang/tcl-8.4"
src_compile() {
- einfo \
- "$(tc-getCC) -shared ${LDFLAGS} -fPIC ${CFLAGS} -o tclpython.so.${PV} \
- -I$(python_get_includedir) tclpython.c -lpthread -lutil"
-
- $(tc-getCC) -shared ${LDFLAGS} -fPIC ${CFLAGS} -o tclpython.so.${PV} \
- -I$(python_get_includedir) tclpython.c -lpthread -lutil \
- || die
+ cfile="tclpython tclthread"
+ for src in ${cfile}; do
+ compile="$(tc-getCC) -shared -fPIC ${CFLAGS} -I$(python_get_includedir) -c ${src}.c"
+ einfo "${compile}"
+ eval "${compile}" || die
+ done
+
+ link="$(tc-getCC) -fPIC -shared ${LDFLAGS} -o tclpython.so.${PV} tclpython.o tclthread.o -lpthread -lutil $(python_get_library -l) -ltcl"
+ einfo "${link}"
+ eval "${link}" || die
}
src_install() {