summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-10-27 14:22:43 +0000
committerJustin Lecher <jlec@gentoo.org>2014-10-27 14:22:43 +0000
commit02c0e60d77b6dedd2d7cefe3e7af4c3d505ad291 (patch)
treef43db81e72774c3945bceb4175428f31a2f68620 /dev-tcltk
parentStable for x86, wrt bug #526502 (diff)
downloadgentoo-2-02c0e60d77b6dedd2d7cefe3e7af4c3d505ad291.tar.gz
gentoo-2-02c0e60d77b6dedd2d7cefe3e7af4c3d505ad291.tar.bz2
gentoo-2-02c0e60d77b6dedd2d7cefe3e7af4c3d505ad291.zip
dev-tcltk/tclpython: Add missing patch, #509738; thanks Alexander Turenko for the backport
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tclpython/ChangeLog8
-rw-r--r--dev-tcltk/tclpython/files/tclpython-4.1-python-3.patch229
-rw-r--r--dev-tcltk/tclpython/tclpython-4.1-r4.ebuild (renamed from dev-tcltk/tclpython/tclpython-4.1-r3.ebuild)12
3 files changed, 246 insertions, 3 deletions
diff --git a/dev-tcltk/tclpython/ChangeLog b/dev-tcltk/tclpython/ChangeLog
index e2cdf764533e..c0a5c875ad46 100644
--- a/dev-tcltk/tclpython/ChangeLog
+++ b/dev-tcltk/tclpython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tcltk/tclpython
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclpython/ChangeLog,v 1.18 2014/10/26 18:45:17 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclpython/ChangeLog,v 1.19 2014/10/27 14:22:43 jlec Exp $
+
+*tclpython-4.1-r4 (27 Oct 2014)
+
+ 27 Oct 2014; Justin Lecher <jlec@gentoo.org> -tclpython-4.1-r3.ebuild,
+ +tclpython-4.1-r4.ebuild, +files/tclpython-4.1-python-3.patch:
+ Add missing patch, #509738; thanks Alexander Turenko for the backport
*tclpython-4.1-r3 (26 Oct 2014)
diff --git a/dev-tcltk/tclpython/files/tclpython-4.1-python-3.patch b/dev-tcltk/tclpython/files/tclpython-4.1-python-3.patch
new file mode 100644
index 000000000000..2a26f647c10e
--- /dev/null
+++ b/dev-tcltk/tclpython/files/tclpython-4.1-python-3.patch
@@ -0,0 +1,229 @@
+--- a/tclpython.c 2006-03-07 16:28:03.000000000 +0300
++++ b/tclpython.c 2014-05-06 23:33:41.713623943 +0400
+@@ -19,13 +19,83 @@
+ $ cc -fpic -I/usr/local/include/tcltk/tcl8.3 -c tclthread.c
+ $ ld -o tclpython.so -Bshareable -L/usr/X11R6/lib -L/usr/local/lib -L/usr/local/share/python/config tclpython.o tclthread.o -lpython -lutil -lreadline -ltermcap -lcrypt -lgmp -lgdbm -lpq -lz -ltcl83 -ltk83 -lX11
+
++Patched for Python 3 with respect to https://github.com/facebook/fbthrift/blob/master/thrift/lib/py/protocol/fastbinary.c
++
+ */
+
+ #include <Python.h>
+ #include <tcl.h>
+-#include <cStringIO.h>
++
++#if PY_MAJOR_VERSION >= 3
++ #define PyInt_FromLong PyLong_FromLong
++ #define PyInt_AsLong PyLong_AsLong
++ #define PyString_FromStringAndSize PyBytes_FromStringAndSize
++#else
++ #include <cStringIO.h>
++#endif
++
+ #include "tclpython.h"
+
++// Mostly copied from cStringIO.c
++#if PY_MAJOR_VERSION >= 3
++
++/** io module in python3. */
++static PyObject* Python3IO;
++
++typedef struct {
++ PyObject_HEAD
++ char *buf;
++ Py_ssize_t pos, string_size;
++} IOobject;
++
++#define IOOOBJECT(O) ((IOobject*)(O))
++
++static int
++IO__opencheck(IOobject *self) {
++ if (!self->buf) {
++ PyErr_SetString(PyExc_ValueError,
++ "I/O operation on closed file");
++ return 0;
++ }
++ return 1;
++}
++
++static PyObject *
++IO_cgetval(PyObject *self) {
++ if (!IO__opencheck(IOOOBJECT(self))) return NULL;
++ assert(IOOOBJECT(self)->pos >= 0);
++ return PyBytes_FromStringAndSize(((IOobject*)self)->buf,
++ ((IOobject*)self)->pos);
++}
++#endif
++
++/* -- PYTHON MODULE SETUP STUFF --- */
++
++static PyObject *pythonTclEvaluate(PyObject *self, PyObject *args);
++
++static PyMethodDef tclMethods[] = {
++ {"eval", pythonTclEvaluate, METH_VARARGS, "Evaluate a Tcl script."},
++ {0, 0, 0, 0} /* sentinel */
++};
++
++#if PY_MAJOR_VERSION >= 3
++struct module_state {
++ PyObject *error;
++};
++
++static struct PyModuleDef TclModuleDef = {
++ PyModuleDef_HEAD_INIT,
++ "tcl",
++ NULL,
++ sizeof(struct module_state),
++ tclMethods,
++ NULL,
++ NULL,
++ NULL,
++ NULL
++};
++#endif
++
+ #ifndef WIN32
+ /* George Petasis, 21 Feb 2006:
+ * The following check cannot be handled correctly
+@@ -66,13 +136,13 @@
+
+ static int pythonInterpreter(ClientData clientData, Tcl_Interp *interpreter, int numberOfArguments, Tcl_Obj * CONST arguments[])
+ {
+- int identifier;
++ intptr_t identifier;
+ PyObject *output;
+ PyObject *message;
+ PyObject *result;
+ PyObject *globals;
+ char *string = 0;
+- int length;
++ Py_ssize_t length;
+ Tcl_Obj *object;
+ struct Tcl_HashEntry *entry;
+ unsigned evaluate;
+@@ -111,12 +181,22 @@
+ /* choose start token depending on whether this is an evaluation or an execution: */
+ result = PyRun_String(Tcl_GetString(arguments[2]), (evaluate? Py_eval_input: Py_file_input), globals, globals);
+ if (result == 0) { /* an error occured */
++#if PY_MAJOR_VERSION >= 3
++ output = PyObject_CallMethod(Python3IO, "BytesIO", "()");
++#else
+ output = PycStringIO->NewOutput(1024); /* use a reasonable initial size but big enough to handle most cases */
+- PySys_SetObject("stderr", output); /* capture all interpreter error output */
++#endif
++ PySys_SetObject("sys.stderr", output); /* capture all interpreter error output */
+ PyErr_Print(); /* so that error is printed on standard error, redirected above */
++#if PY_MAJOR_VERSION >= 3
++ message = IO_cgetval(output);
++ string = PyBytes_AsString(message);
++ length = (string == NULL) ? 0 : strlen(string);
++#else
+ message = PycStringIO->cgetvalue(output);
+ string = PyString_AsString(message);
+ length = PyString_Size(message);
++#endif
+ if ((length > 0) && (string[length - 1] == '\n')) length--; /* eventually remove trailing new line character */
+ object = Tcl_NewObj();
+ Tcl_AppendStringsToObj(object, Tcl_GetString(arguments[0]), ": ", 0); /* identify interpreter in error */
+@@ -124,7 +204,11 @@
+ Py_DECREF(output);
+ } else {
+ if (evaluate) {
++#if PY_MAJOR_VERSION >= 3
++ string = PyUnicode_AsUTF8(PyObject_Str(result));
++#else
+ string = PyString_AsString(PyObject_Str(result));
++#endif
+ object = Tcl_NewStringObj(string, -1); /* return evaluation result */
+ } else /* execute */
+ object = Tcl_NewObj(); /* always return an empty result or an error */
+@@ -139,9 +223,9 @@
+
+ Tcl_Interp *tclInterpreter(CONST char *name) /* public function for use in extensions to this extension */
+ {
+- int identifier;
++ intptr_t identifier;
+
+- if ((sscanf(name, "tcl%u", &identifier) == 0) || (identifier != 0)) {
++ if ((sscanf(name, "tcl%lu", &identifier) == 0) || (identifier != 0)) {
+ return 0; /* invalid name */
+ } else {
+ return mainInterpreter; /* sole available interpreter */
+@@ -188,14 +272,9 @@
+ return Py_BuildValue("s", result);
+ }
+
+-static PyMethodDef tclMethods[] = {
+- {"eval", pythonTclEvaluate, METH_VARARGS, "Evaluate a Tcl script."},
+- {0, 0, 0, 0} /* sentinel */
+-};
+-
+ static int newInterpreter(Tcl_Interp *interpreter)
+ {
+- int identifier;
++ intptr_t identifier;
+ Tcl_Obj *object;
+ int created;
+ #ifdef WITH_THREAD
+@@ -214,19 +293,31 @@
+ return TCL_ERROR;
+ } else {
+ Py_Initialize(); /* initialize main interpreter */
++#if PY_MAJOR_VERSION >= 3
++ Python3IO = PyImport_ImportModule("io");
++#else
+ PycString_IMPORT;
++#endif
+ }
+ Tcl_SetHashValue(Tcl_CreateHashEntry(&threadStates, (ClientData)identifier, &created), 0);
+ #else
+ if (existingInterpreters == 0) {
+ Py_Initialize(); /* initialize main interpreter */
+ PyEval_InitThreads(); /* initialize and acquire the global interpreter lock */
++#if PY_MAJOR_VERSION >= 3
++ Python3IO = PyImport_ImportModule("io");
++#else
+ PycString_IMPORT;
++#endif
+ globalState = PyThreadState_Swap(0); /* save the global thread */
+ } else {
+ PyEval_AcquireLock(); /* needed in order to be able to create a new interpreter */
+ }
++#if PY_MAJOR_VERSION >= 3
++ if (Python3IO == 0) { /* make sure string input/output is properly initialized */
++#else
+ if (PycStringIO == 0) { /* make sure string input/output is properly initialized */
++#endif
+ Tcl_SetResult(interpreter, "fatal error: could not initialize Python string input/output module", TCL_STATIC);
+ return TCL_ERROR;
+ }
+@@ -250,7 +341,11 @@
+ newIdentifier++;
+ #endif
+ existingInterpreters++;
++#if PY_MAJOR_VERSION >= 3
++ tcl = PyModule_Create(&TclModuleDef);
++#else
+ tcl = Py_InitModule("tcl", tclMethods); /* add a new 'tcl' module to the python interpreter */
++#endif
+ Py_INCREF(tcl);
+ PyModule_AddObject(PyImport_AddModule("__builtin__"), "tcl", tcl);
+ return TCL_OK;
+@@ -260,7 +355,7 @@
+ {
+ int index;
+ char *name;
+- int identifier;
++ intptr_t identifier;
+ struct Tcl_HashEntry *entry;
+ Tcl_Obj *object;
+ #ifdef WITH_THREAD
+@@ -270,7 +365,7 @@
+ for (index = 0; index < numberOfArguments; index++) {
+ name = Tcl_GetString(arguments[index]); /* interpreter name is "pythonN" */
+ entry = 0;
+- if (sscanf(name, "python%u", &identifier) == 1) {
++ if (sscanf(name, "python%lu", &identifier) == 1) {
+ identifier = atoi(name + 6);
+ entry = Tcl_FindHashEntry(&threadStates, (ClientData)identifier);
+ }
diff --git a/dev-tcltk/tclpython/tclpython-4.1-r3.ebuild b/dev-tcltk/tclpython/tclpython-4.1-r4.ebuild
index 2007324646af..63ef9a4d1bb2 100644
--- a/dev-tcltk/tclpython/tclpython-4.1-r3.ebuild
+++ b/dev-tcltk/tclpython/tclpython-4.1-r4.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclpython/tclpython-4.1-r3.ebuild,v 1.1 2014/10/26 18:45:17 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclpython/tclpython-4.1-r4.ebuild,v 1.1 2014/10/27 14:22:43 jlec Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-inherit multilib python-single-r1 toolchain-funcs
+inherit eutils multilib python-single-r1 toolchain-funcs
DESCRIPTION="Python package for Tcl"
HOMEPAGE="http://jfontain.free.fr/tclpython.htm"
@@ -23,6 +23,14 @@ DEPEND="${PYTHON_DEPS}
dev-lang/tcl"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${P}-python-3.patch
+)
+
+src_prepare() {
+ epatch ${PATCHES[@]}
+}
+
src_compile() {
local cfile="tclpython tclthread"
for src in ${cfile}; do