summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2007-12-16 13:01:23 +0000
committerMarijn Schouten <hkbst@gentoo.org>2007-12-16 13:01:23 +0000
commitbdcabce1682454d66469ed99923bb783d73e14fe (patch)
tree9b7d5302a7015317947c2e6bfbb027db55101ed6 /dev-scheme/gambit
parentbump (diff)
downloadgentoo-2-bdcabce1682454d66469ed99923bb783d73e14fe.tar.gz
gentoo-2-bdcabce1682454d66469ed99923bb783d73e14fe.tar.bz2
gentoo-2-bdcabce1682454d66469ed99923bb783d73e14fe.zip
bump
(Portage version: 2.1.4_rc10)
Diffstat (limited to 'dev-scheme/gambit')
-rw-r--r--dev-scheme/gambit/ChangeLog19
-rw-r--r--dev-scheme/gambit/files/digest-gambit-4.1.13
-rw-r--r--dev-scheme/gambit/gambit-4.1.1.ebuild107
3 files changed, 127 insertions, 2 deletions
diff --git a/dev-scheme/gambit/ChangeLog b/dev-scheme/gambit/ChangeLog
index d357d4b0bc1b..ec0b69e96e81 100644
--- a/dev-scheme/gambit/ChangeLog
+++ b/dev-scheme/gambit/ChangeLog
@@ -1,11 +1,26 @@
# ChangeLog for dev-scheme/gambit
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/ChangeLog,v 1.14 2007/11/18 18:29:34 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/ChangeLog,v 1.15 2007/12/16 13:01:23 hkbst Exp $
+
+*gambit-4.1.1 (16 Dec 2007)
+
+ 16 Dec 2007; Marijn Schouten <hkBst@gentoo.org> +gambit-4.1.1.ebuild:
+ Changes:
+ Some of the REPL's debugging functionality is now available as
+ procedures (e.g. display-continuation-backtrace and display-
+ exception). These can be used to implement specialized debuggers or
+ error catchers.
+
+ Two new REPL commands have been added to inspect the environment of
+ closures (the command ",(e <closure>)") and to start a REPL in the
+ environment of a closure or continuation (the command ",(v <closure-or-
+ continuation>)").
*gambit-4.1.0 (18 Nov 2007)
18 Nov 2007; Marijn Schouten <hkBst@gentoo.org> +gambit-4.1.0.ebuild:
- bump
+ Don't enable syntax-case anymore by default.
+ It conflicts with gambit's own macro system.
*gambit-4.0.1 (12 Sep 2007)
diff --git a/dev-scheme/gambit/files/digest-gambit-4.1.1 b/dev-scheme/gambit/files/digest-gambit-4.1.1
new file mode 100644
index 000000000000..3482f9590be4
--- /dev/null
+++ b/dev-scheme/gambit/files/digest-gambit-4.1.1
@@ -0,0 +1,3 @@
+MD5 00a45302a7879a329c926083ce72412f gambc-v4_1_1.tgz 11971875
+RMD160 9a3dc12b1b98c62f3c567150957b0337360bcee8 gambc-v4_1_1.tgz 11971875
+SHA256 8db1fa538966ceae1f8b5f916758c21dbf0539417167c7cf99b609c12b11c7bc gambc-v4_1_1.tgz 11971875
diff --git a/dev-scheme/gambit/gambit-4.1.1.ebuild b/dev-scheme/gambit/gambit-4.1.1.ebuild
new file mode 100644
index 000000000000..19701ae9ce0d
--- /dev/null
+++ b/dev-scheme/gambit/gambit-4.1.1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.1.1.ebuild,v 1.1 2007/12/16 13:01:23 hkbst Exp $
+
+inherit eutils elisp-common check-reqs autotools multilib
+
+MY_PN=gambc
+MY_PV=${PV//./_}
+MY_P=${MY_PN}-v${MY_PV}
+
+DESCRIPTION="Gambit-C is a native Scheme to C compiler and interpreter."
+HOMEPAGE="http://www.iro.umontreal.ca/~gambit/"
+SRC_URI="http://www.iro.umontreal.ca/~gambit/download/gambit/v${PV%.*}/source/${MY_P}.tgz"
+
+LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND="emacs? ( virtual/emacs )"
+
+SITEFILE="50gambit-gentoo.el"
+
+S=${WORKDIR}/${MY_P}
+
+IUSE="big-iron emacs static"
+
+pkg_setup() {
+ if ! use big-iron; then
+ ewarn "NOT compiling each Scheme module as a single C function"
+ ewarn "NOT using gcc specific optimizations"
+# ewarn "NOT compiling syntax-case macro system"
+ ewarn "approximately 0.5GB ram will be needed"
+ ewarn "if you experience thrashing, try disabling parallel building or setting -O1"
+ # need this much memory in MBytes (does *not* check swap)
+ CHECKREQS_MEMORY="768" check_reqs
+ else
+ ewarn "compiling each Scheme module as a single C function"
+ ewarn "using gcc specific optimizations"
+# ewarn "compiling syntax-case macro system"
+ ewarn "approximately 2GB ram will be needed instead of 0.5GB"
+ ewarn "this will cause heavy thrashing of your system"
+ ewarn "and may cause your compiler to crash when it runs out of memory"
+ ewarn "unless your system is BIG IRON"
+ # need this much memory in MBytes (does *not* check swap)
+ CHECKREQS_MEMORY="2560" check_reqs
+ fi
+}
+
+src_unpack() {
+ unpack ${A}; cd "${S}"
+# cp configure.ac configure.ac.old
+ sed -e 's:PACKAGE_SUBDIR="/$PACKAGE_VERSION"::' \
+ -e 's:#PACKAGE_SUBDIR="":PACKAGE_SUBDIR="":' -i configure.ac
+ #don't force -O1
+ sed 's:$DASH_O1::' -i configure.ac
+ eautoreconf
+# diff -u configure.ac.old configure.ac
+}
+
+src_compile() {
+ econf $(use_enable !static shared) $(use_enable big-iron single-host) $(use_enable big-iron gcc-opts)
+
+ emake || die "emake failed"
+
+ if use emacs; then
+ ( cd misc; elisp-comp *.el )
+ fi
+
+ #workaround
+ mv gsi/libgambcgsi.so gsc/libgambcgsc.so lib/
+}
+
+src_install() {
+ einstall docdir="${D}"/usr/share/doc/${PF} || die "einstall failed"
+
+ rm "${D}"/usr/current
+
+ mv "${D}"/usr/syntax-case.scm "${D}"/usr/$(get_libdir)
+
+ # rename the /usr/bin/gsc to avoid collision with gsc from ghostscript
+ mv "${D}"/usr/bin/gsc "${D}"/usr/bin/gsc-gambit
+
+ # remove emacs/site-lisp/gambit.el
+ rm -r "${D}"/usr/share/emacs
+ if use emacs; then
+ elisp-install ${PN} misc/*.{el,elc}
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ fi
+
+ dodoc INSTALL.txt README
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+
+ # create some more explicit names
+ dosym gsc-gambit usr/bin/gambit-compiler
+ dosym gsi usr/bin/gambit-interpreter
+
+ echo "GAMBCOPT=\"=/usr/\"" > "${T}"/50gambit && doenvd "${T}"/50gambit
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}