summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-10-22 17:59:01 +0000
committerHans de Graaff <graaff@gentoo.org>2013-10-22 17:59:01 +0000
commitf709b265bb8ceb14ee8e162aabf71319ed849fb1 (patch)
treea5d56d8c6125f4cdfd23c27d653c51a37f370bc7 /dev-ruby
parentRemove older patches (diff)
downloadgentoo-2-f709b265bb8ceb14ee8e162aabf71319ed849fb1.tar.gz
gentoo-2-f709b265bb8ceb14ee8e162aabf71319ed849fb1.tar.bz2
gentoo-2-f709b265bb8ceb14ee8e162aabf71319ed849fb1.zip
Version bump. Ebuild by Peter Wilmott in the ruby overlay.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activeldap/ChangeLog7
-rw-r--r--dev-ruby/activeldap/activeldap-4.0.1.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-ruby/activeldap/ChangeLog b/dev-ruby/activeldap/ChangeLog
index 2aa0a176682e..2999cd44b614 100644
--- a/dev-ruby/activeldap/ChangeLog
+++ b/dev-ruby/activeldap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activeldap
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeldap/ChangeLog,v 1.6 2013/07/23 01:57:27 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeldap/ChangeLog,v 1.7 2013/10/22 17:59:01 graaff Exp $
+
+*activeldap-4.0.1 (22 Oct 2013)
+
+ 22 Oct 2013; Hans de Graaff <graaff@gentoo.org> +activeldap-4.0.1.ebuild:
+ Version bump. Ebuild by Peter Wilmott in the ruby overlay.
23 Jul 2013; Patrick Lauer <patrick@gentoo.org> -activeldap-1.2.2-r1.ebuild:
QA: Drop old version with unsatisfiable ruby-gettext depend
diff --git a/dev-ruby/activeldap/activeldap-4.0.1.ebuild b/dev-ruby/activeldap/activeldap-4.0.1.ebuild
new file mode 100644
index 000000000000..a9b4bd9db716
--- /dev/null
+++ b/dev-ruby/activeldap/activeldap-4.0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeldap/activeldap-4.0.1.ebuild,v 1.1 2013/10/22 17:59:01 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.textile TODO"
+RUBY_FAKEGEM_EXTRAINSTALL="po"
+
+inherit ruby-fakegem
+
+MY_P="${P/ruby-/}"
+DESCRIPTION="Ruby/ActiveLDAP provides an activerecord inspired object oriented interface to LDAP"
+HOMEPAGE="https://github.com/activeldap/activeldap"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64"
+IUSE=""
+
+# Most tests require a live LDAP server to run.
+RESTRICT="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/activemodel-4.0.0:4.0
+ dev-ruby/locale
+ dev-ruby/ruby-gettext
+ dev-ruby/gettext_i18n_rails
+ || ( >=dev-ruby/ruby-ldap-0.8.2 dev-ruby/ruby-net-ldap )"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc doc/text/*
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+}