summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-02-20 11:02:52 +0000
committerHans de Graaff <graaff@gentoo.org>2014-02-20 11:02:52 +0000
commite98c7a63b6d1ec7a10fd5b7e3e041985ea5e089e (patch)
tree04447a1ecc15bf765314e0420513ffbf8198d31d /dev-ruby
parentStable for x86, wrt bug #500528 (diff)
downloadgentoo-2-e98c7a63b6d1ec7a10fd5b7e3e041985ea5e089e.tar.gz
gentoo-2-e98c7a63b6d1ec7a10fd5b7e3e041985ea5e089e.tar.bz2
gentoo-2-e98c7a63b6d1ec7a10fd5b7e3e041985ea5e089e.zip
Version bump. Drop ruby18 and jruby since the code no longer works with it.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/childprocess/ChangeLog7
-rw-r--r--dev-ruby/childprocess/childprocess-0.5.1.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-ruby/childprocess/ChangeLog b/dev-ruby/childprocess/ChangeLog
index 438bb745ee65..8c09dfc20187 100644
--- a/dev-ruby/childprocess/ChangeLog
+++ b/dev-ruby/childprocess/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/childprocess
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/childprocess/ChangeLog,v 1.41 2014/02/14 10:26:33 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/childprocess/ChangeLog,v 1.42 2014/02/20 11:02:52 graaff Exp $
+
+*childprocess-0.5.1 (20 Feb 2014)
+
+ 20 Feb 2014; Hans de Graaff <graaff@gentoo.org> +childprocess-0.5.1.ebuild:
+ Version bump. Drop ruby18 and jruby since the code no longer works with it.
*childprocess-0.4.2 (14 Feb 2014)
diff --git a/dev-ruby/childprocess/childprocess-0.5.1.ebuild b/dev-ruby/childprocess/childprocess-0.5.1.ebuild
new file mode 100644
index 000000000000..05b6e6238aa5
--- /dev/null
+++ b/dev-ruby/childprocess/childprocess-0.5.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/childprocess/childprocess-0.5.1.ebuild,v 1.1 2014/02/20 11:02:52 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC="yard"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple and reliable solution for controlling external programs running in the background."
+HOMEPAGE="https://github.com/jarib/childprocess"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/yard dev-ruby/rspec:2 )"
+
+ruby_add_rdepend "virtual/ruby-ffi"
+
+all_ruby_prepare() {
+ # Remove bundler support
+ rm Gemfile || die
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ sed -i -e "/[Cc]overalls/d" spec/spec_helper.rb || die
+ sed -i -e '/git ls-files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+}