summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-07-21 07:13:50 +0000
committerHans de Graaff <graaff@gentoo.org>2013-07-21 07:13:50 +0000
commitbc5d204d05799eb612d758380b499a62f0afa563 (patch)
treede96070d307da134898e0a4ca2562d6e92f9c79c /dev-ruby
parentRemove masked for removal package (diff)
downloadgentoo-2-bc5d204d05799eb612d758380b499a62f0afa563.tar.gz
gentoo-2-bc5d204d05799eb612d758380b499a62f0afa563.tar.bz2
gentoo-2-bc5d204d05799eb612d758380b499a62f0afa563.zip
Cleanup.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rspec-core/ChangeLog5
-rw-r--r--dev-ruby/rspec-core/rspec-core-2.13.0.ebuild75
2 files changed, 4 insertions, 76 deletions
diff --git a/dev-ruby/rspec-core/ChangeLog b/dev-ruby/rspec-core/ChangeLog
index e20b6f4607da..9c4a9bbb1f24 100644
--- a/dev-ruby/rspec-core/ChangeLog
+++ b/dev-ruby/rspec-core/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/rspec-core
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/ChangeLog,v 1.56 2013/07/20 06:45:56 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/ChangeLog,v 1.57 2013/07/21 07:13:50 graaff Exp $
+
+ 21 Jul 2013; Hans de Graaff <graaff@gentoo.org> -rspec-core-2.13.0.ebuild:
+ Cleanup.
*rspec-core-2.14.3 (20 Jul 2013)
diff --git a/dev-ruby/rspec-core/rspec-core-2.13.0.ebuild b/dev-ruby/rspec-core/rspec-core-2.13.0.ebuild
deleted file mode 100644
index 20f2223f30d0..000000000000
--- a/dev-ruby/rspec-core/rspec-core-2.13.0.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/rspec-core-2.13.0.ebuild,v 1.1 2013/02/24 08:43:44 graaff Exp $
-
-EAPI=5
-USE_RUBY="ruby18 ree18 ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_TEST="none"
-RUBY_FAKEGEM_TASK_DOC="none"
-
-RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
-
-# Also install this custom path since internal paths depend on it.
-RUBY_FAKEGEM_EXTRAINSTALL="exe"
-
-RUBY_FAKEGEM_GEMSPEC="rspec-core.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
-HOMEPAGE="http://rspec.rubyforge.org/"
-SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
-
-LICENSE="MIT"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RDEPEND="${RDEPEND} !<dev-ruby/rspec-1.3.1-r1"
-
-ruby_add_bdepend "test? (
- >=dev-ruby/nokogiri-1.5.2
- dev-ruby/syntax
- >=dev-ruby/zentest-4.6.2
- dev-ruby/rspec-expectations:2
- >=dev-ruby/rspec-mocks-2.12.0:2
- )"
-ruby_add_bdepend "doc? ( dev-ruby/yard )"
-
-all_ruby_prepare() {
- # Don't set up bundler: it doesn't understand our setup.
- sed -i -e '/[Bb]undler/d' Rakefile || die
-
- # Avoid dependency on cucumber since we can't run the features anyway.
- sed -i -e '/[Cc]ucumber/ s:^:#:' Rakefile || die
-
- # Also clean the /usr/lib/rubyee path (which is our own invention).
- sed -i -e 's#lib\\d\*\\/ruby\\/#lib\\d*\\/ruby(ee|)\\/#' lib/rspec/core/configuration.rb || die
-
- # Remove jruby-specific comparison documents since for us the normal
- # version passes.
- cp spec/rspec/core/formatters/text_mate_formatted-1.8.7.html spec/rspec/core/formatters/text_mate_formatted-1.8.7-jruby.html|| die
-
- # Duplicate exe also in bin. We can't change it since internal stuff
- # also depends on this and fixing that is going to be fragile. This
- # way we can at least install proper bin scripts.
- cp -R exe bin || die
-
- # Avoid unneeded dependency on git.
- sed -i -e '/git ls-files/ s:^:#:' rspec-core.gemspec || die
-
- # Avoid aruba dependency so that we don't end up in dependency hell.
- sed -i -e '/aruba/ s:^:#:' -e '104,106 s:^:#:' spec/spec_helper.rb || die
- rm spec/command_line/order_spec.rb || die
-}
-
-all_ruby_compile() {
- if use doc ; then
- yardoc || die
- fi
-}
-
-each_ruby_test() {
- PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -Ilib bin/rspec spec || die "Tests failed."
-}