summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-02-19 07:19:35 +0000
committerHans de Graaff <graaff@gentoo.org>2014-02-19 07:19:35 +0000
commit9fdb3c71d5b15ad59ee58ac8e9420469f2b36533 (patch)
tree5ac088bfa55c7e7521341914053f9e5988ffafb0 /dev-ruby
parentVersion bump for security bug 501750. (diff)
downloadgentoo-2-9fdb3c71d5b15ad59ee58ac8e9420469f2b36533.tar.gz
gentoo-2-9fdb3c71d5b15ad59ee58ac8e9420469f2b36533.tar.bz2
gentoo-2-9fdb3c71d5b15ad59ee58ac8e9420469f2b36533.zip
Version bump for security bug 501750.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/actionmailer/ChangeLog7
-rw-r--r--dev-ruby/actionmailer/actionmailer-3.2.17.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index 04fed371a87d..27282e1fd945 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.249 2014/01/18 09:54:17 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.250 2014/02/19 07:19:35 graaff Exp $
+
+*actionmailer-3.2.17 (19 Feb 2014)
+
+ 19 Feb 2014; Hans de Graaff <graaff@gentoo.org> +actionmailer-3.2.17.ebuild:
+ Version bump for security bug 501750.
18 Jan 2014; Hans de Graaff <graaff@gentoo.org> -actionmailer-2.3.18.ebuild:
Remove masked version.
diff --git a/dev-ruby/actionmailer/actionmailer-3.2.17.ebuild b/dev-ruby/actionmailer/actionmailer-3.2.17.ebuild
new file mode 100644
index 000000000000..ea978a145468
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-3.2.17.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-3.2.17.ebuild,v 1.1 2014/02/19 07:19:35 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/mail-2.5.4:2.5"
+ruby_add_bdepend "test? (
+ dev-ruby/test-unit:2
+ dev-ruby/mocha:0.13
+)"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Make sure we use the test-unit gem since ruby18 does not provide
+ # all the test-unit features needed.
+ sed -i -e '1igem "test-unit"' test/abstract_unit.rb || die
+}