summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-16 13:58:49 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-16 13:58:49 +0000
commit4bc0def42e23058d35d2c013d8ddbfdaf995e6e1 (patch)
treee6de1fcb460c24f840a14b639c9760b2b30980fe /dev-ruby
parentRemove old. (diff)
downloadgentoo-2-4bc0def42e23058d35d2c013d8ddbfdaf995e6e1.tar.gz
gentoo-2-4bc0def42e23058d35d2c013d8ddbfdaf995e6e1.tar.bz2
gentoo-2-4bc0def42e23058d35d2c013d8ddbfdaf995e6e1.zip
Remove old; bump to EAPI=4; use the testrb-2 helper for testing.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/liquid/ChangeLog11
-rw-r--r--dev-ruby/liquid/liquid-2.2.2.ebuild24
-rw-r--r--dev-ruby/liquid/liquid-2.3.0.ebuild10
3 files changed, 13 insertions, 32 deletions
diff --git a/dev-ruby/liquid/ChangeLog b/dev-ruby/liquid/ChangeLog
index 9d367bc36419..70b9afbba1f2 100644
--- a/dev-ruby/liquid/ChangeLog
+++ b/dev-ruby/liquid/ChangeLog
@@ -1,6 +1,10 @@
-# ChangeLog for dev-ruby/lisquid
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/liquid/ChangeLog,v 1.1 2012/08/16 03:44:19 flameeyes Exp $
+# ChangeLog for dev-ruby/liquid
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/liquid/ChangeLog,v 1.2 2012/08/16 13:58:49 flameeyes Exp $
+
+ 16 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> -liquid-2.2.2.ebuild,
+ liquid-2.3.0.ebuild:
+ Remove old; bump to EAPI=4; use the testrb-2 helper for testing.
*ruby-liquid-2.3.0 (18 Oct 2011)
@@ -63,4 +67,3 @@
24 Jun 2006; Diego Pettenò <flameeyes@gentoo.org> +metadata.xml,
+ruby-liquid-1.0.ebuild:
Initial import of Liquid Template Library for Ruby.
-
diff --git a/dev-ruby/liquid/liquid-2.2.2.ebuild b/dev-ruby/liquid/liquid-2.2.2.ebuild
deleted file mode 100644
index f5251bb92dac..000000000000
--- a/dev-ruby/liquid/liquid-2.2.2.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/liquid/liquid-2.2.2.ebuild,v 1.2 2012/08/16 07:38:56 mr_bones_ Exp $
-
-EAPI="2"
-USE_RUBY="ruby18 ree18"
-
-# Drop tests and documentation tasks for 2.1.2 since they are no
-# longer included in the gem, and github is not tagged and it's not
-# obvious how it matches the released gem version.
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_FAKEGEM_EXTRADOC="History.txt README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Template engine for Ruby"
-HOMEPAGE="http://www.liquidmarkup.org/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86-fbsd ~x86"
-IUSE=""
diff --git a/dev-ruby/liquid/liquid-2.3.0.ebuild b/dev-ruby/liquid/liquid-2.3.0.ebuild
index 2cc8a4cfc43e..b594d8684d87 100644
--- a/dev-ruby/liquid/liquid-2.3.0.ebuild
+++ b/dev-ruby/liquid/liquid-2.3.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/liquid/liquid-2.3.0.ebuild,v 1.2 2012/08/16 07:38:56 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/liquid/liquid-2.3.0.ebuild,v 1.3 2012/08/16 13:58:49 flameeyes Exp $
-EAPI="2"
+EAPI=4
USE_RUBY="ruby18 ree18 jruby"
RUBY_FAKEGEM_TASK_DOC=""
@@ -20,6 +20,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86-fbsd ~x86"
IUSE=""
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+
each_ruby_test() {
- ${RUBY} -Ilib:test -S testrb test/liquid/*_test.rb || die
+ ruby-ng_testrb-2 -Ilib:test test/liquid/*_test.rb
}