summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-02-21 09:34:22 +0000
committerHans de Graaff <graaff@gentoo.org>2015-02-21 09:34:22 +0000
commit339c66c0eb3ca20323cbd5ead4bfa37dcb94956b (patch)
tree5e8323593872a5b8265572e87307bd6d1c104251 /dev-ruby
parentAdd ruby22. (diff)
downloadgentoo-2-339c66c0eb3ca20323cbd5ead4bfa37dcb94956b.tar.gz
gentoo-2-339c66c0eb3ca20323cbd5ead4bfa37dcb94956b.tar.bz2
gentoo-2-339c66c0eb3ca20323cbd5ead4bfa37dcb94956b.zip
Add ruby22.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rspec-support/ChangeLog5
-rw-r--r--dev-ruby/rspec-support/rspec-support-3.2.1.ebuild13
2 files changed, 15 insertions, 3 deletions
diff --git a/dev-ruby/rspec-support/ChangeLog b/dev-ruby/rspec-support/ChangeLog
index bf2db3a40825..85bab7c27e66 100644
--- a/dev-ruby/rspec-support/ChangeLog
+++ b/dev-ruby/rspec-support/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/rspec-support
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-support/ChangeLog,v 1.3 2015/02/15 07:12:18 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-support/ChangeLog,v 1.4 2015/02/21 09:34:22 graaff Exp $
+
+ 21 Feb 2015; Hans de Graaff <graaff@gentoo.org> rspec-support-3.2.1.ebuild:
+ Add ruby22.
*rspec-support-3.2.1 (15 Feb 2015)
diff --git a/dev-ruby/rspec-support/rspec-support-3.2.1.ebuild b/dev-ruby/rspec-support/rspec-support-3.2.1.ebuild
index 29ed996ac370..2dea0c9d0a1b 100644
--- a/dev-ruby/rspec-support/rspec-support-3.2.1.ebuild
+++ b/dev-ruby/rspec-support/rspec-support-3.2.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-support/rspec-support-3.2.1.ebuild,v 1.1 2015/02/15 07:12:18 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-support/rspec-support-3.2.1.ebuild,v 1.2 2015/02/21 09:34:22 graaff Exp $
EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21"
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
@@ -32,3 +32,12 @@ all_ruby_prepare() {
# the whole filesystem.
rm spec/rspec/support/caller_filter_spec.rb || die
}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby22)
+ # The rubygems version bundled with ruby 2.2 causes warnings.
+ rm spec/rspec/support_spec.rb spec/rspec/support/spec/shell_out_spec.rb || die
+ ;;
+ esac
+}