summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-09-22 16:54:57 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-09-22 16:54:57 +0000
commit06780a208d6323d571ae4f9909f52b6fff062edb (patch)
tree9a68232e82b6d45d02a23a8c93a03944ca3b9797 /dev-ruby/will_paginate
parentPick the correct libdir by Nikoli (bug #485600 again). (diff)
downloadgentoo-2-06780a208d6323d571ae4f9909f52b6fff062edb.tar.gz
gentoo-2-06780a208d6323d571ae4f9909f52b6fff062edb.tar.bz2
gentoo-2-06780a208d6323d571ae4f9909f52b6fff062edb.zip
Version bump.
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/will_paginate')
-rw-r--r--dev-ruby/will_paginate/ChangeLog8
-rw-r--r--dev-ruby/will_paginate/will_paginate-3.0.5.ebuild27
2 files changed, 33 insertions, 2 deletions
diff --git a/dev-ruby/will_paginate/ChangeLog b/dev-ruby/will_paginate/ChangeLog
index eaca903cfda7..79eb94cab675 100644
--- a/dev-ruby/will_paginate/ChangeLog
+++ b/dev-ruby/will_paginate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/will_paginate
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/will_paginate/ChangeLog,v 1.20 2013/07/02 05:55:13 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/will_paginate/ChangeLog,v 1.21 2013/09/22 16:54:57 mrueg Exp $
+
+*will_paginate-3.0.5 (22 Sep 2013)
+
+ 22 Sep 2013; Manuel Rüger <mrueg@gentoo.org> +will_paginate-3.0.5.ebuild:
+ Version bump.
02 Jul 2013; Hans de Graaff <graaff@gentoo.org> -will_paginate-3.0.3.ebuild:
Cleanup.
@@ -130,4 +135,3 @@
Loosely based on Wim Muskee work on bug #256077. Uses the github-produced
tarball (renamed), has proper dependencies and an src_test function and
installs a fake gemspec file.
-
diff --git a/dev-ruby/will_paginate/will_paginate-3.0.5.ebuild b/dev-ruby/will_paginate/will_paginate-3.0.5.ebuild
new file mode 100644
index 000000000000..b8645870876e
--- /dev/null
+++ b/dev-ruby/will_paginate/will_paginate-3.0.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/will_paginate/will_paginate-3.0.5.ebuild,v 1.1 2013/09/22 16:54:57 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Most awesome pagination solution for Ruby."
+HOMEPAGE="http://github.com/mislav/will_paginate/"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~x86 ~x86-macos"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ =dev-ruby/rails-3*
+ dev-ruby/mocha
+ )"