summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-08-26 06:11:50 +0000
committerHans de Graaff <graaff@gentoo.org>2013-08-26 06:11:50 +0000
commit25eaa582c37aab7d2b9cfc891ab23ab7cb9f49b7 (patch)
tree76517e137d2d96c5b44e8fbb0a835576e50c19de /dev-ruby/tzinfo
parentdev-haskell/idna: new version (diff)
downloadgentoo-2-25eaa582c37aab7d2b9cfc891ab23ab7cb9f49b7.tar.gz
gentoo-2-25eaa582c37aab7d2b9cfc891ab23ab7cb9f49b7.tar.bz2
gentoo-2-25eaa582c37aab7d2b9cfc891ab23ab7cb9f49b7.zip
Version bump. tzinfo now uses the system timezone data from sys-libs/timezone-data.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/tzinfo')
-rw-r--r--dev-ruby/tzinfo/ChangeLog8
-rw-r--r--dev-ruby/tzinfo/tzinfo-1.0.1.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-ruby/tzinfo/ChangeLog b/dev-ruby/tzinfo/ChangeLog
index 9febd1ccf816..339308dead4f 100644
--- a/dev-ruby/tzinfo/ChangeLog
+++ b/dev-ruby/tzinfo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/tzinfo
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.116 2013/04/21 05:51:55 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.117 2013/08/26 06:11:50 graaff Exp $
+
+*tzinfo-1.0.1 (26 Aug 2013)
+
+ 26 Aug 2013; Hans de Graaff <graaff@gentoo.org> +tzinfo-1.0.1.ebuild:
+ Version bump. tzinfo now uses the system timezone data from
+ sys-libs/timezone-data.
*tzinfo-0.3.37 (21 Apr 2013)
diff --git a/dev-ruby/tzinfo/tzinfo-1.0.1.ebuild b/dev-ruby/tzinfo/tzinfo-1.0.1.ebuild
new file mode 100644
index 000000000000..be99ce48bdb4
--- /dev/null
+++ b/dev-ruby/tzinfo/tzinfo-1.0.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/tzinfo-1.0.1.ebuild,v 1.1 2013/08/26 06:11:50 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Daylight-savings aware timezone library"
+HOMEPAGE="http://tzinfo.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="sys-libs/timezone-data"
+DEPEND="test? ( sys-libs/timezone-data )"
+
+all_ruby_prepare() {
+ # With rubygems 1.3.1 we get the following warning
+ # warning: Insecure world writable dir /var/tmp in LOAD_PATH, mode 041777
+ # when running the test_get_tainted_not_loaded test.
+ sed -i \
+ -e '/^ def test_get_tainted_not_loaded/, /^ end/ s:^:#:' \
+ -e '/test_get_tainted_not_previously_loaded/,/^ end/ s:^:#:' \
+ "${S}"/test/tc_timezone.rb || die "unable to sed out the test"
+
+ sed -i \
+ -e '/test_load_timezone_info_tainted/,/^ end/ s:^:#:' \
+ test/tc_ruby_data_source.rb || die
+}
+
+each_ruby_test() {
+ TZ='America/Los_Angeles' ${RUBY} -I. -S testrb test/tc_*.rb || die
+}