summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-20 21:20:41 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-20 21:20:41 +0000
commit2844cae4b96e28797d4f11a2235cfe91a057c4ff (patch)
treedb9c5f6e8b7b9d546479f32259978395ad3cd971 /dev-ruby/test-spec
parentInitial import, thanks again to Pavel Stratil. New dependency for gearmand[dr... (diff)
downloadgentoo-2-2844cae4b96e28797d4f11a2235cfe91a057c4ff.tar.gz
gentoo-2-2844cae4b96e28797d4f11a2235cfe91a057c4ff.tar.bz2
gentoo-2-2844cae4b96e28797d4f11a2235cfe91a057c4ff.zip
Revision bump again, add a patch to use test-unit directly, fix dependencies.
(Portage version: 2.2_rc60/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/test-spec')
-rw-r--r--dev-ruby/test-spec/ChangeLog10
-rw-r--r--dev-ruby/test-spec/files/test-spec-0.10.0-test-unit.patch12
-rw-r--r--dev-ruby/test-spec/test-spec-0.10.0-r1.ebuild24
-rw-r--r--dev-ruby/test-spec/test-spec-0.10.0-r2.ebuild42
4 files changed, 63 insertions, 25 deletions
diff --git a/dev-ruby/test-spec/ChangeLog b/dev-ruby/test-spec/ChangeLog
index f149889c7bb7..ca723a9894e8 100644
--- a/dev-ruby/test-spec/ChangeLog
+++ b/dev-ruby/test-spec/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ruby/test-spec
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-spec/ChangeLog,v 1.6 2009/12/16 15:23:15 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-spec/ChangeLog,v 1.7 2009/12/20 21:20:41 flameeyes Exp $
+
+*test-spec-0.10.0-r2 (20 Dec 2009)
+
+ 20 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ -test-spec-0.10.0-r1.ebuild, +test-spec-0.10.0-r2.ebuild,
+ +files/test-spec-0.10.0-test-unit.patch:
+ Revision bump again, add a patch to use test-unit directly, fix
+ dependencies.
*test-spec-0.10.0-r1 (16 Dec 2009)
diff --git a/dev-ruby/test-spec/files/test-spec-0.10.0-test-unit.patch b/dev-ruby/test-spec/files/test-spec-0.10.0-test-unit.patch
new file mode 100644
index 000000000000..366cb1de4ca4
--- /dev/null
+++ b/dev-ruby/test-spec/files/test-spec-0.10.0-test-unit.patch
@@ -0,0 +1,12 @@
+Index: test-spec-0.10.0/lib/test/spec.rb
+===================================================================
+--- test-spec-0.10.0.orig/lib/test/spec.rb
++++ test-spec-0.10.0/lib/test/spec.rb
+@@ -6,6 +6,7 @@
+ # This work is licensed under the same terms as Ruby itself.
+ #
+
++gem 'test-unit'
+ require 'test/unit'
+
+ class Test::Unit::AutoRunner # :nodoc:
diff --git a/dev-ruby/test-spec/test-spec-0.10.0-r1.ebuild b/dev-ruby/test-spec/test-spec-0.10.0-r1.ebuild
deleted file mode 100644
index 7bebd8be0862..000000000000
--- a/dev-ruby/test-spec/test-spec-0.10.0-r1.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-spec/test-spec-0.10.0-r1.ebuild,v 1.1 2009/12/16 15:23:15 a3li Exp $
-
-EAPI="2"
-USE_RUBY="ruby18 ruby19"
-inherit ruby-fakegem
-
-DESCRIPTION="A library to do Behavior Driven Development with Test::Unit"
-HOMEPAGE="http://chneukirchen.org/blog/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-all_ruby_install() {
- ruby_fakegem_binwrapper specrb
- dodoc README SPECS || die
-
- if use doc; then
- dodoc examples/* || die
- fi
-}
diff --git a/dev-ruby/test-spec/test-spec-0.10.0-r2.ebuild b/dev-ruby/test-spec/test-spec-0.10.0-r2.ebuild
new file mode 100644
index 000000000000..769d25381e29
--- /dev/null
+++ b/dev-ruby/test-spec/test-spec-0.10.0-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-spec/test-spec-0.10.0-r2.ebuild,v 1.1 2009/12/20 21:20:41 flameeyes Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_EXTRADOC="README SPECS ROADMAP TODO"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="A library to do Behavior Driven Development with Test::Unit"
+HOMEPAGE="http://chneukirchen.org/blog/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# This should in theory work with the test-unit from Ruby 1.8 as well,
+# but since mocha seem to prefer the gem, we're just going to depend
+# on the new version.
+#
+# And yes it's a runtime dependency.
+ruby_add_rdepend dev-ruby/test-unit
+
+ruby_add_bdepend test dev-ruby/mocha
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${P}-test-unit.patch
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper specrb
+
+ if use doc; then
+ dodoc examples/* || die
+ fi
+}