summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-02-12 21:54:24 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-02-12 21:54:24 +0000
commit838ff5aa2192b8071f83a8e835456cf2a49d9572 (patch)
tree2f188403dc5d256d63bf72d7cda2f10a90a22640 /dev-ruby/storable
parentAdd missing libsoup dep, bug 304613 (diff)
downloadgentoo-2-838ff5aa2192b8071f83a8e835456cf2a49d9572.tar.gz
gentoo-2-838ff5aa2192b8071f83a8e835456cf2a49d9572.tar.bz2
gentoo-2-838ff5aa2192b8071f83a8e835456cf2a49d9572.zip
Initial import of storable, needed for Rudy.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/storable')
-rw-r--r--dev-ruby/storable/ChangeLog10
-rw-r--r--dev-ruby/storable/files/storable-0.6.1-hanna.patch24
-rw-r--r--dev-ruby/storable/metadata.xml5
-rw-r--r--dev-ruby/storable/storable-0.6.1.ebuild30
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-ruby/storable/ChangeLog b/dev-ruby/storable/ChangeLog
new file mode 100644
index 000000000000..d4afd6f9317a
--- /dev/null
+++ b/dev-ruby/storable/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/storable
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/ChangeLog,v 1.1 2010/02/12 21:54:23 flameeyes Exp $
+
+*storable-0.6.1 (12 Feb 2010)
+
+ 12 Feb 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +storable-0.6.1.ebuild, +files/storable-0.6.1-hanna.patch, +metadata.xml:
+ Initial import of storable, needed for Rudy.
+
diff --git a/dev-ruby/storable/files/storable-0.6.1-hanna.patch b/dev-ruby/storable/files/storable-0.6.1-hanna.patch
new file mode 100644
index 000000000000..e5fdbd98b499
--- /dev/null
+++ b/dev-ruby/storable/files/storable-0.6.1-hanna.patch
@@ -0,0 +1,24 @@
+diff --git a/Rakefile b/Rakefile
+index 85d1c50..619003e 100644
+--- a/Rakefile
++++ b/Rakefile
+@@ -1,7 +1,6 @@
+ require 'rubygems'
+ require 'rake/clean'
+ require 'rake/gempackagetask'
+-require 'hanna/rdoctask'
+ require 'fileutils'
+ include FileUtils
+
+@@ -65,6 +64,11 @@ end
+
+
+ # RUBY DOCS TASK ==================================
++begin
++ require 'hanna/rdoctask'
++rescue LoadError
++ require 'rake/rdoctask'
++end
+
+ Rake::RDocTask.new do |t|
+ t.rdoc_dir = 'doc'
diff --git a/dev-ruby/storable/metadata.xml b/dev-ruby/storable/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/storable/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/storable/storable-0.6.1.ebuild b/dev-ruby/storable/storable-0.6.1.ebuild
new file mode 100644
index 000000000000..e6a37aa51c9c
--- /dev/null
+++ b/dev-ruby/storable/storable-0.6.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/storable-0.6.1.ebuild,v 1.1 2010/02/12 21:54:23 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RESTRICT=test
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc"
+
+RUBY_FAKEGEM_BINWRAP="ec2sh"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Marshal Ruby classes into and out of multiple formats"
+HOMEPAGE="http://solutious.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${P}-hanna.patch
+}