summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-11-28 07:25:42 +0000
committerHans de Graaff <graaff@gentoo.org>2013-11-28 07:25:42 +0000
commitdb4a80bd452d9006c7eb0393eb7a6cbd16cace6f (patch)
treee37cd167663212a5cda8318cb2e401cd3a5dde59 /dev-ruby/shoulda-context
parentupdate test phase (diff)
downloadgentoo-2-db4a80bd452d9006c7eb0393eb7a6cbd16cace6f.tar.gz
gentoo-2-db4a80bd452d9006c7eb0393eb7a6cbd16cace6f.tar.bz2
gentoo-2-db4a80bd452d9006c7eb0393eb7a6cbd16cace6f.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/shoulda-context')
-rw-r--r--dev-ruby/shoulda-context/ChangeLog8
-rw-r--r--dev-ruby/shoulda-context/shoulda-context-1.1.6.ebuild32
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-ruby/shoulda-context/ChangeLog b/dev-ruby/shoulda-context/ChangeLog
index 98394a000de2..b3e1d97c753b 100644
--- a/dev-ruby/shoulda-context/ChangeLog
+++ b/dev-ruby/shoulda-context/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/shoulda-context
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/shoulda-context/ChangeLog,v 1.2 2013/11/26 19:42:20 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/shoulda-context/ChangeLog,v 1.3 2013/11/28 07:25:42 graaff Exp $
+
+*shoulda-context-1.1.6 (28 Nov 2013)
+
+ 28 Nov 2013; Hans de Graaff <graaff@gentoo.org>
+ +shoulda-context-1.1.6.ebuild:
+ Version bump.
26 Nov 2013; Hans de Graaff <graaff@gentoo.org> shoulda-context-1.1.4.ebuild:
Don't install the conversion script in /usr/bin to avoid file collisions with
diff --git a/dev-ruby/shoulda-context/shoulda-context-1.1.6.ebuild b/dev-ruby/shoulda-context/shoulda-context-1.1.6.ebuild
new file mode 100644
index 000000000000..7ad6eca76106
--- /dev/null
+++ b/dev-ruby/shoulda-context/shoulda-context-1.1.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/shoulda-context/shoulda-context-1.1.6.ebuild,v 1.1 2013/11/28 07:25:42 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING.md README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb rails tasks"
+
+# Don't install the conversion script to avoid collisions with older
+# shoulda.
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Context framework extracted from Shoulda"
+HOMEPAGE="http://thoughtbot.com/projects/shoulda"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 dev-ruby/mocha )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Itest test/shoulda/*_test.rb || die
+}