summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-10-20 05:52:20 +0000
committerHans de Graaff <graaff@gentoo.org>2013-10-20 05:52:20 +0000
commit1c3ceda56918fc291d20bd623d8a7f9783b814da (patch)
tree475e2a916f31d369b0953d7ab1be949a82bdc09e /dev-ruby/selenium-webdriver
parentBump utf8-light to 0.4.2 (diff)
downloadgentoo-2-1c3ceda56918fc291d20bd623d8a7f9783b814da.tar.gz
gentoo-2-1c3ceda56918fc291d20bd623d8a7f9783b814da.tar.bz2
gentoo-2-1c3ceda56918fc291d20bd623d8a7f9783b814da.zip
Cleanup.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/selenium-webdriver')
-rw-r--r--dev-ruby/selenium-webdriver/ChangeLog7
-rw-r--r--dev-ruby/selenium-webdriver/selenium-webdriver-2.31.0.ebuild39
-rw-r--r--dev-ruby/selenium-webdriver/selenium-webdriver-2.32.1.ebuild39
-rw-r--r--dev-ruby/selenium-webdriver/selenium-webdriver-2.33.0.ebuild39
4 files changed, 6 insertions, 118 deletions
diff --git a/dev-ruby/selenium-webdriver/ChangeLog b/dev-ruby/selenium-webdriver/ChangeLog
index 23d4860be1af..5a75fa57ee7f 100644
--- a/dev-ruby/selenium-webdriver/ChangeLog
+++ b/dev-ruby/selenium-webdriver/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/selenium-webdriver
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/selenium-webdriver/ChangeLog,v 1.49 2013/08/30 06:03:40 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/selenium-webdriver/ChangeLog,v 1.50 2013/10/20 05:52:20 graaff Exp $
+
+ 20 Oct 2013; Hans de Graaff <graaff@gentoo.org>
+ -selenium-webdriver-2.31.0.ebuild, -selenium-webdriver-2.32.1.ebuild,
+ -selenium-webdriver-2.33.0.ebuild:
+ Cleanup.
*selenium-webdriver-2.35.1 (30 Aug 2013)
diff --git a/dev-ruby/selenium-webdriver/selenium-webdriver-2.31.0.ebuild b/dev-ruby/selenium-webdriver/selenium-webdriver-2.31.0.ebuild
deleted file mode 100644
index 1d71a9fa815a..000000000000
--- a/dev-ruby/selenium-webdriver/selenium-webdriver-2.31.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/selenium-webdriver/selenium-webdriver-2.31.0.ebuild,v 1.1 2013/03/08 05:55:24 graaff Exp $
-
-EAPI=5
-USE_RUBY="ruby18 ruby19 ree18"
-
-# NOTE: this package contains precompiled code. It appears that all
-# source code can be found at http://code.google.com/p/selenium/ but the
-# repository is not organized in a way so that we can easily rebuild the
-# suited shared object. We'll just try our luck with the precompiled
-# objects for now.
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGES README"
-
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_QA_ALLOWED_LIBS="x_ignore_nofocus.so"
-
-inherit ruby-fakegem
-
-DESCRIPTION="This gem provides Ruby bindings for WebDriver."
-HOMEPAGE="http://gemcutter.org/gems/selenium-webdriver"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/childprocess-0.2.5
- >=dev-ruby/multi_json-1.0.4
- dev-ruby/rubyzip"
-
-all_ruby_prepare() {
- # Make websocket a development dependency since it is only needed
- # for the safari driver which we don't support on Gentoo.
- sed -i -e '/websocket/,/version_requirements/ s/runtime/development/' ../metadata || die
-}
diff --git a/dev-ruby/selenium-webdriver/selenium-webdriver-2.32.1.ebuild b/dev-ruby/selenium-webdriver/selenium-webdriver-2.32.1.ebuild
deleted file mode 100644
index e990ca0942b5..000000000000
--- a/dev-ruby/selenium-webdriver/selenium-webdriver-2.32.1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/selenium-webdriver/selenium-webdriver-2.32.1.ebuild,v 1.1 2013/04/19 05:29:15 graaff Exp $
-
-EAPI=5
-USE_RUBY="ruby18 ruby19"
-
-# NOTE: this package contains precompiled code. It appears that all
-# source code can be found at http://code.google.com/p/selenium/ but the
-# repository is not organized in a way so that we can easily rebuild the
-# suited shared object. We'll just try our luck with the precompiled
-# objects for now.
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGES README.md"
-
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_QA_ALLOWED_LIBS="x_ignore_nofocus.so"
-
-inherit ruby-fakegem
-
-DESCRIPTION="This gem provides Ruby bindings for WebDriver."
-HOMEPAGE="http://gemcutter.org/gems/selenium-webdriver"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/childprocess-0.2.5
- >=dev-ruby/multi_json-1.0.4
- dev-ruby/rubyzip"
-
-all_ruby_prepare() {
- # Make websocket a development dependency since it is only needed
- # for the safari driver which we don't support on Gentoo.
- sed -i -e '/websocket/,/version_requirements/ s/runtime/development/' ../metadata || die
-}
diff --git a/dev-ruby/selenium-webdriver/selenium-webdriver-2.33.0.ebuild b/dev-ruby/selenium-webdriver/selenium-webdriver-2.33.0.ebuild
deleted file mode 100644
index 682472a97070..000000000000
--- a/dev-ruby/selenium-webdriver/selenium-webdriver-2.33.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/selenium-webdriver/selenium-webdriver-2.33.0.ebuild,v 1.1 2013/05/27 06:08:25 graaff Exp $
-
-EAPI=5
-USE_RUBY="ruby18 ruby19"
-
-# NOTE: this package contains precompiled code. It appears that all
-# source code can be found at http://code.google.com/p/selenium/ but the
-# repository is not organized in a way so that we can easily rebuild the
-# suited shared object. We'll just try our luck with the precompiled
-# objects for now.
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGES README.md"
-
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_QA_ALLOWED_LIBS="x_ignore_nofocus.so"
-
-inherit ruby-fakegem
-
-DESCRIPTION="This gem provides Ruby bindings for WebDriver."
-HOMEPAGE="http://gemcutter.org/gems/selenium-webdriver"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/childprocess-0.2.5
- >=dev-ruby/multi_json-1.0.4
- dev-ruby/rubyzip"
-
-all_ruby_prepare() {
- # Make websocket a development dependency since it is only needed
- # for the safari driver which we don't support on Gentoo.
- sed -i -e '/websocket/,/version_requirements/ s/runtime/development/' ../metadata || die
-}