summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-07-11 09:31:42 +0000
committerHans de Graaff <graaff@gentoo.org>2010-07-11 09:31:42 +0000
commit274f81cf29b9c01031c513579ed3c6e5b2525439 (patch)
treeed090436601e53b884e3e0feb44e8090b9ef39d7 /dev-ruby/rubytorrent
parentStable on alpha, bug #295256 (diff)
downloadgentoo-2-274f81cf29b9c01031c513579ed3c6e5b2525439.tar.gz
gentoo-2-274f81cf29b9c01031c513579ed3c6e5b2525439.tar.bz2
gentoo-2-274f81cf29b9c01031c513579ed3c6e5b2525439.zip
Convert to ruby-ng.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rubytorrent')
-rw-r--r--dev-ruby/rubytorrent/ChangeLog8
-rw-r--r--dev-ruby/rubytorrent/rubytorrent-0.3-r1.ebuild31
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-ruby/rubytorrent/ChangeLog b/dev-ruby/rubytorrent/ChangeLog
index 12618807620a..e2ef1020e4d1 100644
--- a/dev-ruby/rubytorrent/ChangeLog
+++ b/dev-ruby/rubytorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rubytorrent
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubytorrent/ChangeLog,v 1.10 2010/05/22 15:55:13 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubytorrent/ChangeLog,v 1.11 2010/07/11 09:31:42 graaff Exp $
+
+*rubytorrent-0.3-r1 (11 Jul 2010)
+
+ 11 Jul 2010; Hans de Graaff <graaff@gentoo.org>
+ +rubytorrent-0.3-r1.ebuild:
+ Convert to ruby-ng.
22 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
rubytorrent-0.3.ebuild:
diff --git a/dev-ruby/rubytorrent/rubytorrent-0.3-r1.ebuild b/dev-ruby/rubytorrent/rubytorrent-0.3-r1.ebuild
new file mode 100644
index 000000000000..ce286df8521b
--- /dev/null
+++ b/dev-ruby/rubytorrent/rubytorrent-0.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubytorrent/rubytorrent-0.3-r1.ebuild,v 1.1 2010/07/11 09:31:42 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+inherit ruby-ng
+
+DESCRIPTION="A pure-Ruby BitTorrent peer library and toolset"
+HOMEPAGE="http://rubytorrent.rubyforge.org/"
+SRC_URI="http://rubyforge.org/frs/download.php/3017/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+each_ruby_install() {
+ local sitelibdir=$(ruby_rbconfig_value "sitelibdir")
+ doruby rubytorrent.rb || die
+ insinto "${sitelibdir}/rubytorrent"
+ doins rubytorrent/* || die
+}
+
+all_ruby_install() {
+ dodoc doc/* README ReleaseNotes.txt
+ docinto examples
+ dodoc dump-metainfo.rb dump-peers.rb make-metainfo.rb \
+ rtpeer-ncurses.rb rtpeer.rb
+}