summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-08-01 17:37:45 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-08-01 17:37:45 +0000
commit6f3774d24cb5cbb2274fe8e5d025b97564300229 (patch)
tree5b9f712139355c19a8f144cd52d58e2f082ee1ce /dev-ruby/ruby_parser
parentVersion bump. Cleanup old. (diff)
downloadgentoo-2-6f3774d24cb5cbb2274fe8e5d025b97564300229.tar.gz
gentoo-2-6f3774d24cb5cbb2274fe8e5d025b97564300229.tar.bz2
gentoo-2-6f3774d24cb5cbb2274fe8e5d025b97564300229.zip
Version bump. Cleanup old.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/ruby_parser')
-rw-r--r--dev-ruby/ruby_parser/ChangeLog8
-rw-r--r--dev-ruby/ruby_parser/ruby_parser-3.6.0.ebuild45
-rw-r--r--dev-ruby/ruby_parser/ruby_parser-3.6.2.ebuild (renamed from dev-ruby/ruby_parser/ruby_parser-3.4.1.ebuild)4
3 files changed, 9 insertions, 48 deletions
diff --git a/dev-ruby/ruby_parser/ChangeLog b/dev-ruby/ruby_parser/ChangeLog
index f59fce0d6571..c65177b54d82 100644
--- a/dev-ruby/ruby_parser/ChangeLog
+++ b/dev-ruby/ruby_parser/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/ruby_parser
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby_parser/ChangeLog,v 1.62 2014/05/18 19:56:51 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby_parser/ChangeLog,v 1.63 2014/08/01 17:37:45 mrueg Exp $
+
+*ruby_parser-3.6.2 (01 Aug 2014)
+
+ 01 Aug 2014; Manuel Rüger <mrueg@gentoo.org> +ruby_parser-3.6.2.ebuild,
+ -ruby_parser-3.4.1.ebuild, -ruby_parser-3.6.0.ebuild:
+ Version bump. Cleanup old.
18 May 2014; Hans de Graaff <graaff@gentoo.org> ruby_parser-3.6.1.ebuild:
Add ruby21.
diff --git a/dev-ruby/ruby_parser/ruby_parser-3.6.0.ebuild b/dev-ruby/ruby_parser/ruby_parser-3.6.0.ebuild
deleted file mode 100644
index 460faf7a7010..000000000000
--- a/dev-ruby/ruby_parser/ruby_parser-3.6.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby_parser/ruby_parser-3.6.0.ebuild,v 1.1 2014/04/25 00:08:51 mrueg Exp $
-
-EAPI=5
-
-USE_RUBY="ruby19 ruby20 jruby"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A ruby parser written in pure ruby."
-HOMEPAGE="https://github.com/seattlerb/ruby_parser"
-
-LICENSE="MIT"
-SLOT="3"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/sexp_processor-4.1:4
- !<dev-ruby/ruby_parser-2.3.1-r1"
-
-ruby_add_bdepend "doc? ( >=dev-ruby/hoe-2.9.1 )"
-ruby_add_bdepend "test? ( >=dev-ruby/minitest-4.3 )"
-
-all_ruby_prepare() {
- # Remove reference to perforce method that is not in a released
- # version of hoe-seattlerb.
- #sed -i -e '/perforce/d' Rakefile || die
- sed -i -e '/license/d' Rakefile || die
- sed -i -e '/Hoe.plugin :isolate/ s:^:#:' Rakefile || die
-}
-
-each_ruby_prepare() {
- case ${RUBY} in
- *jruby)
- # Disable tests failing on jruby related to //n regexp
- # https://github.com/seattlerb/ruby_parser/issues/117
- rm test/test_ruby_parser.rb || die
- ;;
- esac
-}
diff --git a/dev-ruby/ruby_parser/ruby_parser-3.4.1.ebuild b/dev-ruby/ruby_parser/ruby_parser-3.6.2.ebuild
index 1906f0825558..b4c319cf18a8 100644
--- a/dev-ruby/ruby_parser/ruby_parser-3.4.1.ebuild
+++ b/dev-ruby/ruby_parser/ruby_parser-3.6.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby_parser/ruby_parser-3.4.1.ebuild,v 1.2 2014/04/05 14:21:52 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby_parser/ruby_parser-3.6.2.ebuild,v 1.1 2014/08/01 17:37:45 mrueg Exp $
EAPI=5
-USE_RUBY="ruby19 ruby20 jruby"
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
RUBY_FAKEGEM_TASK_DOC="docs"
RUBY_FAKEGEM_DOCDIR="doc"