summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-07-20 06:06:08 +0000
committerHans de Graaff <graaff@gentoo.org>2013-07-20 06:06:08 +0000
commit2e6b7294b297f1bca286781a1e79343a4907feab (patch)
tree889d43041d454b09f6dabbb80141984f26f2b184 /dev-ruby/rcairo
parentVersion bump. (diff)
downloadgentoo-2-2e6b7294b297f1bca286781a1e79343a4907feab.tar.gz
gentoo-2-2e6b7294b297f1bca286781a1e79343a4907feab.tar.bz2
gentoo-2-2e6b7294b297f1bca286781a1e79343a4907feab.zip
Version bump.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/rcairo')
-rw-r--r--dev-ruby/rcairo/ChangeLog7
-rw-r--r--dev-ruby/rcairo/rcairo-1.12.6.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/dev-ruby/rcairo/ChangeLog b/dev-ruby/rcairo/ChangeLog
index 7493b2655c80..493c342f9b98 100644
--- a/dev-ruby/rcairo/ChangeLog
+++ b/dev-ruby/rcairo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rcairo
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcairo/ChangeLog,v 1.81 2013/04/14 07:04:27 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcairo/ChangeLog,v 1.82 2013/07/20 06:06:08 graaff Exp $
+
+*rcairo-1.12.6 (20 Jul 2013)
+
+ 20 Jul 2013; Hans de Graaff <graaff@gentoo.org> +rcairo-1.12.6.ebuild:
+ Version bump.
*rcairo-1.12.4 (14 Apr 2013)
diff --git a/dev-ruby/rcairo/rcairo-1.12.6.ebuild b/dev-ruby/rcairo/rcairo-1.12.6.ebuild
new file mode 100644
index 000000000000..8f38d972edd9
--- /dev/null
+++ b/dev-ruby/rcairo/rcairo-1.12.6.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcairo/rcairo-1.12.6.ebuild,v 1.1 2013/07/20 06:06:08 graaff Exp $
+
+EAPI=5
+
+# jruby → cannot work, it's a compiled extension
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_NAME="cairo"
+
+# Documentation depends on files that are not distributed.
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="AUTHORS NEWS"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Ruby bindings for cairo"
+HOMEPAGE="http://cairographics.org/rcairo/"
+
+IUSE=""
+
+SLOT="0"
+LICENSE="|| ( Ruby GPL-2 )"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="${RDEPEND}
+ >=x11-libs/cairo-1.2.0[svg]"
+DEPEND="${DEPEND}
+ >=x11-libs/cairo-1.2.0[svg]"
+
+ruby_add_bdepend "
+ dev-ruby/pkg-config
+ dev-ruby/ruby-glib2
+ test? ( >=dev-ruby/test-unit-2.1.0-r1:2 )"
+
+each_ruby_configure() {
+ ${RUBY} -Cext/cairo extconf.rb || die "extconf failed"
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/cairo || die "make failed"
+
+ # again, try to make it more standard, to install it more easily.
+ cp ext/cairo/cairo$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ # don't rely on the Rakefile because it's a mess to load with
+ # their hierarchy, do it manually.
+ ${RUBY} -Ilib -r ./test/cairo-test-utils.rb \
+ -e 'gem "test-unit"; require "test/unit"; Dir.glob("test/**/test_*.rb") {|f| load f}' || die "tests failed"
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ insinto $(ruby_get_hdrdir)
+ doins ext/cairo/rb_cairo.h || die "Cannot install header file."
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/samples
+ doins -r samples/* || die "Cannot install sample files."
+}