summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-06-08 18:27:59 +0000
committerHans de Graaff <graaff@gentoo.org>2011-06-08 18:27:59 +0000
commitc5ffb8ca93420ca0c1a04f02e8b020a2ba6adc2c (patch)
treea2a5a723b10cbe47835aff8b20bf171f3e5eed34 /dev-ruby/rake-compiler
parentamd64/x86 stable, bug #369377 (diff)
downloadgentoo-2-c5ffb8ca93420ca0c1a04f02e8b020a2ba6adc2c.tar.gz
gentoo-2-c5ffb8ca93420ca0c1a04f02e8b020a2ba6adc2c.tar.bz2
gentoo-2-c5ffb8ca93420ca0c1a04f02e8b020a2ba6adc2c.zip
Remove old versions.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rake-compiler')
-rw-r--r--dev-ruby/rake-compiler/ChangeLog6
-rw-r--r--dev-ruby/rake-compiler/rake-compiler-0.7.6.ebuild55
-rw-r--r--dev-ruby/rake-compiler/rake-compiler-0.7.7.ebuild55
3 files changed, 5 insertions, 111 deletions
diff --git a/dev-ruby/rake-compiler/ChangeLog b/dev-ruby/rake-compiler/ChangeLog
index c288243c5f84..7f890f3e1121 100644
--- a/dev-ruby/rake-compiler/ChangeLog
+++ b/dev-ruby/rake-compiler/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/rake-compiler
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/ChangeLog,v 1.38 2011/04/28 17:08:46 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/ChangeLog,v 1.39 2011/06/08 18:27:59 graaff Exp $
+
+ 08 Jun 2011; Hans de Graaff <graaff@gentoo.org> -rake-compiler-0.7.6.ebuild,
+ -rake-compiler-0.7.7.ebuild:
+ Remove old versions.
*rake-compiler-0.7.8 (28 Apr 2011)
diff --git a/dev-ruby/rake-compiler/rake-compiler-0.7.6.ebuild b/dev-ruby/rake-compiler/rake-compiler-0.7.6.ebuild
deleted file mode 100644
index 0c54a90f39ea..000000000000
--- a/dev-ruby/rake-compiler/rake-compiler-0.7.6.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/rake-compiler-0.7.6.ebuild,v 1.2 2011/03/05 07:18:06 graaff Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18 ruby19 jruby"
-
-# Tests for now seem only to work when rubygems is fully installed for
-# the implementation and that for now only means Ruby 1.8
-RUBY_FAKEGEM_TASK_TEST="-f tasks/rspec.rake -f tasks/cucumber.rake spec cucumber"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="Provide a standard and simplified way to build and package Ruby extensions"
-HOMEPAGE="http://github.com/luislavena/rake-compiler"
-LICENSE="as-is" # truly
-
-SRC_URI="http://github.com/luislavena/${PN}/tarball/v${PV} -> ${P}.tar.gz"
-S="${WORKDIR}/luislavena-${PN}-*"
-
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-USE_RUBY=ruby18 \
- ruby_add_bdepend "test? ( dev-ruby/rspec:0 dev-util/cucumber dev-ruby/rubygems )"
-
-ruby_add_rdepend "dev-ruby/rake"
-
-each_ruby_prepare() {
- case ${RUBY} in
- *ruby19|*jruby)
- # Remove this task so that it won't load on Ruby 1.9 and JRuby
- # that lack the package_task file. It is, though, needed for the
- # tests
- rm tasks/gem.rake || die
- ;;
- *)
- ;;
- esac
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *ruby19|*jruby)
- ewarn "Tests disabled for this implementation. Long story, check ebuild if you want."
- ;;
- *)
- each_fakegem_test
- ;;
- esac
-}
diff --git a/dev-ruby/rake-compiler/rake-compiler-0.7.7.ebuild b/dev-ruby/rake-compiler/rake-compiler-0.7.7.ebuild
deleted file mode 100644
index 9c9004f4e8e6..000000000000
--- a/dev-ruby/rake-compiler/rake-compiler-0.7.7.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/rake-compiler-0.7.7.ebuild,v 1.1 2011/04/08 05:47:42 graaff Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18 ruby19 jruby"
-
-# Tests for now seem only to work when rubygems is fully installed for
-# the implementation and that for now only means Ruby 1.8
-RUBY_FAKEGEM_TASK_TEST="-f tasks/rspec.rake -f tasks/cucumber.rake spec cucumber"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="Provide a standard and simplified way to build and package Ruby extensions"
-HOMEPAGE="http://github.com/luislavena/rake-compiler"
-LICENSE="as-is" # truly
-
-SRC_URI="http://github.com/luislavena/${PN}/tarball/v${PV} -> ${P}.tar.gz"
-S="${WORKDIR}/luislavena-${PN}-*"
-
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-USE_RUBY=ruby18 \
- ruby_add_bdepend "test? ( dev-ruby/rspec:0 dev-util/cucumber dev-ruby/rubygems )"
-
-ruby_add_rdepend "dev-ruby/rake"
-
-each_ruby_prepare() {
- case ${RUBY} in
- *ruby19|*jruby)
- # Remove this task so that it won't load on Ruby 1.9 and JRuby
- # that lack the package_task file. It is, though, needed for the
- # tests
- rm tasks/gem.rake || die
- ;;
- *)
- ;;
- esac
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *ruby19|*jruby)
- ewarn "Tests disabled for this implementation. Long story, check ebuild if you want."
- ;;
- *)
- each_fakegem_test
- ;;
- esac
-}