summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-03-27 06:31:49 +0000
committerHans de Graaff <graaff@gentoo.org>2014-03-27 06:31:49 +0000
commitf426075cab488955d8b6fb5482920da95b7773dd (patch)
tree0d716985350dcdaa60b954199250bf31bf32a056 /dev-ruby/protected_attributes
parentFix build w/newer glibc, and simplify install phase. (diff)
downloadgentoo-2-f426075cab488955d8b6fb5482920da95b7773dd.tar.gz
gentoo-2-f426075cab488955d8b6fb5482920da95b7773dd.tar.bz2
gentoo-2-f426075cab488955d8b6fb5482920da95b7773dd.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/protected_attributes')
-rw-r--r--dev-ruby/protected_attributes/ChangeLog8
-rw-r--r--dev-ruby/protected_attributes/protected_attributes-1.0.7.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-ruby/protected_attributes/ChangeLog b/dev-ruby/protected_attributes/ChangeLog
index fda2da0a4b09..fc97f59ed477 100644
--- a/dev-ruby/protected_attributes/ChangeLog
+++ b/dev-ruby/protected_attributes/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/protected_attributes
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/protected_attributes/ChangeLog,v 1.2 2014/02/13 08:10:27 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/protected_attributes/ChangeLog,v 1.3 2014/03/27 06:31:49 graaff Exp $
+
+*protected_attributes-1.0.7 (27 Mar 2014)
+
+ 27 Mar 2014; Hans de Graaff <graaff@gentoo.org>
+ +protected_attributes-1.0.7.ebuild:
+ Version bump.
*protected_attributes-1.0.5 (13 Feb 2014)
diff --git a/dev-ruby/protected_attributes/protected_attributes-1.0.7.ebuild b/dev-ruby/protected_attributes/protected_attributes-1.0.7.ebuild
new file mode 100644
index 000000000000..7b73dd724450
--- /dev/null
+++ b/dev-ruby/protected_attributes/protected_attributes-1.0.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/protected_attributes/protected_attributes-1.0.7.ebuild,v 1.1 2014/03/27 06:31:49 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Protect attributes from mass-assignment in ActiveRecord models"
+HOMEPAGE="https://github.com/rails/protected_attributes"
+SRC_URI="https://github.com/rails/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="1"
+
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend "
+ =dev-ruby/activemodel-4*
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ =dev-ruby/actionpack-4*
+ =dev-ruby/activerecord-4*
+ dev-ruby/mocha
+ dev-ruby/sqlite3
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/github/ s:^:#:' Gemfile || die
+}