summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-06-17 06:01:28 +0000
committerHans de Graaff <graaff@gentoo.org>2014-06-17 06:01:28 +0000
commit0bf7dcf345133c7976c554b19c97220356edbde6 (patch)
treefb7a6d04f7dd69d1042e1129426426254ac42505 /dev-ruby/protected_attributes
parentbump; clean python impls py2.6 py3.2, add py3.4, add new dep for testsuite (diff)
downloadgentoo-2-0bf7dcf345133c7976c554b19c97220356edbde6.tar.gz
gentoo-2-0bf7dcf345133c7976c554b19c97220356edbde6.tar.bz2
gentoo-2-0bf7dcf345133c7976c554b19c97220356edbde6.zip
Version bump. Support forthcoming versions of Rails.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/protected_attributes')
-rw-r--r--dev-ruby/protected_attributes/ChangeLog8
-rw-r--r--dev-ruby/protected_attributes/protected_attributes-1.0.8.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-ruby/protected_attributes/ChangeLog b/dev-ruby/protected_attributes/ChangeLog
index 5429cf519595..faeed8ad20f8 100644
--- a/dev-ruby/protected_attributes/ChangeLog
+++ b/dev-ruby/protected_attributes/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/protected_attributes
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/protected_attributes/ChangeLog,v 1.5 2014/05/02 05:52:28 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/protected_attributes/ChangeLog,v 1.6 2014/06/17 06:01:28 graaff Exp $
+
+*protected_attributes-1.0.8 (17 Jun 2014)
+
+ 17 Jun 2014; Hans de Graaff <graaff@gentoo.org>
+ +protected_attributes-1.0.8.ebuild:
+ Version bump. Support forthcoming versions of Rails.
02 May 2014; Hans de Graaff <graaff@gentoo.org>
protected_attributes-1.0.7.ebuild:
diff --git a/dev-ruby/protected_attributes/protected_attributes-1.0.8.ebuild b/dev-ruby/protected_attributes/protected_attributes-1.0.8.ebuild
new file mode 100644
index 000000000000..63ba398a7025
--- /dev/null
+++ b/dev-ruby/protected_attributes/protected_attributes-1.0.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/protected_attributes/protected_attributes-1.0.8.ebuild,v 1.1 2014/06/17 06:01:28 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Protect attributes from mass-assignment in ActiveRecord models"
+HOMEPAGE="https://github.com/rails/protected_attributes"
+SRC_URI="https://github.com/rails/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="1"
+
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend "
+ =dev-ruby/activemodel-4* >=dev-ruby/activemodel-4.0.1
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ =dev-ruby/actionpack-4*
+ =dev-ruby/activerecord-4*
+ dev-ruby/mocha
+ dev-ruby/sqlite3
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/github/ s:^:#:' Gemfile || die
+}