summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-12-11 09:22:34 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-12-11 09:22:34 +0000
commit0490d1d31c7b23cc38c9e4453554e0ee860cc665 (patch)
tree3cd880390fbabc6a1bc52e5022049a69e98b58c7 /dev-ruby/posix-spawn
parentnet-analyzer/linkchecker: Add live ebuild; backport upstream fix and drop bad... (diff)
downloadgentoo-2-0490d1d31c7b23cc38c9e4453554e0ee860cc665.tar.gz
gentoo-2-0490d1d31c7b23cc38c9e4453554e0ee860cc665.tar.bz2
gentoo-2-0490d1d31c7b23cc38c9e4453554e0ee860cc665.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/posix-spawn')
-rw-r--r--dev-ruby/posix-spawn/ChangeLog10
-rw-r--r--dev-ruby/posix-spawn/posix-spawn-0.3.8.ebuild34
2 files changed, 41 insertions, 3 deletions
diff --git a/dev-ruby/posix-spawn/ChangeLog b/dev-ruby/posix-spawn/ChangeLog
index 1ae045cb957f..b92af0d91314 100644
--- a/dev-ruby/posix-spawn/ChangeLog
+++ b/dev-ruby/posix-spawn/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/posix-spawn
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/posix-spawn/ChangeLog,v 1.2 2011/12/04 11:08:36 graaff Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/posix-spawn/ChangeLog,v 1.3 2013/12/11 09:22:34 mrueg Exp $
+
+*posix-spawn-0.3.8 (11 Dec 2013)
+
+ 11 Dec 2013; Manuel Rüger <mrueg@gentoo.org> +posix-spawn-0.3.8.ebuild:
+ Version bump.
04 Dec 2011; Hans de Graaff <graaff@gentoo.org> posix-spawn-0.3.6.ebuild:
Merge the ebuild from my overlay. Fix USE=doc, run tests since they work for
@@ -11,4 +16,3 @@
24 Apr 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+posix-spawn-0.3.6.ebuild, +metadata.xml:
Initial import of the posix-spawn gem.
-
diff --git a/dev-ruby/posix-spawn/posix-spawn-0.3.8.ebuild b/dev-ruby/posix-spawn/posix-spawn-0.3.8.ebuild
new file mode 100644
index 000000000000..3d19b81d6556
--- /dev/null
+++ b/dev-ruby/posix-spawn/posix-spawn-0.3.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/posix-spawn/posix-spawn-0.3.8.ebuild,v 1.1 2013/12/11 09:22:34 mrueg Exp $
+
+EAPI=5
+
+# jruby → should be supported but does not work with "rake compile"
+USE_RUBY="ruby18 ruby19"
+KEYWORDS="~amd64"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md TODO HACKING"
+
+inherit ruby-fakegem
+
+DESCRIPTION="The posix-spawn library aims to implement a subset of the Ruby 1.9 Process::spawn"
+HOMEPAGE="https://github.com/rtomayko/posix-spawn/"
+
+LICENSE="MIT LGPL-2.1"
+SLOT="0"
+IUSE="test"
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext
+ cp ext/*$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S testrb test || die
+}