summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-01-29 01:03:16 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-01-29 01:03:16 +0000
commit80e0c29383a175403532478026c34b9b3806957c (patch)
tree701714d6922c9ff276c99c599dd547ceb425a5aa /dev-ruby/podcast/podcast-0.0.4-r2.ebuild
parentAdd ruby20, ruby21 support. Cleanup old. (diff)
downloadgentoo-2-80e0c29383a175403532478026c34b9b3806957c.tar.gz
gentoo-2-80e0c29383a175403532478026c34b9b3806957c.tar.bz2
gentoo-2-80e0c29383a175403532478026c34b9b3806957c.zip
Add ruby20 support. Remove ruby18 support.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/podcast/podcast-0.0.4-r2.ebuild')
-rw-r--r--dev-ruby/podcast/podcast-0.0.4-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/podcast/podcast-0.0.4-r2.ebuild b/dev-ruby/podcast/podcast-0.0.4-r2.ebuild
new file mode 100644
index 000000000000..2f3a036cf135
--- /dev/null
+++ b/dev-ruby/podcast/podcast-0.0.4-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/podcast/podcast-0.0.4-r2.ebuild,v 1.1 2014/01/29 01:03:15 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure Ruby library for generating podcasts from mp3 files"
+HOMEPAGE="http://podcast.rubyforge.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="test"
+
+ruby_add_rdepend "dev-ruby/ruby-mp3info"
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/ts_podcast.rb || die "Tests failed."
+}