summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-06-27 07:38:03 +0000
committerHans de Graaff <graaff@gentoo.org>2010-06-27 07:38:03 +0000
commitbfa6c932c403bbc41b0b6d78cad293eb43b64266 (patch)
tree2f35ca0220578258a1fc84a53261e8fa4a7146fd /dev-ruby/plruby
parentFix Manifest and signature (diff)
downloadgentoo-2-bfa6c932c403bbc41b0b6d78cad293eb43b64266.tar.gz
gentoo-2-bfa6c932c403bbc41b0b6d78cad293eb43b64266.tar.bz2
gentoo-2-bfa6c932c403bbc41b0b6d78cad293eb43b64266.zip
Version bump. Convert to ruby-ng. Fix build system to work with other ruby versions installed.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/plruby')
-rw-r--r--dev-ruby/plruby/ChangeLog9
-rw-r--r--dev-ruby/plruby/files/plruby-0.5.4-fix-build-system.patch63
-rw-r--r--dev-ruby/plruby/plruby-0.5.4.ebuild48
3 files changed, 119 insertions, 1 deletions
diff --git a/dev-ruby/plruby/ChangeLog b/dev-ruby/plruby/ChangeLog
index 3638766d1f5d..c1ffa42741ef 100644
--- a/dev-ruby/plruby/ChangeLog
+++ b/dev-ruby/plruby/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/plruby
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/plruby/ChangeLog,v 1.13 2010/06/17 19:54:41 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/plruby/ChangeLog,v 1.14 2010/06/27 07:38:03 graaff Exp $
+
+*plruby-0.5.4 (27 Jun 2010)
+
+ 27 Jun 2010; Hans de Graaff <graaff@gentoo.org> +plruby-0.5.4.ebuild,
+ +files/plruby-0.5.4-fix-build-system.patch:
+ Version bump. Convert to ruby-ng. Fix build system to work with other ruby
+ versions installed.
17 Jun 2010; Patrick Lauer <patrick@gentoo.org> plruby-0.4.2.ebuild,
plruby-0.5.3.ebuild:
diff --git a/dev-ruby/plruby/files/plruby-0.5.4-fix-build-system.patch b/dev-ruby/plruby/files/plruby-0.5.4-fix-build-system.patch
new file mode 100644
index 000000000000..30d5c0463156
--- /dev/null
+++ b/dev-ruby/plruby/files/plruby-0.5.4-fix-build-system.patch
@@ -0,0 +1,63 @@
+diff --git a/extconf.rb b/extconf.rb
+index 06a6284..f8c04e9 100755
+--- a/extconf.rb
++++ b/extconf.rb
+@@ -156,6 +156,8 @@ if macro_defined?("PG_TRY", %Q{#include "c.h"\n#include "utils/elog.h"})
+ $CFLAGS += " -DPG_PL_TRYCATCH"
+ end
+
++have_library('pq', 'PQconnectdb')
++
+ enable_conversion = false
+ if enable_conversion = enable_config("conversion", true)
+ $CFLAGS += " -DPLRUBY_ENABLE_CONVERSION"
+diff --git a/src/conversions/basic/extconf.rb b/src/conversions/basic/extconf.rb
+index d4833b8..f788d9c 100644
+--- a/src/conversions/basic/extconf.rb
++++ b/src/conversions/basic/extconf.rb
+@@ -4,4 +4,5 @@ if CONFIG["LIBRUBYARG"] == "$(LIBRUBYARG_SHARED)" &&
+ !enable_config("plruby-shared")
+ $LIBRUBYARG = ""
+ end
++have_library('ruby18', 'ruby_init')
+ create_makefile('plruby/plruby_basic')
+diff --git a/src/conversions/bitstring/extconf.rb b/src/conversions/bitstring/extconf.rb
+index e980c1e..b6f89d3 100644
+--- a/src/conversions/bitstring/extconf.rb
++++ b/src/conversions/bitstring/extconf.rb
+@@ -4,4 +4,5 @@ if CONFIG["LIBRUBYARG"] == "$(LIBRUBYARG_SHARED)" &&
+ !enable_config("plruby-shared")
+ $LIBRUBYARG = ""
+ end
++have_library('ruby18', 'ruby_init')
+ create_makefile('plruby/plruby_bitstring')
+diff --git a/src/conversions/datetime/extconf.rb b/src/conversions/datetime/extconf.rb
+index c5de23b..caeebea 100644
+--- a/src/conversions/datetime/extconf.rb
++++ b/src/conversions/datetime/extconf.rb
+@@ -4,4 +4,5 @@ if CONFIG["LIBRUBYARG"] == "$(LIBRUBYARG_SHARED)" &&
+ !enable_config("plruby-shared")
+ $LIBRUBYARG = ""
+ end
++have_library('ruby18', 'ruby_init')
+ create_makefile('plruby/plruby_datetime')
+diff --git a/src/conversions/geometry/extconf.rb b/src/conversions/geometry/extconf.rb
+index 9fcf48e..74655b3 100644
+--- a/src/conversions/geometry/extconf.rb
++++ b/src/conversions/geometry/extconf.rb
+@@ -4,4 +4,5 @@ if CONFIG["LIBRUBYARG"] == "$(LIBRUBYARG_SHARED)" &&
+ !enable_config("plruby-shared")
+ $LIBRUBYARG = ""
+ end
++have_library('ruby18', 'ruby_init')
+ create_makefile('plruby/plruby_geometry')
+diff --git a/src/conversions/network/extconf.rb b/src/conversions/network/extconf.rb
+index 29952ee..612e7fa 100644
+--- a/src/conversions/network/extconf.rb
++++ b/src/conversions/network/extconf.rb
+@@ -4,4 +4,5 @@ if CONFIG["LIBRUBYARG"] == "$(LIBRUBYARG_SHARED)" &&
+ !enable_config("plruby-shared")
+ $LIBRUBYARG = ""
+ end
++have_library('ruby18', 'ruby_init')
+ create_makefile('plruby/plruby_network')
diff --git a/dev-ruby/plruby/plruby-0.5.4.ebuild b/dev-ruby/plruby/plruby-0.5.4.ebuild
new file mode 100644
index 000000000000..4aa742962067
--- /dev/null
+++ b/dev-ruby/plruby/plruby-0.5.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/plruby/plruby-0.5.4.ebuild,v 1.1 2010/06/27 07:38:03 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+inherit ruby-ng
+
+GITHUB_USER="knu"
+
+DESCRIPTION="plruby language for PostgreSQL"
+HOMEPAGE="http://github.com/knu/postgresql-plruby"
+SRC_URI="http://github.com/${GITHUB_USER}/postgresql-plruby/tarball/v${PV} -> ${P}.tgz"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="${DEPEND} dev-db/postgresql-server"
+RDEPEND="${RDEPEND} dev-db/postgresql-server"
+
+RUBY_PATCHES=( "${P}-fix-build-system.patch" )
+
+S="${WORKDIR}"/${GITHUB_USER}-postgresql-plruby-*
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die
+}
+
+each_ruby_compile() {
+ # We have injected --no-undefined in Ruby as a safety precaution
+ # against broken ebuilds, but these bindings unfortunately rely on
+ # the lazy load of other extensions; see bug #320545.
+ find . -name Makefile -print0 | xargs -0 \
+ sed -i -e 's:-Wl,--no-undefined::' || die "--no-undefined removal failed"
+
+ emake || die
+}
+
+each_ruby_install() {
+ emake install DESTDIR="${D}"
+}
+
+all_ruby_install() {
+ dodoc Changes plruby.html plruby.rd README.en
+}