summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-12-20 06:46:22 +0000
committerHans de Graaff <graaff@gentoo.org>2012-12-20 06:46:22 +0000
commitdce43cc5ca639c3297fdccb2912fe4a905fe3d87 (patch)
tree3f4ee3bee8b5df738f20d92ada14f38fc37dbc8c /dev-ruby/nokogiri
parentRemove pypy version mapping table from wrapper scripts. We can add it back if... (diff)
downloadgentoo-2-dce43cc5ca639c3297fdccb2912fe4a905fe3d87.tar.gz
gentoo-2-dce43cc5ca639c3297fdccb2912fe4a905fe3d87.tar.bz2
gentoo-2-dce43cc5ca639c3297fdccb2912fe4a905fe3d87.zip
Cleanup.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/nokogiri')
-rw-r--r--dev-ruby/nokogiri/ChangeLog6
-rw-r--r--dev-ruby/nokogiri/nokogiri-1.4.4-r1.ebuild77
-rw-r--r--dev-ruby/nokogiri/nokogiri-1.5.2.ebuild103
3 files changed, 5 insertions, 181 deletions
diff --git a/dev-ruby/nokogiri/ChangeLog b/dev-ruby/nokogiri/ChangeLog
index 17f56b6969db..560f8cc3b828 100644
--- a/dev-ruby/nokogiri/ChangeLog
+++ b/dev-ruby/nokogiri/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/nokogiri
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/ChangeLog,v 1.84 2012/12/01 18:56:35 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/ChangeLog,v 1.85 2012/12/20 06:46:22 graaff Exp $
+
+ 20 Dec 2012; Hans de Graaff <graaff@gentoo.org> -nokogiri-1.4.4-r1.ebuild,
+ -nokogiri-1.5.2.ebuild:
+ Cleanup.
01 Dec 2012; Raúl Porcel <armin76@gentoo.org> nokogiri-1.5.5.ebuild:
alpha/ia64/sparc/x86 stable wrt #440094
diff --git a/dev-ruby/nokogiri/nokogiri-1.4.4-r1.ebuild b/dev-ruby/nokogiri/nokogiri-1.4.4-r1.ebuild
deleted file mode 100644
index 761f555d5a10..000000000000
--- a/dev-ruby/nokogiri/nokogiri-1.4.4-r1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/nokogiri-1.4.4-r1.ebuild,v 1.10 2012/10/28 17:46:30 armin76 Exp $
-
-EAPI=2
-
-USE_RUBY="ruby18 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc CHANGELOG.ja.rdoc README.rdoc README.ja.rdoc"
-
-inherit ruby-fakegem eutils multilib
-
-DESCRIPTION="Nokogiri is an HTML, XML, SAX, and Reader parser."
-HOMEPAGE="http://nokogiri.rubyforge.org/"
-LICENSE="MIT"
-
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-SLOT="0"
-IUSE="ffi"
-
-RDEPEND="${RDEPEND}
- dev-libs/libxml2
- dev-libs/libxslt"
-DEPEND="${DEPEND}
- dev-libs/libxml2
- dev-libs/libxslt"
-
-# The tests require _minitest_, not the virtual; what is shipped with
-# Ruby 1.9 is *not* enough, unfortunately
-ruby_add_bdepend "
- dev-ruby/rake-compiler
- dev-ruby/rexical
- dev-ruby/hoe
- dev-ruby/racc
- doc? ( dev-ruby/rdoc )
- test? ( dev-ruby/minitest )"
-
-ruby_add_rdepend "ffi? ( virtual/ruby-ffi )"
-
-USE_RUBY=jruby ruby_add_rdepend "dev-ruby/weakling"
-
-all_ruby_prepare() {
- epatch "${FILESDIR}/${P}-libxml-2.7.8.patch"
-
- sed -i \
- -e '/tasks\/cross_compile/s:^:#:' \
- -e '/:test.*prerequisites/s:^:#:' \
- Rakefile || die
-}
-
-nokogiri_ffi() {
- [[ $(basename ${RUBY}) == "jruby" ]] || use ffi
-}
-
-each_ruby_configure() {
- nokogiri_ffi && return
- ${RUBY} -Cext/${PN} extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- if ! [[ -f lib/nokogiri/css/generated_tokenizer.rb ]]; then
- ${RUBY} -S rake lib/nokogiri/css/generated_tokenizer.rb || die "rexical failed"
- fi
-
- nokogiri_ffi && return
- emake -Cext/${PN} \
- CFLAGS="${CFLAGS} -fPIC" \
- archflag="${LDFLAGS}" || die "make extension failed"
- cp -l ext/${PN}/${PN}$(get_modname) lib/${PN}/ || die
-}
-
-each_ruby_test() {
- nokogiri_ffi && export NOKOGIRI_FFI=yes
- each_fakegem_test
-}
diff --git a/dev-ruby/nokogiri/nokogiri-1.5.2.ebuild b/dev-ruby/nokogiri/nokogiri-1.5.2.ebuild
deleted file mode 100644
index 78d56720d914..000000000000
--- a/dev-ruby/nokogiri/nokogiri-1.5.2.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/nokogiri-1.5.2.ebuild,v 1.9 2012/11/06 17:06:59 jer Exp $
-
-EAPI=4
-
-USE_RUBY="ruby18 ruby19 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc CHANGELOG.ja.rdoc README.rdoc README.ja.rdoc"
-
-inherit ruby-fakegem eutils multilib
-
-DESCRIPTION="Nokogiri is an HTML, XML, SAX, and Reader parser."
-HOMEPAGE="http://nokogiri.rubyforge.org/"
-LICENSE="MIT"
-SRC_URI="https://github.com/tenderlove/nokogiri/tarball/v${PV} -> ${P}.tgz"
-RUBY_S="tenderlove-nokogiri-*"
-
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-RDEPEND="${RDEPEND}
- dev-libs/libxml2
- dev-libs/libxslt"
-DEPEND="${DEPEND}
- dev-libs/libxml2
- dev-libs/libxslt"
-
-# The tests require _minitest_, not the virtual; what is shipped with
-# Ruby 1.9 is *not* enough, unfortunately
-ruby_add_bdepend "
- dev-ruby/rake-compiler
- dev-ruby/rexical
- dev-ruby/hoe
- dev-ruby/rdoc
- dev-ruby/racc
- test? ( dev-ruby/minitest )"
-
-# tests currently work only with Ruby 1.9; there is a small issue with
-# JRuby, but it's insignificant, while 1.8 and EE 1.8 are failing due to
-# the hashing order changes.
-RESTRICT="ruby_targets_ruby18? ( test )
- ruby_targets_ree18? ( test )
- ruby_targets_jruby? ( test )"
-
-all_ruby_prepare() {
- sed -i \
- -e '/tasks\/cross_compile/s:^:#:' \
- -e '/:test.*prerequisites/s:^:#:' \
- Rakefile || die
- # Remove the cross compilation options since they interfere with
- # native building.
- sed -i -e 's/cross_compile = true/cross_compile = false/' Rakefile || die
- sed -i -e '/cross_config_options/d' Rakefile || die
-}
-
-each_ruby_configure() {
- case ${RUBY} in
- *jruby)
- ;;
- *)
- ${RUBY} -Cext/${PN} extconf.rb \
- --with-zlib-include="${EPREFIX}"/usr/include \
- --with-zlib-lib="${EPREFIX}"/$(get_libdir) \
- --with-iconv-include="${EPREFIX}"/usr/include \
- --with-iconv-lib="${EPREFIX}"/$(get_libdir) \
- --with-xml2-include="${EPREFIX}"/usr/include/libxml2 \
- --with-xml2-lib="${EPREFIX}"/usr/$(get_libdir) \
- --with-xslt-dir="${EPREFIX}"/usr \
- --with-iconvlib=iconv \
- || die "extconf.rb failed"
- ;;
- esac
-}
-
-each_ruby_compile() {
- case ${RUBY} in
- *jruby)
- if ! [[ -f lib/nokogiri/css/parser.rb ]]; then
- ${RUBY} -S rake lib/nokogiri/css/parser.rb || die "racc failed"
- fi
-
- ${RUBY} -S rake compile || die
- ;;
- *)
- if ! [[ -f lib/nokogiri/css/tokenizer.rb ]]; then
- ${RUBY} -S rake lib/nokogiri/css/tokenizer.rb || die "rexical failed"
- fi
-
- if ! [[ -f lib/nokogiri/css/parser.rb ]]; then
- ${RUBY} -S rake lib/nokogiri/css/parser.rb || die "racc failed"
- fi
-
- emake -Cext/${PN} \
- CFLAGS="${CFLAGS} -fPIC" \
- archflag="${LDFLAGS}" || die "make extension failed"
- cp -l ext/${PN}/${PN}$(get_modname) lib/${PN}/ || die
- ;;
- esac
-}