summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-13 21:20:30 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-13 21:20:30 +0000
commit6878786302e9f8a66b461ee5650342f347766d71 (patch)
treec15bd7789f22738abcb8b7ee93c5fff9444bee3f /dev-ruby/mixlib-log
parentAdd a cucumber wrapper similar to the rspec one we have already. (diff)
downloadgentoo-2-6878786302e9f8a66b461ee5650342f347766d71.tar.gz
gentoo-2-6878786302e9f8a66b461ee5650342f347766d71.tar.bz2
gentoo-2-6878786302e9f8a66b461ee5650342f347766d71.zip
Convert to use from Rake to rspec+cucumber directly; use the newly introduced helper for cucumber as well.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/mixlib-log')
-rw-r--r--dev-ruby/mixlib-log/ChangeLog7
-rw-r--r--dev-ruby/mixlib-log/mixlib-log-1.4.1.ebuild19
2 files changed, 17 insertions, 9 deletions
diff --git a/dev-ruby/mixlib-log/ChangeLog b/dev-ruby/mixlib-log/ChangeLog
index c15a81678b3a..70b8041519b3 100644
--- a/dev-ruby/mixlib-log/ChangeLog
+++ b/dev-ruby/mixlib-log/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/mixlib-log
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-log/ChangeLog,v 1.8 2012/08/11 16:13:48 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-log/ChangeLog,v 1.9 2012/08/13 21:20:30 flameeyes Exp $
+
+ 13 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> mixlib-log-1.4.1.ebuild:
+ Convert to use from Rake to rspec+cucumber directly; use the newly introduced
+ helper for cucumber as well.
11 Aug 2012; Hans de Graaff <graaff@gentoo.org> mixlib-log-1.4.1.ebuild:
Avoid unneeded dependency on bundler.
@@ -36,4 +40,3 @@
03 Jul 2010; Benedikt Böhm <hollow@gentoo.org> +mixlib-log-1.1.0.ebuild,
+metadata.xml:
initial ebuild, thanks to Gábor Vészi
-
diff --git a/dev-ruby/mixlib-log/mixlib-log-1.4.1.ebuild b/dev-ruby/mixlib-log/mixlib-log-1.4.1.ebuild
index 6ac9545a25a2..17d997a7b51f 100644
--- a/dev-ruby/mixlib-log/mixlib-log-1.4.1.ebuild
+++ b/dev-ruby/mixlib-log/mixlib-log-1.4.1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-log/mixlib-log-1.4.1.ebuild,v 1.2 2012/08/11 16:13:48 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-log/mixlib-log-1.4.1.ebuild,v 1.3 2012/08/13 21:20:30 flameeyes Exp $
EAPI=4
USE_RUBY="ruby18 ruby19 ree18"
-RUBY_FAKEGEM_TASK_TEST="spec features"
+RUBY_FAKEGEM_RECIPE_TEST="none"
RUBY_FAKEGEM_EXTRA_DOC="README.rdoc"
@@ -19,14 +19,19 @@ RUBY_S="opscode-${PN}-*"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="test"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec:2
+ dev-util/cucumber
+)"
all_ruby_prepare() {
# Avoid unneeded dependency on bundler.
rm Gemfile || die
}
-ruby_add_bdepend "test? (
- dev-ruby/rspec:2
- dev-util/cucumber
-)"
+each_ruby_test() {
+ ruby-ng_rspec
+ ruby-ng_cucumber
+}