summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-26 15:39:29 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-26 15:39:29 +0000
commit654c424ffeba7b318805c10ef747bc7052baa19d (patch)
treefca76a212d90710b2deb02ca8ed41fa22d968092 /dev-ruby/mixlib-log/mixlib-log-1.3.0-r1.ebuild
parentRemove old version. (diff)
downloadgentoo-2-654c424ffeba7b318805c10ef747bc7052baa19d.tar.gz
gentoo-2-654c424ffeba7b318805c10ef747bc7052baa19d.tar.bz2
gentoo-2-654c424ffeba7b318805c10ef747bc7052baa19d.zip
Revision bump to EAPI=4 and RUBY_S. Fixes bug 378143.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/mixlib-log/mixlib-log-1.3.0-r1.ebuild')
-rw-r--r--dev-ruby/mixlib-log/mixlib-log-1.3.0-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/mixlib-log/mixlib-log-1.3.0-r1.ebuild b/dev-ruby/mixlib-log/mixlib-log-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..6ac319bcd4a5
--- /dev/null
+++ b/dev-ruby/mixlib-log/mixlib-log-1.3.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-log/mixlib-log-1.3.0-r1.ebuild,v 1.1 2011/12/26 15:39:29 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="spec features"
+
+RUBY_FAKEGEM_EXTRA_DOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple class based Log mechanism"
+HOMEPAGE="http://github.com/opscode/mixlib-log"
+SRC_URI="https://github.com/opscode/${PN}/tarball/${PV} -> ${P}.tgz"
+RUBY_S="opscode-${PN}-*"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:0 dev-util/cucumber )"