summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-01-13 06:45:56 +0000
committerHans de Graaff <graaff@gentoo.org>2010-01-13 06:45:56 +0000
commit5aaaf9022e802628cc863a053c8ab6156af635c9 (patch)
tree3a41bf5761c6e29d8051c331e647bf9900db0cca /dev-ruby/log4r
parentFix Manifest (diff)
downloadgentoo-2-5aaaf9022e802628cc863a053c8ab6156af635c9.tar.gz
gentoo-2-5aaaf9022e802628cc863a053c8ab6156af635c9.tar.bz2
gentoo-2-5aaaf9022e802628cc863a053c8ab6156af635c9.zip
Version bump. Convert to ruby-fakegem.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/log4r')
-rw-r--r--dev-ruby/log4r/ChangeLog9
-rw-r--r--dev-ruby/log4r/log4r-1.1.4.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/dev-ruby/log4r/ChangeLog b/dev-ruby/log4r/ChangeLog
index f6c2b67fde3e..9681d28e803a 100644
--- a/dev-ruby/log4r/ChangeLog
+++ b/dev-ruby/log4r/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/log4r
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/log4r/ChangeLog,v 1.11 2009/12/15 19:23:39 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/log4r/ChangeLog,v 1.12 2010/01/13 06:45:56 graaff Exp $
+
+*log4r-1.1.4 (13 Jan 2010)
+
+ 13 Jan 2010; Hans de Graaff <graaff@gentoo.org> +log4r-1.1.4.ebuild:
+ Version bump. Convert to ruby-fakegem.
15 Dec 2009; Raúl Porcel <armin76@gentoo.org> log4r-1.1.2.ebuild:
ia64 stable wrt #295047
diff --git a/dev-ruby/log4r/log4r-1.1.4.ebuild b/dev-ruby/log4r/log4r-1.1.4.ebuild
new file mode 100644
index 000000000000..6924eb124652
--- /dev/null
+++ b/dev-ruby/log4r/log4r-1.1.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/log4r/log4r-1.1.4.ebuild,v 1.1 2010/01/13 06:45:56 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+# There are no working tests atm, to be checked on next version bump.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README TODO"
+
+RUBY_FAKEGEM_EXTRAINSTALL="src"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Log4r is a comprehensive and flexible logging library written in
+Ruby for use in Ruby programs."
+HOMEPAGE="http://log4r.sourceforge.net/"
+IUSE=""
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/* || die
+}
+
+