summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-08-14 06:39:56 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-08-14 06:39:56 +0000
commit943d0a45d5e543259cf90661fa3e324a82fff024 (patch)
tree662809e172817216d856f3b77e477a5d3b32eb61 /dev-ruby/i18n
parentinitial commit (diff)
downloadgentoo-2-943d0a45d5e543259cf90661fa3e324a82fff024.tar.gz
gentoo-2-943d0a45d5e543259cf90661fa3e324a82fff024.tar.bz2
gentoo-2-943d0a45d5e543259cf90661fa3e324a82fff024.zip
Version bump
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/i18n')
-rw-r--r--dev-ruby/i18n/ChangeLog7
-rw-r--r--dev-ruby/i18n/i18n-0.6.5.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-ruby/i18n/ChangeLog b/dev-ruby/i18n/ChangeLog
index 39fbe3a7b383..cf41045d3aad 100644
--- a/dev-ruby/i18n/ChangeLog
+++ b/dev-ruby/i18n/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/i18n
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/ChangeLog,v 1.54 2013/07/20 07:25:00 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/ChangeLog,v 1.55 2013/08/14 06:39:56 mrueg Exp $
+
+*i18n-0.6.5 (14 Aug 2013)
+
+ 14 Aug 2013; Manuel Rüger <mrueg@gentoo.org> +i18n-0.6.5.ebuild:
+ Version bump
20 Jul 2013; Hans de Graaff <graaff@gentoo.org> -i18n-0.6.0-r1.ebuild,
-i18n-0.6.1.ebuild:
diff --git a/dev-ruby/i18n/i18n-0.6.5.ebuild b/dev-ruby/i18n/i18n-0.6.5.ebuild
new file mode 100644
index 000000000000..2ed0005a42b5
--- /dev/null
+++ b/dev-ruby/i18n/i18n-0.6.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/i18n-0.6.5.ebuild,v 1.1 2013/08/14 06:39:56 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 jruby ruby19"
+
+RUBY_FAKEGEM_RECIPE_TEST="test"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.textile README.textile"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Add Internationalization support to your Ruby application."
+HOMEPAGE="http://rails-i18n.org/"
+
+LICENSE="MIT"
+SLOT="0.6"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/activesupport
+ dev-ruby/mocha:0.12
+ dev-ruby/test_declarative )"
+
+each_ruby_test() {
+ ${RUBY} -w -Ilib -Itest test/all.rb || die
+}
+
+all_ruby_prepare() {
+ #Bundler isn't really necessary here, and it doesn't work with jruby
+ #Tests fail for ruby18 with >=mocha-0.13
+ sed -i -e "15s/require 'bundler\/setup'//"\
+ -e "/require 'mocha'/i gem 'mocha', '~>0.12.0'" test/test_helper.rb || die
+}