summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-05-31 05:46:39 +0000
committerHans de Graaff <graaff@gentoo.org>2015-05-31 05:46:39 +0000
commitcfac7e6e91edfb78bc995c502be544579250c792 (patch)
treedc0ea4742eec08e2bd95cd1c38e6a09b54b0e7e0 /dev-ruby/httparty
parentVersion bump. (diff)
downloadgentoo-2-cfac7e6e91edfb78bc995c502be544579250c792.tar.gz
gentoo-2-cfac7e6e91edfb78bc995c502be544579250c792.tar.bz2
gentoo-2-cfac7e6e91edfb78bc995c502be544579250c792.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/httparty')
-rw-r--r--dev-ruby/httparty/ChangeLog7
-rw-r--r--dev-ruby/httparty/httparty-0.13.5.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-ruby/httparty/ChangeLog b/dev-ruby/httparty/ChangeLog
index f59fc6e22574..98919ce63158 100644
--- a/dev-ruby/httparty/ChangeLog
+++ b/dev-ruby/httparty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/httparty
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httparty/ChangeLog,v 1.38 2015/05/16 08:20:24 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httparty/ChangeLog,v 1.39 2015/05/31 05:46:39 graaff Exp $
+
+*httparty-0.13.5 (31 May 2015)
+
+ 31 May 2015; Hans de Graaff <graaff@gentoo.org> +httparty-0.13.5.ebuild:
+ Version bump.
16 May 2015; Hans de Graaff <graaff@gentoo.org> -httparty-0.13.1.ebuild:
Cleanup.
diff --git a/dev-ruby/httparty/httparty-0.13.5.ebuild b/dev-ruby/httparty/httparty-0.13.5.ebuild
new file mode 100644
index 000000000000..547d5f61a115
--- /dev/null
+++ b/dev-ruby/httparty/httparty-0.13.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httparty/httparty-0.13.5.ebuild,v 1.1 2015/05/31 05:46:39 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+# We have a custom test function, but don't null this out so that the
+# deps are still added
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md History"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Makes http fun! Also, makes consuming restful web services dead easy"
+HOMEPAGE="http://jnunemaker.github.com/httparty"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+ruby_add_rdepend '>=dev-ruby/json-1.8:0 >=dev-ruby/multi_xml-0.5.2'
+
+ruby_add_bdepend 'dev-ruby/rspec:3 dev-ruby/fakeweb'
+
+all_ruby_prepare() {
+ # Remove bundler
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
+
+ # Avoid test dependency on cucumber. We can't run the features since
+ # they depend on mongrel which is no longer packaged.
+ sed -i -e '/cucumber/I s:^:#:' Rakefile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S rake spec || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*
+}