summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-01-30 09:26:00 +0000
committerHans de Graaff <graaff@gentoo.org>2011-01-30 09:26:00 +0000
commitb13430dc6359647399c2cbd5f867275130b453dd (patch)
tree0b193d665b970fb19571934bc6a7a7c3f5a6860b /dev-ruby/gnuplot
parentAdd ~ppc64 wrt #346383, despite failing tests (#282441) (diff)
downloadgentoo-2-b13430dc6359647399c2cbd5f867275130b453dd.tar.gz
gentoo-2-b13430dc6359647399c2cbd5f867275130b453dd.tar.bz2
gentoo-2-b13430dc6359647399c2cbd5f867275130b453dd.zip
Version bump.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/gnuplot')
-rw-r--r--dev-ruby/gnuplot/ChangeLog9
-rw-r--r--dev-ruby/gnuplot/gnuplot-2.3.5.ebuild29
2 files changed, 36 insertions, 2 deletions
diff --git a/dev-ruby/gnuplot/ChangeLog b/dev-ruby/gnuplot/ChangeLog
index d2ca61ff5664..807b0de1e2b9 100644
--- a/dev-ruby/gnuplot/ChangeLog
+++ b/dev-ruby/gnuplot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/gnuplot
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gnuplot/ChangeLog,v 1.9 2010/08/29 11:38:24 graaff Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gnuplot/ChangeLog,v 1.10 2011/01/30 09:26:00 graaff Exp $
+
+*gnuplot-2.3.5 (30 Jan 2011)
+
+ 30 Jan 2011; Hans de Graaff <graaff@gentoo.org> +gnuplot-2.3.5.ebuild:
+ Version bump.
29 Aug 2010; Hans de Graaff <graaff@gentoo.org> -gnuplot-2.3.1.ebuild,
-gnuplot-2.3.3.ebuild:
diff --git a/dev-ruby/gnuplot/gnuplot-2.3.5.ebuild b/dev-ruby/gnuplot/gnuplot-2.3.5.ebuild
new file mode 100644
index 000000000000..7385fe6b8ba3
--- /dev/null
+++ b/dev-ruby/gnuplot/gnuplot-2.3.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gnuplot/gnuplot-2.3.5.ebuild,v 1.1 2011/01/30 09:26:00 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="AUTHORS.txt ChangeLog README.textile"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Gnuplot drawing library - Ruby Bindings"
+HOMEPAGE="http://rgplot.rubyforge.org/"
+
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="test"
+SLOT="0"
+
+RDEPEND="${RDEPEND} sci-visualization/gnuplot"
+
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+
+each_ruby_test() {
+ ${RUBY} -Ctest -rtest/unit -e "Dir['test/*.rb'].each{|f| require f}" || die
+}