summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-08-07 12:46:22 +0000
committerHans de Graaff <graaff@gentoo.org>2010-08-07 12:46:22 +0000
commit8c3adb0338e49339dde478caba52b0c9612008e7 (patch)
tree1f38596f3859a7001bd7eeb9ec7bcb5ddac73507 /dev-ruby/gnuplot
parentAdd missing inherit. (diff)
downloadgentoo-2-8c3adb0338e49339dde478caba52b0c9612008e7.tar.gz
gentoo-2-8c3adb0338e49339dde478caba52b0c9612008e7.tar.bz2
gentoo-2-8c3adb0338e49339dde478caba52b0c9612008e7.zip
Version bump, now with documentation and tests.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/gnuplot')
-rw-r--r--dev-ruby/gnuplot/ChangeLog7
-rw-r--r--dev-ruby/gnuplot/gnuplot-2.3.4.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-ruby/gnuplot/ChangeLog b/dev-ruby/gnuplot/ChangeLog
index 344203e24c41..535c1c30a20e 100644
--- a/dev-ruby/gnuplot/ChangeLog
+++ b/dev-ruby/gnuplot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/gnuplot
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gnuplot/ChangeLog,v 1.6 2010/07/31 06:59:10 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gnuplot/ChangeLog,v 1.7 2010/08/07 12:46:22 graaff Exp $
+
+*gnuplot-2.3.4 (07 Aug 2010)
+
+ 07 Aug 2010; Hans de Graaff <graaff@gentoo.org> +gnuplot-2.3.4.ebuild:
+ Version bump, now with documentation and tests.
*gnuplot-2.3.3 (31 Jul 2010)
diff --git a/dev-ruby/gnuplot/gnuplot-2.3.4.ebuild b/dev-ruby/gnuplot/gnuplot-2.3.4.ebuild
new file mode 100644
index 000000000000..9d16a71b18c6
--- /dev/null
+++ b/dev-ruby/gnuplot/gnuplot-2.3.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gnuplot/gnuplot-2.3.4.ebuild,v 1.1 2010/08/07 12:46:22 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="AUTHORS.txt ChangeLog README.textile"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Gnuplot drawing library - Ruby Bindings"
+HOMEPAGE="http://rgplot.rubyforge.org/"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+SLOT="0"
+
+RDEPEND="${RDEPEND} sci-visualization/gnuplot"
+
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+
+each_ruby_test() {
+ ${RUBY} -Ctest -rtest/unit -e "Dir['test/*.rb'].each{|f| require f}" || die
+}