summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-06-25 07:15:40 +0000
committerHans de Graaff <graaff@gentoo.org>2011-06-25 07:15:40 +0000
commit7226d090db52bd31a54222ee90014a3c4449694e (patch)
tree33a21755362d022e15ca75048c3e32e1d883f229 /dev-ruby/file-tail
parentRemove old version. (diff)
downloadgentoo-2-7226d090db52bd31a54222ee90014a3c4449694e.tar.gz
gentoo-2-7226d090db52bd31a54222ee90014a3c4449694e.tar.bz2
gentoo-2-7226d090db52bd31a54222ee90014a3c4449694e.zip
Version bump.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/file-tail')
-rw-r--r--dev-ruby/file-tail/ChangeLog9
-rw-r--r--dev-ruby/file-tail/file-tail-1.0.6.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/dev-ruby/file-tail/ChangeLog b/dev-ruby/file-tail/ChangeLog
index fca4de0d18d6..9f619063d494 100644
--- a/dev-ruby/file-tail/ChangeLog
+++ b/dev-ruby/file-tail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/file-tail
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/file-tail/ChangeLog,v 1.2 2010/11/04 17:30:17 fauli Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/file-tail/ChangeLog,v 1.3 2011/06/25 07:15:40 graaff Exp $
+
+*file-tail-1.0.6 (25 Jun 2011)
+
+ 25 Jun 2011; Hans de Graaff <graaff@gentoo.org> +file-tail-1.0.6.ebuild:
+ Version bump.
04 Nov 2010; Christian Faulhammer <fauli@gentoo.org>
file-tail-1.0.5.ebuild:
diff --git a/dev-ruby/file-tail/file-tail-1.0.6.ebuild b/dev-ruby/file-tail/file-tail-1.0.6.ebuild
new file mode 100644
index 000000000000..05098831470e
--- /dev/null
+++ b/dev-ruby/file-tail/file-tail-1.0.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/file-tail/file-tail-1.0.6.ebuild,v 1.1 2011/06/25 07:15:40 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A small ruby library that allows it to 'tail' files in Ruby"
+HOMEPAGE="http://flori.github.com/file-tail"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/spruz-0.2"
+ruby_add_bdepend "test? ( virtual/ruby-test-unit ) "
+
+all_ruby_prepare() {
+ # sdoc is not yet available
+ sed -i -e 's/sdoc/rdoc/' Rakefile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib tests/test_file-tail*.rb || die
+}