summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-03-03 20:41:47 +0000
committerHans de Graaff <graaff@gentoo.org>2013-03-03 20:41:47 +0000
commite7f64fc4d3202dd1eb0218759e01184af1af7038 (patch)
tree7e957096ce5de51002e05f3bac8fba1059c34206 /dev-ruby/fast_gettext
parentCleanup. (diff)
downloadgentoo-2-e7f64fc4d3202dd1eb0218759e01184af1af7038.tar.gz
gentoo-2-e7f64fc4d3202dd1eb0218759e01184af1af7038.tar.bz2
gentoo-2-e7f64fc4d3202dd1eb0218759e01184af1af7038.zip
Version bump.
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/fast_gettext')
-rw-r--r--dev-ruby/fast_gettext/ChangeLog7
-rw-r--r--dev-ruby/fast_gettext/fast_gettext-0.7.0.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-ruby/fast_gettext/ChangeLog b/dev-ruby/fast_gettext/ChangeLog
index ca6b7122b3d9..aaec27803bdc 100644
--- a/dev-ruby/fast_gettext/ChangeLog
+++ b/dev-ruby/fast_gettext/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/fast_gettext
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_gettext/ChangeLog,v 1.21 2013/03/03 20:39:29 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_gettext/ChangeLog,v 1.22 2013/03/03 20:41:47 graaff Exp $
+
+*fast_gettext-0.7.0 (03 Mar 2013)
+
+ 03 Mar 2013; Hans de Graaff <graaff@gentoo.org> +fast_gettext-0.7.0.ebuild:
+ Version bump.
03 Mar 2013; Hans de Graaff <graaff@gentoo.org> -fast_gettext-0.6.10.ebuild:
Cleanup.
diff --git a/dev-ruby/fast_gettext/fast_gettext-0.7.0.ebuild b/dev-ruby/fast_gettext/fast_gettext-0.7.0.ebuild
new file mode 100644
index 000000000000..f920d2202826
--- /dev/null
+++ b/dev-ruby/fast_gettext/fast_gettext-0.7.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_gettext/fast_gettext-0.7.0.ebuild,v 1.1 2013/03/03 20:41:47 graaff Exp $
+
+EAPI=5
+
+# jruby support requires sqlite3 support for jruby.
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG Readme.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="GetText but 3.5 x faster, 560 x less memory, simple, clean namespace (7 vs 34) and threadsave!"
+HOMEPAGE="https://github.com/grosser/fast_gettext"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/activerecord dev-ruby/bundler )"
+
+all_ruby_prepare() {
+ rm Gemfile.lock || die
+
+ # Remove jeweler and bump from Gemfile since they are not needed for tests.
+ sed -i -e '/jeweler/d' -e '/bump/d' -e '/appraisal/d' Gemfile || die
+
+ # Avoid unneeded dependency on git.
+ sed -i -e '/git ls-files/ s:^:#:' fast_gettext.gemspec || die
+
+ # Don't run a test that requires safe mode which we can't provide
+ # due to insecure directory settings for the portage dir. This spec
+ # also calls out to ruby which won't work with different ruby
+ # implementations.
+ sed -i -e '/can work in SAFE mode/,/end/ s:^:#:' spec/fast_gettext/translation_repository/mo_spec.rb || die
+}
+
+each_ruby_prepare() {
+ # Make sure the right ruby interpreter is used
+ sed -i -e "s:bundle exec ruby:bundle exec ${RUBY}:" spec/fast_gettext/vendor/*spec.rb || die
+}