summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2009-08-26 23:01:07 +0000
committerAlex Legler <a3li@gentoo.org>2009-08-26 23:01:07 +0000
commitfe20af70fb4e5bdf35f3f85f1277b24e1799ab58 (patch)
tree9390fed164deb31ec0106018eeba07dc4a69bf0c /dev-ruby/dbd-odbc/dbd-odbc-0.2.5.ebuild
parentRemoving roedu from mirror://rubyforge, dead. (diff)
downloadgentoo-2-fe20af70fb4e5bdf35f3f85f1277b24e1799ab58.tar.gz
gentoo-2-fe20af70fb4e5bdf35f3f85f1277b24e1799ab58.tar.bz2
gentoo-2-fe20af70fb4e5bdf35f3f85f1277b24e1799ab58.zip
Initial import, ebuild by /me.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/dbd-odbc/dbd-odbc-0.2.5.ebuild')
-rw-r--r--dev-ruby/dbd-odbc/dbd-odbc-0.2.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/dbd-odbc/dbd-odbc-0.2.5.ebuild b/dev-ruby/dbd-odbc/dbd-odbc-0.2.5.ebuild
new file mode 100644
index 000000000000..ea1b4d4a7a6e
--- /dev/null
+++ b/dev-ruby/dbd-odbc/dbd-odbc-0.2.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/dbd-odbc/dbd-odbc-0.2.5.ebuild,v 1.1 2009/08/26 23:01:07 a3li Exp $
+
+inherit "ruby"
+
+DESCRIPTION="The ODBC database driver (DBD) for Ruby/DBI"
+HOMEPAGE="http://ruby-dbi.rubyforge.org"
+SRC_URI="mirror://rubyforge/ruby-dbi/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="virtual/ruby"
+RDEPEND="${DEPEND}
+ >=dev-ruby/ruby-dbi-0.4.2
+ dev-ruby/ruby-odbc"
+
+USE_RUBY="ruby18"
+
+src_test() {
+ elog "The tests require additional configuration."
+ elog "You will find them in /usr/share/${PN}/test/"
+ elog "Be sure to read the file called DBD_TESTS."
+}
+
+src_install() {
+ ruby setup.rb install \
+ --prefix="${D}" || die "setup.rb install failed"
+
+ if use test; then
+ dodir /usr/share/${PN}
+ cp -pPR test "${D}/usr/share/${PN}" || die "couldn't copy tests"
+ fi
+}