summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-02-10 08:59:29 +0000
committerHans de Graaff <graaff@gentoo.org>2013-02-10 08:59:29 +0000
commitf007c7f0e842be7bb4d0ae1ff35bc54d668e4ac8 (patch)
tree862480e805295434a7cb6f79fcc1d694366a58f8 /dev-ruby/css_parser
parentVersion bump. Fixes security bug 442580. (diff)
downloadgentoo-2-f007c7f0e842be7bb4d0ae1ff35bc54d668e4ac8.tar.gz
gentoo-2-f007c7f0e842be7bb4d0ae1ff35bc54d668e4ac8.tar.bz2
gentoo-2-f007c7f0e842be7bb4d0ae1ff35bc54d668e4ac8.zip
Avoid a test requiring the network to be active, bug 455608.
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/css_parser')
-rw-r--r--dev-ruby/css_parser/ChangeLog7
-rw-r--r--dev-ruby/css_parser/css_parser-1.2.6.ebuild8
2 files changed, 11 insertions, 4 deletions
diff --git a/dev-ruby/css_parser/ChangeLog b/dev-ruby/css_parser/ChangeLog
index 2710d5e1c778..19f09c5161b1 100644
--- a/dev-ruby/css_parser/ChangeLog
+++ b/dev-ruby/css_parser/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/css_parser
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/css_parser/ChangeLog,v 1.2 2012/05/05 05:44:15 graaff Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/css_parser/ChangeLog,v 1.3 2013/02/10 08:59:29 graaff Exp $
+
+ 10 Feb 2013; Hans de Graaff <graaff@gentoo.org> css_parser-1.2.6.ebuild:
+ Avoid a test requiring the network to be active, bug 455608.
05 May 2012; Hans de Graaff <graaff@gentoo.org> css_parser-1.2.6.ebuild:
Add missing IUSE.
diff --git a/dev-ruby/css_parser/css_parser-1.2.6.ebuild b/dev-ruby/css_parser/css_parser-1.2.6.ebuild
index 328d9b6f6d38..247861f5f0f6 100644
--- a/dev-ruby/css_parser/css_parser-1.2.6.ebuild
+++ b/dev-ruby/css_parser/css_parser-1.2.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/css_parser/css_parser-1.2.6.ebuild,v 1.2 2012/05/05 05:44:15 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/css_parser/css_parser-1.2.6.ebuild,v 1.3 2013/02/10 08:59:29 graaff Exp $
EAPI=4
USE_RUBY="ruby18 ruby19 ree18 jruby"
@@ -37,6 +37,10 @@ all_ruby_prepare() {
# get rid of bundler usage
rm Gemfile || die
sed -i -e '/bundler/d' rakefile.rb || die
+
+ # Avoid tests using the network.
+ sed -i -e '/test_loading_a_remote_file_over_ssl/,/end/ s:^:#:' test/test_css_parser_loading.rb || die
+
}
each_ruby_prepare() {