summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-09-27 17:51:59 +0000
committerHans de Graaff <graaff@gentoo.org>2011-09-27 17:51:59 +0000
commitc20d601d3032448278d8a2d7a7b753a1beb39ff8 (patch)
tree67fe1713b05dc0577ee5431b0e37cb3d9c136de4 /dev-ruby/coderay
parentFix bug 384383 (diff)
downloadgentoo-2-c20d601d3032448278d8a2d7a7b753a1beb39ff8.tar.gz
gentoo-2-c20d601d3032448278d8a2d7a7b753a1beb39ff8.tar.bz2
gentoo-2-c20d601d3032448278d8a2d7a7b753a1beb39ff8.zip
Version bump.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/coderay')
-rw-r--r--dev-ruby/coderay/ChangeLog7
-rw-r--r--dev-ruby/coderay/coderay-1.0.0.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-ruby/coderay/ChangeLog b/dev-ruby/coderay/ChangeLog
index 040630a97332..2ef87e892a6e 100644
--- a/dev-ruby/coderay/ChangeLog
+++ b/dev-ruby/coderay/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/coderay
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/ChangeLog,v 1.39 2011/09/21 19:08:48 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/ChangeLog,v 1.40 2011/09/27 17:51:59 graaff Exp $
+
+*coderay-1.0.0 (27 Sep 2011)
+
+ 27 Sep 2011; Hans de Graaff <graaff@gentoo.org> +coderay-1.0.0.ebuild:
+ Version bump.
21 Sep 2011; Hans de Graaff <graaff@gentoo.org> +coderay-0.9.7.ebuild:
Add back because redmine depends on this specific version. Sigh. Thanks to Mr
diff --git a/dev-ruby/coderay/coderay-1.0.0.ebuild b/dev-ruby/coderay/coderay-1.0.0.ebuild
new file mode 100644
index 000000000000..a324f1889daa
--- /dev/null
+++ b/dev-ruby/coderay/coderay-1.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/coderay-1.0.0.ebuild,v 1.1 2011/09/27 17:51:59 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+# The test target also contains test:exe but that requires
+# shoulda-context which we do not have packaged yet.
+RUBY_FAKEGEM_TASK_TEST="test:functional test:units"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="Changes-1.0.textile Changes.textile IDEA README.textile TODO"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby library for syntax highlighting."
+HOMEPAGE="http://coderay.rubychan.de/"
+SRC_URI="https://github.com/rubychan/coderay/tarball/v${PV} -> ${P}.tgz"
+
+RUBY_S="rubychan-coderay-*"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+# Redcloth is optional but automagically tested, so we add this
+# dependency to ensure that we get at least a version that works: bug
+# 330621. We use this convoluted way because redcloth isn't available
+# yet for jruby.
+USE_RUBY=ruby18 ruby_add_bdepend "ruby_targets_ruby18 test" ">=dev-ruby/redcloth-4.2.2"
+USE_RUBY=ruby19 ruby_add_bdepend "ruby_targets_ruby19 test" ">=dev-ruby/redcloth-4.2.2"
+USE_RUBY=ree18 ruby_add_bdepend "ruby_targets_ree18 test" ">=dev-ruby/redcloth-4.2.2"
+
+all_ruby_prepare() {
+ # Don't run two tests that are known to break on jruby 1.5. We
+ # should depend on jruby 1.6 to fix this, but only the tests are
+ # broken. https://github.com/rubychan/coderay/issues/4
+ sed -i -e '22,35d' test/unit/file_type.rb || die
+ sed -i -e '48,61d' test/unit/plugin.rb || die
+}