summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-01-27 06:42:12 +0000
committerHans de Graaff <graaff@gentoo.org>2015-01-27 06:42:12 +0000
commitaa6fd8b3defcfb7d2958c027eced66a5857ad308 (patch)
tree23576ec022bb0fe7f32b07eea6fc62adf5adfd63 /dev-ruby/atomic
parentBump ebuild due to lack of stable keywords for pyQT4 for py-3.4 enabled ebuilds (diff)
downloadgentoo-2-aa6fd8b3defcfb7d2958c027eced66a5857ad308.tar.gz
gentoo-2-aa6fd8b3defcfb7d2958c027eced66a5857ad308.tar.bz2
gentoo-2-aa6fd8b3defcfb7d2958c027eced66a5857ad308.zip
Version bump. Add ruby22. Avoid dependency on rake-compiler completely.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/atomic')
-rw-r--r--dev-ruby/atomic/ChangeLog9
-rw-r--r--dev-ruby/atomic/atomic-1.1.99.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/dev-ruby/atomic/ChangeLog b/dev-ruby/atomic/ChangeLog
index 06003990278d..733fab929dfe 100644
--- a/dev-ruby/atomic/ChangeLog
+++ b/dev-ruby/atomic/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/atomic
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/atomic/ChangeLog,v 1.16 2014/08/12 21:27:22 blueness Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/atomic/ChangeLog,v 1.17 2015/01/27 06:42:12 graaff Exp $
+
+*atomic-1.1.99 (27 Jan 2015)
+
+ 27 Jan 2015; Hans de Graaff <graaff@gentoo.org> +atomic-1.1.99.ebuild:
+ Version bump. Add ruby22. Avoid dependency on rake-compiler completely.
12 Aug 2014; Anthony G. Basile <blueness@gentoo.org> atomic-1.1.16.ebuild:
Keyword ~ppc and ~ppc64, bug #519170
diff --git a/dev-ruby/atomic/atomic-1.1.99.ebuild b/dev-ruby/atomic/atomic-1.1.99.ebuild
new file mode 100644
index 000000000000..5e66b43e5e05
--- /dev/null
+++ b/dev-ruby/atomic/atomic-1.1.99.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/atomic/atomic-1.1.99.ebuild,v 1.1 2015/01/27 06:42:12 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="An atomic reference implementation for JRuby, Rubinius, and MRI"
+HOMEPAGE="https://github.com/headius/ruby-atomic"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Avoid compilation dependencies since we compile directly.
+ sed -i -e '/:test => :compile/ s:^:#:' \
+ -e '/extensiontask/,/end/ s:^:#:' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext
+ cp ext/atomic_reference$(get_modname) lib/ || die
+}