summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-01-10 19:12:12 +0000
committerHans de Graaff <graaff@gentoo.org>2011-01-10 19:12:12 +0000
commite2046d170c47e26aba12082341eb544e800ca470 (patch)
treea49f81e7f4f3479bdc4f649f1d43d7d5b0eb48c4 /dev-ruby/activemodel
parentThis requires a bump since we modify the gemspec file. (diff)
downloadgentoo-2-e2046d170c47e26aba12082341eb544e800ca470.tar.gz
gentoo-2-e2046d170c47e26aba12082341eb544e800ca470.tar.bz2
gentoo-2-e2046d170c47e26aba12082341eb544e800ca470.zip
This requires a bump since we modify the gemspec file.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activemodel')
-rw-r--r--dev-ruby/activemodel/ChangeLog8
-rw-r--r--dev-ruby/activemodel/activemodel-3.0.3-r1.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-ruby/activemodel/ChangeLog b/dev-ruby/activemodel/ChangeLog
index 0b51815bccb1..2584e86c2100 100644
--- a/dev-ruby/activemodel/ChangeLog
+++ b/dev-ruby/activemodel/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activemodel
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.5 2011/01/10 19:03:14 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.6 2011/01/10 19:12:12 graaff Exp $
+
+*activemodel-3.0.3-r1 (10 Jan 2011)
+
+ 10 Jan 2011; Hans de Graaff <graaff@gentoo.org>
+ +activemodel-3.0.3-r1.ebuild:
+ This requires a bump since we modify the gemspec file.
10 Jan 2011; Hans de Graaff <graaff@gentoo.org> activemodel-3.0.3.ebuild:
Relax builder requirements for bug 351189.
diff --git a/dev-ruby/activemodel/activemodel-3.0.3-r1.ebuild b/dev-ruby/activemodel/activemodel-3.0.3-r1.ebuild
new file mode 100644
index 000000000000..414ee37c39df
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-3.0.3-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-3.0.3-r1.ebuild,v 1.1 2011/01/10 19:12:12 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+S="${WORKDIR}/rails-rails-*/activemodel"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-2.1.2
+ >=dev-ruby/i18n-0.4.1:0.4"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/ruby-debug
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+
+ # Relax builder requirement to also support 3.0.0
+ sed -i -e 's/~> 2.1.2/>= 2.1.2/' activemodel.gemspec || die
+}