summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-11-17 20:18:56 +0000
committerHans de Graaff <graaff@gentoo.org>2014-11-17 20:18:56 +0000
commitae83433b64b42be5c8bd3a8f3ab32bc444f5dbd5 (patch)
tree4ccf073b1132e9832e77d24e9c917c027a70ecae /dev-ruby/actionview
parentVersion bump for security bug 529635. (diff)
downloadgentoo-2-ae83433b64b42be5c8bd3a8f3ab32bc444f5dbd5.tar.gz
gentoo-2-ae83433b64b42be5c8bd3a8f3ab32bc444f5dbd5.tar.bz2
gentoo-2-ae83433b64b42be5c8bd3a8f3ab32bc444f5dbd5.zip
Version bump for security bug 529635.
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/actionview')
-rw-r--r--dev-ruby/actionview/ChangeLog7
-rw-r--r--dev-ruby/actionview/actionview-4.1.8.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-ruby/actionview/ChangeLog b/dev-ruby/actionview/ChangeLog
index eea2bcac1e25..c8e1bc0a58ff 100644
--- a/dev-ruby/actionview/ChangeLog
+++ b/dev-ruby/actionview/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionview
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionview/ChangeLog,v 1.12 2014/11/07 10:14:54 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionview/ChangeLog,v 1.13 2014/11/17 20:18:56 graaff Exp $
+
+*actionview-4.1.8 (17 Nov 2014)
+
+ 17 Nov 2014; Hans de Graaff <graaff@gentoo.org> +actionview-4.1.8.ebuild:
+ Version bump for security bug 529635.
07 Nov 2014; Hans de Graaff <graaff@gentoo.org> -actionview-4.1.5.ebuild,
-actionview-4.1.6.ebuild:
diff --git a/dev-ruby/actionview/actionview-4.1.8.ebuild b/dev-ruby/actionview/actionview-4.1.8.ebuild
new file mode 100644
index 000000000000..c945c7ed6048
--- /dev/null
+++ b/dev-ruby/actionview/actionview-4.1.8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionview/actionview-4.1.8.ebuild,v 1.1 2014/11/17 20:18:56 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Simple, battle-tested conventions and helpers for building web pages"
+HOMEPAGE="https://github.com/rails/rails/"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.1 =dev-ruby/builder-3*
+ >=dev-ruby/erubis-2.7.0
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha:0.14
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activemodel-${PV}
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|minitest\)/ s:^:#:" ../Gemfile || die
+
+}