summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2008-07-25 02:44:24 +0000
committerRyan Hill <dirtyepic@gentoo.org>2008-07-25 02:44:24 +0000
commitf4789ff9d5c5b98e797b70148fe8a96e7bd1542c (patch)
treebf78b47230d91ec577bbc096541bc2b8963340fc /dev-python
parentVersion bump. (diff)
downloadgentoo-2-f4789ff9d5c5b98e797b70148fe8a96e7bd1542c.tar.gz
gentoo-2-f4789ff9d5c5b98e797b70148fe8a96e7bd1542c.tar.bz2
gentoo-2-f4789ff9d5c5b98e797b70148fe8a96e7bd1542c.zip
Version bump.
(Portage version: 2.2_rc3/cvs/Linux 2.6.26-rc9 x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wxpython/ChangeLog9
-rw-r--r--dev-python/wxpython/files/wxpython-2.8.8-wxversion-scripts.patch131
-rw-r--r--dev-python/wxpython/files/wxpython-2.8.8.1-musthaveapp.patch19
-rw-r--r--dev-python/wxpython/wxpython-2.8.8.1.ebuild122
4 files changed, 280 insertions, 1 deletions
diff --git a/dev-python/wxpython/ChangeLog b/dev-python/wxpython/ChangeLog
index dce125974488..5b7a89014c84 100644
--- a/dev-python/wxpython/ChangeLog
+++ b/dev-python/wxpython/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/wxpython
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.88 2008/05/29 16:40:05 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.89 2008/07/25 02:44:24 dirtyepic Exp $
+
+*wxpython-2.8.8.1 (25 Jul 2008)
+
+ 25 Jul 2008; Ryan Hill <dirtyepic@gentoo.org>
+ +files/wxpython-2.8.8.1-musthaveapp.patch,
+ +files/wxpython-2.8.8-wxversion-scripts.patch, +wxpython-2.8.8.1.ebuild:
+ Version bump.
29 May 2008; Ali Polatel <hawking@gentoo.org> wxpython-2.6.4.0-r1.ebuild,
wxpython-2.8.7.1.ebuild:
diff --git a/dev-python/wxpython/files/wxpython-2.8.8-wxversion-scripts.patch b/dev-python/wxpython/files/wxpython-2.8.8-wxversion-scripts.patch
new file mode 100644
index 000000000000..95d5da3abade
--- /dev/null
+++ b/dev-python/wxpython/files/wxpython-2.8.8-wxversion-scripts.patch
@@ -0,0 +1,131 @@
+diff -Naur wxPython-src-2.8.8.0-orig/wxPython/scripts/editra wxPython-src-2.8.8.0/wxPython/scripts/editra
+--- wxPython-src-2.8.8.0-orig/wxPython/scripts/editra 2008-02-29 14:32:17.000000000 -0600
++++ wxPython-src-2.8.8.0/wxPython/scripts/editra 2008-06-26 17:38:39.000000000 -0600
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.8")
+
+ from wx.tools.Editra.launcher import main
+ main()
+diff -Naur wxPython-src-2.8.8.0-orig/wxPython/scripts/genaxmodule wxPython-src-2.8.8.0/wxPython/scripts/genaxmodule
+--- wxPython-src-2.8.8.0-orig/wxPython/scripts/genaxmodule 2008-02-29 14:32:17.000000000 -0600
++++ wxPython-src-2.8.8.0/wxPython/scripts/genaxmodule 2008-06-26 17:38:39.000000000 -0600
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.8")
+
+ from wx.tools.genaxmodule import main
+ main()
+diff -Naur wxPython-src-2.8.8.0-orig/wxPython/scripts/helpviewer wxPython-src-2.8.8.0/wxPython/scripts/helpviewer
+--- wxPython-src-2.8.8.0-orig/wxPython/scripts/helpviewer 2007-07-18 16:33:55.000000000 -0600
++++ wxPython-src-2.8.8.0/wxPython/scripts/helpviewer 2008-06-26 17:38:39.000000000 -0600
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.8")
+
+ from wx.tools.helpviewer import main
+ main()
+diff -Naur wxPython-src-2.8.8.0-orig/wxPython/scripts/img2png wxPython-src-2.8.8.0/wxPython/scripts/img2png
+--- wxPython-src-2.8.8.0-orig/wxPython/scripts/img2png 2007-07-18 16:33:55.000000000 -0600
++++ wxPython-src-2.8.8.0/wxPython/scripts/img2png 2008-06-26 17:38:39.000000000 -0600
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.8")
+
+ from wx.tools.img2png import main
+ main()
+diff -Naur wxPython-src-2.8.8.0-orig/wxPython/scripts/img2py wxPython-src-2.8.8.0/wxPython/scripts/img2py
+--- wxPython-src-2.8.8.0-orig/wxPython/scripts/img2py 2008-02-29 14:32:17.000000000 -0600
++++ wxPython-src-2.8.8.0/wxPython/scripts/img2py 2008-06-26 17:38:39.000000000 -0600
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.8")
+
+ from wx.tools.img2py import main
+ main()
+diff -Naur wxPython-src-2.8.8.0-orig/wxPython/scripts/img2xpm wxPython-src-2.8.8.0/wxPython/scripts/img2xpm
+--- wxPython-src-2.8.8.0-orig/wxPython/scripts/img2xpm 2007-07-18 16:33:55.000000000 -0600
++++ wxPython-src-2.8.8.0/wxPython/scripts/img2xpm 2008-06-26 17:38:39.000000000 -0600
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.8")
+
+ from wx.tools.img2xpm import main
+ main()
+diff -Naur wxPython-src-2.8.8.0-orig/wxPython/scripts/pyalacarte wxPython-src-2.8.8.0/wxPython/scripts/pyalacarte
+--- wxPython-src-2.8.8.0-orig/wxPython/scripts/pyalacarte 2007-07-18 16:33:55.000000000 -0600
++++ wxPython-src-2.8.8.0/wxPython/scripts/pyalacarte 2008-06-26 17:38:39.000000000 -0600
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.8")
+
+ from wx.py.PyAlaCarte import main
+ main()
+diff -Naur wxPython-src-2.8.8.0-orig/wxPython/scripts/pyalamode wxPython-src-2.8.8.0/wxPython/scripts/pyalamode
+--- wxPython-src-2.8.8.0-orig/wxPython/scripts/pyalamode 2007-07-18 16:33:55.000000000 -0600
++++ wxPython-src-2.8.8.0/wxPython/scripts/pyalamode 2008-06-26 17:38:39.000000000 -0600
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.8")
+
+ from wx.py.PyAlaMode import main
+ main()
+diff -Naur wxPython-src-2.8.8.0-orig/wxPython/scripts/pycrust wxPython-src-2.8.8.0/wxPython/scripts/pycrust
+--- wxPython-src-2.8.8.0-orig/wxPython/scripts/pycrust 2007-07-18 16:33:55.000000000 -0600
++++ wxPython-src-2.8.8.0/wxPython/scripts/pycrust 2008-06-26 17:38:39.000000000 -0600
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.8")
+
+ from wx.py.PyCrust import main
+ main()
+diff -Naur wxPython-src-2.8.8.0-orig/wxPython/scripts/pyshell wxPython-src-2.8.8.0/wxPython/scripts/pyshell
+--- wxPython-src-2.8.8.0-orig/wxPython/scripts/pyshell 2007-07-18 16:33:55.000000000 -0600
++++ wxPython-src-2.8.8.0/wxPython/scripts/pyshell 2008-06-26 17:38:39.000000000 -0600
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.8")
+
+ from wx.py.PyShell import main
+ main()
+diff -Naur wxPython-src-2.8.8.0-orig/wxPython/scripts/pywrap wxPython-src-2.8.8.0/wxPython/scripts/pywrap
+--- wxPython-src-2.8.8.0-orig/wxPython/scripts/pywrap 2007-07-18 16:33:55.000000000 -0600
++++ wxPython-src-2.8.8.0/wxPython/scripts/pywrap 2008-06-26 17:38:39.000000000 -0600
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.8")
+
+ from wx.py.PyWrap import main
+ main()
+diff -Naur wxPython-src-2.8.8.0-orig/wxPython/scripts/pywxrc wxPython-src-2.8.8.0/wxPython/scripts/pywxrc
+--- wxPython-src-2.8.8.0-orig/wxPython/scripts/pywxrc 2008-02-29 14:32:17.000000000 -0600
++++ wxPython-src-2.8.8.0/wxPython/scripts/pywxrc 2008-06-26 17:39:49.000000000 -0600
+@@ -1,5 +1,5 @@
+ #!/usr/bin/env python
+-
++import wxversion
++wxversion.select("2.8")
+ from wx.tools.pywxrc import main
+ main()
+-
+diff -Naur wxPython-src-2.8.8.0-orig/wxPython/scripts/xrced wxPython-src-2.8.8.0/wxPython/scripts/xrced
+--- wxPython-src-2.8.8.0-orig/wxPython/scripts/xrced 2007-07-18 16:33:55.000000000 -0600
++++ wxPython-src-2.8.8.0/wxPython/scripts/xrced 2008-06-26 17:38:39.000000000 -0600
+@@ -1,4 +1,6 @@
+ #!/usr/bin/env python
++import wxversion
++wxversion.select("2.8")
+
+ from wx.tools.XRCed.xrced import main
+ main()
diff --git a/dev-python/wxpython/files/wxpython-2.8.8.1-musthaveapp.patch b/dev-python/wxpython/files/wxpython-2.8.8.1-musthaveapp.patch
new file mode 100644
index 000000000000..d3ae2e90d48b
--- /dev/null
+++ b/dev-python/wxpython/files/wxpython-2.8.8.1-musthaveapp.patch
@@ -0,0 +1,19 @@
+diff -Naurp wxPython-src-2.8.8.1-orig/wxPython/src/_config.i wxPython-src-2.8.8.1/wxPython/src/_config.i
+--- wxPython-src-2.8.8.1-orig/wxPython/src/_config.i 2008-07-24 16:02:07.000000000 -0600
++++ wxPython-src-2.8.8.1/wxPython/src/_config.i 2008-07-24 16:02:53.000000000 -0600
+@@ -391,7 +391,6 @@ time)", "");
+
+ //---------------------------------------------------------------------------
+
+-MustHaveApp(wxConfig);
+
+ DocStr(wxConfig,
+ "This ConfigBase-derived class will use the registry on Windows,
+@@ -413,7 +412,6 @@ public:
+
+
+
+-MustHaveApp(wxFileConfig);
+
+ DocStr(wxFileConfig,
+ "This config class will use a file for storage on all platforms.", "");
diff --git a/dev-python/wxpython/wxpython-2.8.8.1.ebuild b/dev-python/wxpython/wxpython-2.8.8.1.ebuild
new file mode 100644
index 000000000000..73d99c71719b
--- /dev/null
+++ b/dev-python/wxpython/wxpython-2.8.8.1.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.8.1.ebuild,v 1.1 2008/07/25 02:44:24 dirtyepic Exp $
+
+EAPI="1"
+WX_GTK_VER="2.8"
+
+inherit alternatives eutils multilib python wxwidgets
+
+# Note, we don't use distutils.eclass because it doesn't seem to play nice with
+# need-wxwidgets
+
+MY_P="${P/wxpython-/wxPython-src-}"
+DESCRIPTION="A blending of the wxWindows C++ class library with Python"
+HOMEPAGE="http://www.wxpython.org/"
+SRC_URI="mirror://sourceforge/wxpython/${MY_P}.tar.bz2"
+
+LICENSE="wxWinLL-3"
+SLOT="2.8"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="opengl"
+
+# FIXME - change wxGTK back to >=x11-libs/wxGTK-${PV}:2.8
+# before commiting
+RDEPEND=">=dev-lang/python-2.1
+ >=x11-libs/wxGTK-${PV}:2.8
+ >=x11-libs/gtk+-2.4
+ >=x11-libs/pango-1.2
+ >=dev-libs/glib-2.0
+ media-libs/libpng
+ media-libs/jpeg
+ media-libs/tiff
+ opengl? ( >=dev-python/pyopengl-2.0.0.44 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}/wxPython/"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i "s:cflags.append('-O3'):pass:" config.py || die "sed failed"
+
+ epatch "${FILESDIR}"/${PN}-2.8.8-wxversion-scripts.patch
+ epatch "${FILESDIR}"/${P}-musthaveapp.patch # 2.8.8.1 only
+}
+
+src_compile() {
+ local mypyconf
+
+ need-wxwidgets unicode
+ use opengl && check_wxuse opengl
+
+ mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
+ use opengl \
+ && mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
+ || mypyconf="${mypyconf} BUILD_GLCANVAS=0"
+
+ mypyconf="${mypyconf} WXPORT=gtk2 UNICODE=1"
+
+ python setup.py ${mypyconf} build || die "setup.py build failed"
+}
+
+src_install() {
+ local mypyconf
+ python_version
+ local site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
+
+ mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
+ use opengl \
+ && mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
+ || mypyconf="${mypyconf} BUILD_GLCANVAS=0"
+
+ mypyconf="${mypyconf} WXPORT=gtk2 UNICODE=1"
+
+ python setup.py ${mypyconf} install --root="${D}" \
+ --install-purelib ${site_pkgs} || die "setup.py install failed"
+
+ # Collision protection.
+ for file in "${D}"/usr/bin/* "${D}"/${site_pkgs}/wx{version.*,.pth}; do
+ mv "${file}" "${file}-${SLOT}"
+ done
+
+ for dir in "${D}"/${site_pkgs}/wx-${SLOT}-gtk2-{ansi,unicode}; do
+ if [[ -d ${dir} ]]; then
+ cp -R "${D}"/${site_pkgs}/wxaddons/ "${dir}"
+ wxaddons_copied=1
+ fi
+ done
+
+ [[ ${wxaddons_copied} ]] && rm -rf "${D}"/${site_pkgs}/wxaddons/
+}
+
+pkg_postinst() {
+ local site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
+
+ python_mod_optimize ${site_pkgs}
+
+ alternatives_auto_makesym \
+ "${site_pkgs}/wx.pth" "${site_pkgs}/wx.pth-[0-9].[0-9]"
+ alternatives_auto_makesym \
+ "${site_pkgs}/wxversion.py" "${site_pkgs}/wxversion.py-[0-9].[0-9]"
+
+ echo
+ elog "Gentoo uses the Multi-version method for SLOT'ing."
+ elog "Developers see this site for instructions on using 2.6 or 2.8"
+ elog "with your apps:"
+ elog "http://wiki.wxpython.org/index.cgi/MultiVersionInstalls"
+ echo
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+
+ local site_pkgs=/usr/$(get_libdir)/python${PYVER}/site-packages
+
+ alternatives_auto_makesym \
+ "${site_pkgs}/wx.pth" "${site_pkgs}/wx.pth-[0-9].[0-9]"
+ alternatives_auto_makesym \
+ "${site_pkgs}/wxversion.py" "${site_pkgs}/wxversion.py-[0-9].[0-9]"
+}