summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-09-07 09:06:47 +0000
committerMichał Górny <mgorny@gentoo.org>2013-09-07 09:06:47 +0000
commite1775c28f11d0bccf42b373fb96883e0e261e1d0 (patch)
tree7a5ee6e23527f78377a52c112b70a03f57d5c084 /dev-python
parentMask abi_x86_32 to let stabilization (#477182#c5) (diff)
downloadgentoo-2-e1775c28f11d0bccf42b373fb96883e0e261e1d0.tar.gz
gentoo-2-e1775c28f11d0bccf42b373fb96883e0e261e1d0.tar.bz2
gentoo-2-e1775c28f11d0bccf42b373fb96883e0e261e1d0.zip
Introduce funcparserlib, a dep for mockldap.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/funcparserlib/ChangeLog9
-rw-r--r--dev-python/funcparserlib/funcparserlib-0.3.6.ebuild35
-rw-r--r--dev-python/funcparserlib/metadata.xml8
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/funcparserlib/ChangeLog b/dev-python/funcparserlib/ChangeLog
new file mode 100644
index 000000000000..422d526d66f5
--- /dev/null
+++ b/dev-python/funcparserlib/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/funcparserlib
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/funcparserlib/ChangeLog,v 1.1 2013/09/07 09:06:47 mgorny Exp $
+
+*funcparserlib-0.3.6 (07 Sep 2013)
+
+ 07 Sep 2013; Michał Górny <mgorny@gentoo.org> +funcparserlib-0.3.6.ebuild,
+ +metadata.xml:
+ Introduce funcparserlib, a dep for mockldap.
diff --git a/dev-python/funcparserlib/funcparserlib-0.3.6.ebuild b/dev-python/funcparserlib/funcparserlib-0.3.6.ebuild
new file mode 100644
index 000000000000..0976bc6976fe
--- /dev/null
+++ b/dev-python/funcparserlib/funcparserlib-0.3.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/funcparserlib/funcparserlib-0.3.6.ebuild,v 1.1 2013/09/07 09:06:47 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Recursive descent parsing library based on functional combinators"
+HOMEPAGE="https://code.google.com/p/funcparserlib/ https://pypi.python.org/pypi/funcparserlib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( virtual/python-unittest2[${PYTHON_USEDEP}] )"
+
+python_test() {
+ local m=unittest
+ [[ ${EPYTHON} == python2.6 ]] && m=unittest2.__main__
+
+ cd "${BUILD_DIR}"/lib || die
+ "${PYTHON}" -m ${m} discover || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( doc/*.md )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/funcparserlib/metadata.xml b/dev-python/funcparserlib/metadata.xml
new file mode 100644
index 000000000000..a8d1bb227dff
--- /dev/null
+++ b/dev-python/funcparserlib/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">funcparserlib</remote-id>
+ </upstream>
+</pkgmetadata>