summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-12-24 15:15:23 +0000
committerPacho Ramos <pacho@gentoo.org>2013-12-24 15:15:23 +0000
commit9aabf89f11d86f7a7507245d7c3dee058e6f8817 (patch)
treee3bc521ff602e46d4d03dc946b200787ed3adfc3 /dev-python
parentVersion bump for Gnome 3.10 (diff)
downloadgentoo-2-9aabf89f11d86f7a7507245d7c3dee058e6f8817.tar.gz
gentoo-2-9aabf89f11d86f7a7507245d7c3dee058e6f8817.tar.bz2
gentoo-2-9aabf89f11d86f7a7507245d7c3dee058e6f8817.zip
Version bump for Gnome 3.10, drop old
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pygobject/ChangeLog8
-rw-r--r--dev-python/pygobject/pygobject-2.28.6-r54.ebuild135
-rw-r--r--dev-python/pygobject/pygobject-3.10.2.ebuild97
3 files changed, 104 insertions, 136 deletions
diff --git a/dev-python/pygobject/ChangeLog b/dev-python/pygobject/ChangeLog
index 68781a6b4caa..bbab7651ddc9 100644
--- a/dev-python/pygobject/ChangeLog
+++ b/dev-python/pygobject/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pygobject
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.231 2013/12/22 15:58:38 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.232 2013/12/24 15:15:23 pacho Exp $
+
+*pygobject-3.10.2 (24 Dec 2013)
+
+ 24 Dec 2013; Pacho Ramos <pacho@gentoo.org> +pygobject-3.10.2.ebuild,
+ -pygobject-2.28.6-r54.ebuild:
+ Version bump for Gnome 3.10, drop old
22 Dec 2013; Jeroen Roovers <jer@gentoo.org> pygobject-2.28.6-r55.ebuild,
pygobject-3.8.3.ebuild:
diff --git a/dev-python/pygobject/pygobject-2.28.6-r54.ebuild b/dev-python/pygobject/pygobject-2.28.6-r54.ebuild
deleted file mode 100644
index 85d8ff548ab2..000000000000
--- a/dev-python/pygobject/pygobject-2.28.6-r54.ebuild
+++ /dev/null
@@ -1,135 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-2.28.6-r54.ebuild,v 1.2 2013/10/31 13:48:14 mgorny Exp $
-
-EAPI="5"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit autotools eutils gnome2 python-r1 virtualx
-
-DESCRIPTION="GLib's GObject library bindings for Python"
-HOMEPAGE="http://www.pygtk.org/"
-
-LICENSE="LGPL-2.1+"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="examples libffi test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-COMMON_DEPEND=">=dev-libs/glib-2.24.0:2
- libffi? ( virtual/libffi:= )
- ${PYTHON_DEPS}
-"
-DEPEND="${COMMON_DEPEND}
- dev-lang/python-exec:0
- dev-util/gtk-doc-am
- virtual/pkgconfig
- test? (
- media-fonts/font-cursor-misc
- media-fonts/font-misc-misc )
-"
-RDEPEND="${COMMON_DEPEND}
- !<dev-python/pygtk-2.23"
-
-# disable python-exec:2 support, bug #484406
-_PYTHON_WANT_PYTHON_EXEC2=0
-
-src_prepare() {
- # Fix FHS compliance, see upstream bug #535524
- epatch "${FILESDIR}/${PN}-2.28.3-fix-codegen-location.patch"
-
- # Do not build tests if unneeded, bug #226345
- epatch "${FILESDIR}/${PN}-2.28.3-make_check.patch"
-
- # Support installation for multiple Python versions, upstream bug #648292
- epatch "${FILESDIR}/${PN}-2.28.3-support_multiple_python_versions.patch"
-
- # Disable tests that fail
- epatch "${FILESDIR}/${P}-disable-failing-tests.patch"
-
- # Disable introspection tests when we build with --disable-introspection
- epatch "${FILESDIR}/${P}-tests-no-introspection.patch"
-
- # Fix warning spam
- epatch "${FILESDIR}/${P}-set_qdata.patch"
- epatch "${FILESDIR}/${P}-gio-types-2.32.patch"
-
- # Fix glib-2.36 compatibility, bug #486602
- epatch "${FILESDIR}/${P}-glib-2.36-class_init.patch"
-
- sed -i \
- -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' \
- -e 's:AM_PROG_CC_STDC:AC_PROG_CC:' \
- configure.ac || die
-
- eautoreconf
- gnome2_src_prepare
-
- python_copy_sources
-
- prepare_shebangs() {
- # Make a backup with unconverted shebangs to keep python_doscript happy
- cp codegen/codegen.py pygobject-codegen-2.0
- sed -e "s%#! \?/usr/bin/env python%#!${PYTHON}%" \
- -i codegen/*.py || die "shebang convertion failed"
- }
- python_foreach_impl run_in_build_dir prepare_shebangs
-}
-
-src_configure() {
- DOCS="AUTHORS ChangeLog* NEWS README"
- # --disable-introspection and --disable-cairo because we use pygobject:3
- # for introspection support
- G2CONF="${G2CONF}
- --disable-introspection
- --disable-cairo
- $(use_with libffi ffi)"
-
- python_foreach_impl run_in_build_dir gnome2_src_configure
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir gnome2_src_compile
-}
-
-# FIXME: With python multiple ABI support, tests return 1 even when they pass
-src_test() {
- unset DBUS_SESSION_BUS_ADDRESS
- export GIO_USE_VFS="local" # prevents odd issues with deleting ${T}/.gvfs
-
- testing() {
- export XDG_CACHE_HOME="${T}/${EPYTHON}"
- run_in_build_dir Xemake -j1 check
- unset XDG_CACHE_HOME
- }
- python_foreach_impl testing
- unset GIO_USE_VFS
-}
-
-src_install() {
- installing() {
- local f prefixed_sitedir
-
- gnome2_src_install
-
- python_doscript pygobject-codegen-2.0
-
- # Don't keep multiple copies of pygobject-codegen-2.0 script
- prefixed_sitedir=$(python_get_sitedir)
- dosym "${prefixed_sitedir#${EPREFIX}}/gtk-2.0/codegen/codegen.py" /usr/bin/pygobject-codegen-2.0-${EPYTHON}
- }
- python_foreach_impl run_in_build_dir installing
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
-
-run_in_build_dir() {
- pushd "${BUILD_DIR}" > /dev/null || die
- "$@"
- popd > /dev/null
-}
diff --git a/dev-python/pygobject/pygobject-3.10.2.ebuild b/dev-python/pygobject/pygobject-3.10.2.ebuild
new file mode 100644
index 000000000000..e284e78dd2b7
--- /dev/null
+++ b/dev-python/pygobject/pygobject-3.10.2.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-3.10.2.ebuild,v 1.1 2013/12/24 15:15:23 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+
+inherit gnome2 python-r1 virtualx
+
+DESCRIPTION="GLib's GObject library bindings for Python"
+HOMEPAGE="http://www.pygtk.org/"
+
+LICENSE="LGPL-2.1+"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="+cairo examples test +threads"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ test? ( cairo )
+"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.35.9:2
+ >=dev-libs/gobject-introspection-1.35.9
+ virtual/libffi:=
+ cairo? ( >=dev-python/pycairo-1.10.0[${PYTHON_USEDEP}] )
+ ${PYTHON_DEPS}
+"
+DEPEND="${COMMON_DEPEND}
+ x11-libs/cairo[glib]
+ virtual/pkgconfig
+ test? (
+ dev-libs/atk[introspection]
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ virtual/python-unittest2[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection] )
+"
+# gnome-base/gnome-common required by eautoreconf
+
+# We now disable introspection support in slot 2 per upstream recommendation
+# (see https://bugzilla.gnome.org/show_bug.cgi?id=642048#c9); however,
+# older versions of slot 2 installed their own site-packages/gi, and
+# slot 3 will collide with them.
+RDEPEND="${COMMON_DEPEND}
+ !<dev-python/pygtk-2.13
+ !<dev-python/pygobject-2.28.6-r50:2[introspection]"
+
+src_prepare() {
+ gnome2_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ # Hard-enable libffi support since both gobject-introspection and
+ # glib-2.29.x rdepend on it anyway
+ # docs disabled by upstream default since they are very out of date
+ python_foreach_impl run_in_build_dir \
+ gnome2_src_configure \
+ --with-ffi \
+ $(use_enable cairo) \
+ $(use_enable threads thread)
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ export GIO_USE_VFS="local" # prevents odd issues with deleting ${T}/.gvfs
+ export GIO_USE_VOLUME_MONITOR="unix" # prevent udisks-related failures in chroots, bug #449484
+
+ testing() {
+ export XDG_CACHE_HOME="${T}/${EPYTHON}"
+ run_in_build_dir Xemake check
+ unset XDG_CACHE_HOME
+ }
+ python_foreach_impl testing
+ unset GIO_USE_VFS
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog* NEWS README"
+
+ python_foreach_impl run_in_build_dir gnome2_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}