summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2006-06-07 18:47:48 +0000
committerMarien Zwart <marienz@gentoo.org>2006-06-07 18:47:48 +0000
commit80a120d1d9a09f5b7b16658477e9e3fe8f7770d2 (patch)
tree8f38748232151a7c8d01219a669bccdcdb6ec4b6 /dev-python
parentAdd an RDEPEND so gpm gets included properly during Catalyst runs. (diff)
downloadgentoo-2-80a120d1d9a09f5b7b16658477e9e3fe8f7770d2.tar.gz
gentoo-2-80a120d1d9a09f5b7b16658477e9e3fe8f7770d2.tar.bz2
gentoo-2-80a120d1d9a09f5b7b16658477e9e3fe8f7770d2.zip
Fix SRC_URI for 2.1.1 (upstream moved the file). Version bump, adding src_test.
(Portage version: 2.1_rc4-r2)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/beautifulsoup/ChangeLog8
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-2.1.1.ebuild4
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-3.0.3.ebuild25
-rw-r--r--dev-python/beautifulsoup/files/digest-beautifulsoup-3.0.33
4 files changed, 37 insertions, 3 deletions
diff --git a/dev-python/beautifulsoup/ChangeLog b/dev-python/beautifulsoup/ChangeLog
index b3fc4781b227..3556a05a73b7 100644
--- a/dev-python/beautifulsoup/ChangeLog
+++ b/dev-python/beautifulsoup/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/beautifulsoup
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/ChangeLog,v 1.1 2006/05/25 16:10:33 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/ChangeLog,v 1.2 2006/06/07 18:47:48 marienz Exp $
+
+*beautifulsoup-3.0.3 (07 Jun 2006)
+
+ 07 Jun 2006; Marien Zwart <marienz@gentoo.org> beautifulsoup-2.1.1.ebuild,
+ +beautifulsoup-3.0.3.ebuild:
+ Fix SRC_URI for 2.1.1 (upstream moved the file). Version bump, adding src_test.
*beautifulsoup-2.1.1 (25 May 2006)
diff --git a/dev-python/beautifulsoup/beautifulsoup-2.1.1.ebuild b/dev-python/beautifulsoup/beautifulsoup-2.1.1.ebuild
index 1c04862360da..004dafaffced 100644
--- a/dev-python/beautifulsoup/beautifulsoup-2.1.1.ebuild
+++ b/dev-python/beautifulsoup/beautifulsoup-2.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/beautifulsoup-2.1.1.ebuild,v 1.2 2006/06/06 09:11:33 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/beautifulsoup-2.1.1.ebuild,v 1.3 2006/06/07 18:47:48 marienz Exp $
inherit distutils
@@ -9,7 +9,7 @@ S=${WORKDIR}/${MY_P}
DESCRIPTION="HTML/XML parser for quick-turnaround applications like screen-scraping."
HOMEPAGE="http://www.crummy.com/software/BeautifulSoup/"
-SRC_URI="http://www.crummy.com/software/BeautifulSoup/download/${MY_P}.tar.gz"
+SRC_URI="http://www.crummy.com/software/BeautifulSoup/download/2.x/${MY_P}.tar.gz"
LICENSE="PSF-2.3"
SLOT="0"
diff --git a/dev-python/beautifulsoup/beautifulsoup-3.0.3.ebuild b/dev-python/beautifulsoup/beautifulsoup-3.0.3.ebuild
new file mode 100644
index 000000000000..8a8a6e7d7fd4
--- /dev/null
+++ b/dev-python/beautifulsoup/beautifulsoup-3.0.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/beautifulsoup-3.0.3.ebuild,v 1.1 2006/06/07 18:47:48 marienz Exp $
+
+inherit distutils
+
+MY_P=${P/beautifulsoup/BeautifulSoup}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="HTML/XML parser for quick-turnaround applications like screen-scraping."
+HOMEPAGE="http://www.crummy.com/software/BeautifulSoup/"
+SRC_URI="http://www.crummy.com/software/BeautifulSoup/download/${MY_P}.tar.gz"
+
+LICENSE="PSF-2.3"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.2"
+RDEPEND="${DEPEND}"
+
+
+src_test() {
+ "${python}" BeautifulSoupTests.py || die "tests failed"
+}
diff --git a/dev-python/beautifulsoup/files/digest-beautifulsoup-3.0.3 b/dev-python/beautifulsoup/files/digest-beautifulsoup-3.0.3
new file mode 100644
index 000000000000..e64abf960d19
--- /dev/null
+++ b/dev-python/beautifulsoup/files/digest-beautifulsoup-3.0.3
@@ -0,0 +1,3 @@
+MD5 7b788918e887b6b2c1bfef28ca4eb0d1 BeautifulSoup-3.0.3.tar.gz 27018
+RMD160 ca7128e9613f3bd3e1036db3524e5ea7648107b2 BeautifulSoup-3.0.3.tar.gz 27018
+SHA256 e5854807854a05da21357c2b88d26866251298beeb8734a0ef7a4b9132b9b048 BeautifulSoup-3.0.3.tar.gz 27018