summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-01-28 19:55:27 +0000
committerMike Gilbert <floppym@gentoo.org>2012-01-28 19:55:27 +0000
commit58e834c83da462f0fb7983ff40c53254ce31c595 (patch)
tree48e10908e4dba727542bd884aa4a93c100e22455 /dev-python
parentia64/sparc/x86 stable wrt #401093 (diff)
downloadgentoo-2-58e834c83da462f0fb7983ff40c53254ce31c595.tar.gz
gentoo-2-58e834c83da462f0fb7983ff40c53254ce31c595.tar.bz2
gentoo-2-58e834c83da462f0fb7983ff40c53254ce31c595.zip
Prepare for PYTHON_ABI-versioned Boost Python libraries in Boost 1.48. Patch by Arfrever.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pycuda/ChangeLog9
-rw-r--r--dev-python/pycuda/pycuda-2011.2.2-r1.ebuild57
-rw-r--r--dev-python/pycuda/pycuda-2011.2.2.ebuild6
-rw-r--r--dev-python/pycuda/pycuda-9999.ebuild55
4 files changed, 94 insertions, 33 deletions
diff --git a/dev-python/pycuda/ChangeLog b/dev-python/pycuda/ChangeLog
index fc506045e03a..e8aa2a0cb7e1 100644
--- a/dev-python/pycuda/ChangeLog
+++ b/dev-python/pycuda/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pycuda
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycuda/ChangeLog,v 1.13 2012/01/10 16:16:58 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycuda/ChangeLog,v 1.14 2012/01/28 19:55:27 floppym Exp $
+
+*pycuda-2011.2.2-r1 (28 Jan 2012)
+
+ 28 Jan 2012; Mike Gilbert <floppym@gentoo.org> +pycuda-2011.2.2-r1.ebuild,
+ pycuda-2011.2.2.ebuild, pycuda-9999.ebuild:
+ Prepare for PYTHON_ABI-versioned Boost Python libraries in Boost 1.48. Patch
+ by Arfrever.
*pycuda-2011.2.2 (10 Jan 2012)
diff --git a/dev-python/pycuda/pycuda-2011.2.2-r1.ebuild b/dev-python/pycuda/pycuda-2011.2.2-r1.ebuild
new file mode 100644
index 000000000000..f6e57d5ce535
--- /dev/null
+++ b/dev-python/pycuda/pycuda-2011.2.2-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycuda/pycuda-2011.2.2-r1.ebuild,v 1.1 2012/01/28 19:55:27 floppym Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
+
+inherit distutils multilib
+
+DESCRIPTION="Python wrapper for NVIDIA CUDA"
+HOMEPAGE="http://mathema.tician.de/software/pycuda/ http://pypi.python.org/pypi/pycuda"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples opengl"
+
+RDEPEND=">=dev-libs/boost-1.48[python]
+ dev-python/decorator
+ dev-python/numpy
+ dev-python/pytools
+ dev-util/nvidia-cuda-toolkit
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}"
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+
+src_configure() {
+ local myopts=()
+ use opengl && myopts+=(--cuda-enable-gl)
+
+ configuration() {
+ "$(PYTHON)" configure.py \
+ --boost-inc-dir="${EPREFIX}/usr/include" \
+ --boost-lib-dir="${EPREFIX}/usr/$(get_libdir)" \
+ --boost-python-libname=boost_python-${PYTHON_ABI}-mt \
+ --boost-thread-libname=boost_thread-mt \
+ --cuda-root="${EPREFIX}/opt/cuda" \
+ --cudadrv-lib-dir="${EPREFIX}/usr/$(get_libdir)" \
+ --cudart-lib-dir="${EPREFIX}/opt/cuda/$(get_libdir)" \
+ --no-use-shipped-boost \
+ "${myopts[@]}"
+ }
+ python_execute_function -s configuration
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/dev-python/pycuda/pycuda-2011.2.2.ebuild b/dev-python/pycuda/pycuda-2011.2.2.ebuild
index 1ced86c13715..6d7021bc814d 100644
--- a/dev-python/pycuda/pycuda-2011.2.2.ebuild
+++ b/dev-python/pycuda/pycuda-2011.2.2.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycuda/pycuda-2011.2.2.ebuild,v 1.1 2012/01/10 16:16:58 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycuda/pycuda-2011.2.2.ebuild,v 1.2 2012/01/28 19:55:26 floppym Exp $
EAPI=4
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
inherit distutils multilib
@@ -20,7 +20,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="examples opengl"
RDEPEND="
- dev-libs/boost[python]
+ <dev-libs/boost-1.48[python]
dev-python/decorator
dev-python/numpy
dev-python/pytools
diff --git a/dev-python/pycuda/pycuda-9999.ebuild b/dev-python/pycuda/pycuda-9999.ebuild
index 3d209386b678..414be4ae3be5 100644
--- a/dev-python/pycuda/pycuda-9999.ebuild
+++ b/dev-python/pycuda/pycuda-9999.ebuild
@@ -1,17 +1,16 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycuda/pycuda-9999.ebuild,v 1.9 2012/01/10 16:16:58 jlec Exp $
-
-EAPI=4
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycuda/pycuda-9999.ebuild,v 1.10 2012/01/28 19:55:27 floppym Exp $
+EAPI="4"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
-inherit git-2 distutils multilib
+inherit distutils git-2 multilib
DESCRIPTION="Python wrapper for NVIDIA CUDA"
-HOMEPAGE="http://mathema.tician.de/software/pycuda/ http://pypi.python.org/pypi/pycuda/"
+HOMEPAGE="http://mathema.tician.de/software/pycuda/ http://pypi.python.org/pypi/pycuda"
SRC_URI=""
EGIT_REPO_URI="http://git.tiker.net/trees/pycuda.git"
EGIT_HAS_SUBMODULES="True"
@@ -21,8 +20,7 @@ SLOT="0"
KEYWORDS=""
IUSE="examples opengl"
-RDEPEND="
- dev-libs/boost[python]
+RDEPEND=">=dev-libs/boost-1.48[python]
dev-python/decorator
dev-python/numpy
dev-python/pytools
@@ -30,37 +28,36 @@ RDEPEND="
opengl? ( virtual/opengl )"
DEPEND="${RDEPEND}"
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+
src_unpack() {
git-2_src_unpack
}
src_configure() {
- local myopts=""
- use opengl && myopts="${myopts} --cuda-enable-gl"
-
- ./configure.py \
- --cuda-root="${ROOT}opt/cuda" \
- --boost-lib-dir="${EPREFIX}/usr/$(get_libdir)" \
- --boost-inc-dir="${EPREFIX}/usr/include" \
- --cudadrv-lib-dir="${EPREFIX}/usr/$(get_libdir)" \
- --cudart-lib-dir="${EPREFIX}/opt/cuda/$(get_libdir)" \
- --boost-python-libname=boost_python-mt \
- --boost-thread-libname=boost_thread-mt \
- --no-use-shipped-boost \
- ${myopts}
+ local myopts=()
+ use opengl && myopts+=(--cuda-enable-gl)
+
+ configuration() {
+ "$(PYTHON)" configure.py \
+ --boost-inc-dir="${EPREFIX}/usr/include" \
+ --boost-lib-dir="${EPREFIX}/usr/$(get_libdir)" \
+ --boost-python-libname=boost_python-${PYTHON_ABI}-mt \
+ --boost-thread-libname=boost_thread-mt \
+ --cuda-root="${EPREFIX}/opt/cuda" \
+ --cudadrv-lib-dir="${EPREFIX}/usr/$(get_libdir)" \
+ --cudart-lib-dir="${EPREFIX}/opt/cuda/$(get_libdir)" \
+ --no-use-shipped-boost \
+ "${myopts[@]}"
+ }
+ python_execute_function -s configuration
}
src_install() {
distutils_src_install
- insinto /usr/share/doc/${PF}
- if use examples; then
- doins -r examples || die
- fi
-}
-pkg_postinst() {
- distutils_pkg_postinst
if use examples; then
- elog "Some of the examples provided by this package require dev-python/matplotlib."
+ insinto /usr/share/doc/${PF}
+ doins -r examples
fi
}